Topic: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

I have been using Alex Rabe's NextGEN Gallery on www.ohiocichlid.com for quite some time with good success. Recently I upgraded the site with NextGEN FlashViewer, but found out that the free version can display a maximum of 50 images per gallery.  Since some of my galleries have close to 200 images, I purchased Simple Viewer Pro 2.0.1, and replaced the free version of simpleviewer.swf on my site with the one that comes with Simple Viewer Pro 2.0.1.  Unfortunately my galleries still display a maximum of 50 images.  See eg:

http://www.ohiocichlid.com/oca-extravag … 09-gallery

It contains 192 images, but shows only 50 in the gallery view.

What am I doing wrong?  Many thanks

Frank

Re: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

50 image is the limit for the standard version of the SimpleViewer.swf. I would delete the file on the server and re-upload the pro version.

Mike Richards
SimpleViewer Support Team.

Re: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

You were right.  It seems like I was still using the free viewer instead of the pro version.  I found that out by deleting all the swf files on the server - no gallery view.  I then uploaded only simpleviewer.swf that came with the pro version - still no gallery view.  I then renamed that file to viewer.swf, and got a gallery view back, although a very distorted one:

http://www.ohiocichlid.com/oca-extravag … 09-gallery

I found that surprising since I use the tag:

[simpleviewer id="13" width="450" height="750"]

to display a gallery.

Where can I configure the look of my galleries now in order to make them look decent again.  The settings I choose in the Wordpress admin area under Gallery don't seem to affect the current gallery view  hmm

Many thanks

Frank

Last edited by fmueller (2010-02-17 03:10:12)

Re: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

Some more info:

1. The full screen view of the galleries actually looks good.  Just on the page they seem centered without taking the Wordpress sidebar into account.  Part of the thumbnails are covered by the sidebar, and the image at the top is scaled down almost to thumbnail size. 

2. I replaced the Pro 2.0.1 viewer with the Pro 1.9 viewer that also comes in the zip file.  With the 1.0 viewer the gallery view on the page is fine.  Everything is centered as it should be in the column left of the sidebar.  However, the Pro 1.9 viewer doesn't seen to provide a full screen view making it not a feasible option either.

3.  I upgraded to the latest version of Wordpress (2.9.2) tonight, to see if that woudl help.  Unfortunately the problem persists. 

Grateful for any help!

Re: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

Hi,

the issues you are experiencing are due to the fact that the NextGen plugin is not currently compatible with SimpleViewer v2.0.

To fix the positioning weirdness, set 'titlePosition' and 'captionPosition' to 'NONE'. The issue is that there is white text description to the left of the gallery, causing everything to be shifted over.

Felix Turner
SimpleViewer Support Team.

Re: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

> the issues you are experiencing are due to the fact that the NextGen plugin is not currently compatible with SimpleViewer v2.0.

Ah - I didn't know that.  Thanks!

> The issue is that there is white text description to the left of the gallery, causing everything to be shifted over.

Makes sense!

> To fix the positioning weirdness, set 'titlePosition' and 'captionPosition' to 'NONE'.

Where do I find these parameters???

Many thanks

Frank

Re: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

You can set SimpleViewer config options either via XML or HTML: http://www.simpleviewer.net/simpleviewe … tions.html

Felix Turner
SimpleViewer Support Team.

Re: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

Maybe I am a bit daft, but I still don't get it.  I tried the XML route and modified the beginning of the gallery.xml file that came with SimpleViewer Pro 2.0.1 to read:

<?xml version="1.0" encoding="UTF-8"?>

<simpleviewergallery titlePosition="NONE" captionPosition="NONE" title="SimpleViewer-Pro Gallery">

Unfortunately there was no gallery.xml file to be found on my server.  I put it in the same folder as viewer.swf, but it had no effect on my galleries.

I then tried the HTML route, and used:

[simpleviewer id="15" width="450" height="750" titlePosition="NONE" captionPosition="NONE"]

on my page to insert a gallery instead of just:

[simpleviewer id="15" width="450" height="750"]

That also had no effect on that particular gallery.

What am I doing wrong?

Many thanks in advance

Frank

Last edited by fmueller (2010-02-22 03:42:44)

Re: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

I have been using Alex Rabe's NextGEN Gallery on www.ohiocichlid.com for quite some time with good success. Recently I upgraded the site with NextGEN FlashViewer...  ...Unfortunately there was no gallery.xml file to be found on my server.

If you are using NextGEN FlashViewer you will probably need to either set the properties in its menus or edit the plugin to use these settings.

Mike Richards
SimpleViewer Support Team.

Re: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

Many thanks for all your advice!  I finally got it working.  In case anybody else has a similar problem, you need to edit the file simpleviewer.php, which can be found under:

/wp-content/plugins/nextgen-flashviewer/xml/

Note, the directory is called XML, but the file is a PHP file, not an XML file! 

Right at the beginning of the file simpleviewer.php is the tag <simpleviewerGallery>.  You can use that tag to set all the SimpleViewer config options Felix eluded to earlier in this thread. 

The tag usually draws settings from ngg_fv_options, but I don't know where they are stored.  You can influence the settings in ngg_fv_options via the menus in /wp-admin/admin.php?page=nggallery-flashviewer.  The settings not in ngg_fv_options (like for example titlePosition and captionPosition that I needed), you can set directly by editing simpleviewer.php; eg:

<simpleviewerGallery titlePosition="NONE" captionPosition="NONE">.  That did the trick for me!   cool

Many thanks for bearing with me!

Frank

Last edited by fmueller (2010-02-22 22:21:01)

Re: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

Thanks for posting your solution.

Felix Turner
SimpleViewer Support Team.

Re: Simple Viewer Pro 2.0.1 not showing more than 50 images in gallery

Thanks  for posting the fix-- I'll try it.

I previously had a NetGEN gallery running through Simpleviewer - which was perfect for my needs. I sadly wiped it out when I upgraded Simpleviewer. I was very disappointed that I seem to have to re-upload all my images though a post to create a new gallery. How awkward is that?

And assuming this works, of course, editing the simpleviewer files as described this means that the fix will be knocked out again on the next upgrade - I don't want to have to go thorough that each time!

*****

Nope -- looks like I'm SOL. I don't have the file described. I'm not using the flash viewer - just a plain old NetGEN Gallery. In the earlier Simpleviewer I just gave teh shortcode the name of the gallery and it worked. This is one case where downgrading looks appealing. I don't want to have to re-upload everything to use this

Last edited by gzip (2010-12-28 02:38:38)