Topic: Another problem with the background-image

Hey guys!

I have a problem with the background-image. When I open the page directly form my editor (using webocton-scriptly) it shows the background-image, but if I double-click on the index.html there is no background-image. Here is my index.html:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
    <head>
        <title>SimpleViewer Gallery</title>
        <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
        <link rel="shortcut icon" href="favicon.ico" />
        <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
        <script type="text/javascript">
            var flashvars = {};
            flashvars.galleryURL = "gallery.xml";
            var params = {};
            params.allowfullscreen = true;
            params.allowscriptaccess = "always";
            params.bgcolor = "222222";
            swfobject.embedSWF("simpleviewer.swf", "flashContent", "100%", "100%", "9.0.124", false, flashvars, params);
        </script>

        <style type="text/css" media="screen">
            html, body    { height:100%; }
            body {
                margin:0;
                padding:0;
                overflow:auto;
                background-color: #222;
                background-image: url(http://www.poolueberdachung.de/files/pictures/hintergrund2.jpg);
                color:#666;
                font-family:sans-serif;
                font-size:20px;
            }
            a {
                color:#ff0000;
            }
        </style>

    </head>
<body background="http://www.poolueberdachung.de/files/pictures/hintergrund2.jpg"><div id="flashContent">SimpleViewer requires JavaScript and the Flash Player. <a href="http://get.adobe.com/flashplayer/">Get Flash</a></div></body>
</html>

Sorry if this problem was already solved, but I didnt find it on the forum, I just found similiar questions and answers, but the did not help me.

Thank all of you very much in advance.


Fish

Edith says: It does not matter if I try to open the index.html with ie, firefox, opera, safari etc.....

Last edited by megaf1sh (2010-02-19 14:03:58)

Re: Another problem with the background-image

okay solved.....


i had to add:

params.wmode="transparent";

before

swfobject.embedSWF.....

but now it looks very weird and not like in the editor-preview.... sad

Re: Another problem with the background-image

You can also try loading in the background image by using the SimpleViewer-Pro background image options: http://www.simpleviewer.net/simpleviewe … .html#back

Felix Turner
SimpleViewer Support Team.