Topic: can not embed simpleviewer into existing html page in dreamweaver

I have tried everything. I've been trying to do this since 3pm today. It's now 1 am. I have read every related post on this forum and tried every single thing that has been suggested and i do not understand why it wont work.

All I am trying to do is embed the simple flickr gallery viewer into a page that already exists. I am trying to put it inside a frame, so that might make it trickier, but i've done everything everyone else who used frames suggested. Nothing works. All i get to show up is "SimpleViewer requires JavaScript and the Flash Player. Get Flash."

So i thought maybe my flash plug in isnt working, so i re-downloaded and installed flash and it still doesn't work. I tried it on 3 different browsers and it still doesn't work. What could possibly be wrong? How can it be this complicated?!

This is the page i'm trying to put it on:
http://www.heatherrosestudios.com/heath … graphy.htm


I've tried moving all the files around, as various people have suggested, i've been uploading it to my host the whole time, so it's not because it just wont show up in the preview in dreamweaver, so what am I doing wrong?

someone please help. This is turning out to be way more complicated than it should be.

Re: can not embed simpleviewer into existing html page in dreamweaver

This the code you are using to embed simpleviewer.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3c.org/TR/1999/REC-html401-19991224/loose.dtd">
<!-- saved from url=(0072)file://C:\Users\Heather\website_hrs\heatherrosestudios_files\ts20091.htm -->
<!-- saved from url=(0071)file://C:\Users\Heather\website templates\brandimilne_files\ts20091.htm --><!-- saved from url=(0038)http://www.brandimilne.com/ts20091.htm --><HTML><HEAD><TITLE>Untitled Document</TITLE>
<META http-equiv=Content-Type content="text/html; charset=iso-8859-1">
<STYLE type=text/css>.style33 {
    FONT-FAMILY: Chalet-ParisNineteenSeventy
}
A:link {
    TEXT-DECORATION: none
}
A:visited {
    TEXT-DECORATION: none
}
A:hover {
    TEXT-DECORATION: none
}
A:active {
    TEXT-DECORATION: none
}
</STYLE>

<META content="MSHTML 6.00.6000.16830" name=GENERATOR>
<script src="DWConfiguration/ActiveContent/IncludeFiles/AC_ActiveX.js" type="text/javascript"></script>
<script src="../../../Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
</HEAD>
<BODY>
<script type="text/javascript" src="swfobject.js"></script>

<div id="flashcontent">SimpleViewer requires JavaScript and the Flash Player. 
<a href="http://www.macromedia.com/go/getflashplayer/">Get Flash.</a></div>
<script type="text/javascript">
var fo = new SWFObject("viewer.swf", "viewer", "800", "600", "8", "#181818");
fo.write("flashcontent");    
</script>

</BODY></HTML>

It is located at heatherrosestudios.com/heatherrosestudios_files/photography/photography_files/ts20091.htm

Where are the swfobject.js, gallery.xml, image folder, thumb folder and simpleviewer.swf lactated on your server?

Mike Richards
SimpleViewer Support Team.

Re: can not embed simpleviewer into existing html page in dreamweaver

I tried putting all of those files in the folder that contains the ts20091.htm file and it didn't work. So i tried putting them in the folder that is inside that folder (which is named "ts20091_files" that is how i have all the other pages set up, they each have their own folder that holds their files) and that didn't work either.

This is the page i used most recently to get the code: http://www.simpleviewer.net/simpleviewe … /embedded/


is there another way to do it? Or am I still just doing something wrong?


edit:

also, I just tried uploading the index.html file that is included in the folder, and that doesn't even work. nothing shows up, it's just a blank page. I didn't even change anything on that page.

Last edited by HeatherRoseStudios (2010-02-20 20:23:45)

Re: can not embed simpleviewer into existing html page in dreamweaver

Are you using Fetch (an FTP app for Mac) to upload your files? Older versions of Fetch break SWFs on upload. Upgrade Fetch or use a different FTP app, then re-upload your gallery.

Felix Turner
SimpleViewer Support Team.

Re: can not embed simpleviewer into existing html page in dreamweaver

No i'm not using Fetch. I have a pc, not a mac.

I'm not using anything other than dreamweaver. All i am doing is copying the code and pasting it into where it says to paste it. that's all it says to do, that's all i am doing. and it doesn't work. So I tried all the other things people have suggested but still i get the same exact result every time.

can anyone else help me?



edit:

Ok i just deleted all the files, and code, and everything, and started over.

Now.... The "get flash" thing doesn't show up.

Instead, it's just a solid black box. no pictures. no nothing. but atleast there's a box now...
(that was in google chrome)

in firefox, it's nothing. just a blank white page.

in IE, it's also just a black box.

so what am i doing wrong this time?
here's the link again:
http://www.heatherrosestudios.com/heath … graphy.htm

Last edited by HeatherRoseStudios (2010-02-21 01:09:14)

Re: can not embed simpleviewer into existing html page in dreamweaver

The SWF file here does not exist: http://www.heatherrosestudios.com/heath … viewer.swf

Try putting the contents of your SimpleViewer gallery folder in the same folder as your HTML page (in this case it would be http://www.heatherrosestudios.com/heath … ography/).

Felix Turner
SimpleViewer Support Team.

Re: can not embed simpleviewer into existing html page in dreamweaver

I just tried that... still nothing. when i open the page in firefox, it doesn't even say anything. just a white page....

it's been weeks. i don't understand why I can't get this to work.