Topic: Photos are X in firefox

Hi I have a problem when viewing in Firefox.

I Can see the simpleviewer but all the images are X and its only in Firefox. it works fine in IE and in Chrome.

What can i do?

Re: Photos are X in firefox

http://alexander-vega.awardspace.info -> pictures
or
http://alexander-vega.awardspace.info/s … tures.html


| Pitctures.htlm |
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US" xml:lang="en">
<head>
    <!--
    Designed by CompanyName
    Base template (without user's data) checked by http://validator.w3.org : "This page is valid XHTML 1.0 Transitional"
    -->
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
   
    <title>Your Company Name | AllFreeTemplates.info free templates </title>

<script type="text/javascript" src="../script.js"></script>
<script src="../Scripts/swfobject_modified.js" type="text/javascript"></script>
<link rel="stylesheet" href="../style.css" type="text/css" media="screen" />
    <!--[if IE 6]><link rel="stylesheet" href="style.ie6.css" type="text/css" media="screen" /><![endif]-->
    <!--[if IE 7]><link rel="stylesheet" href="style.ie7.css" type="text/css" media="screen" /><![endif]-->
</head>
<body>
    <div class="art-contentLayout">
   <iframe src="web/index.html" name="iframe" width="884" height="400" align="left" scrolling="No" frameborder="0" id="iframe"></iframe>
            </div>
<div class="cleared"></div>
          </div>
        </div>
<p class="art-page-footer">&nbsp;</p>
    </div>

</body>
</html>
___________________

| Index.html *simpleviewer |

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
    <head>
        <title>SimpleViewer Gallery</title>
        <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
        <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
        <script type="text/javascript">
            var flashvars = {};
            flashvars.galleryURL = "gallery.xml";
            var params = {};           
            params.allowfullscreen = true;
            params.allowscriptaccess = "always";
            params.bgcolor = "222222";
            swfobject.embedSWF("simpleviewer.swf", "flashContent", "100%", "100%", "9.0.124", false, flashvars, params);
        </script>
       
        <style type="text/css" media="screen">   
            html, body    { height:100%; }
            body {           
                margin:0;
                padding:0;
                overflow:auto;
                background-color: #222;
                color:#666;
                font-family:sans-serif;
                font-size:20px;       
            }
            a {   
                color:#ff0000;   
            }
        </style>
       
    </head><body><div id="flashContent">SimpleViewer requires JavaScript and the Flash Player. <a href="http://get.adobe.com/flashplayer/">Get Flash</a></div></body>
</html>
____________________________

| gallery.xml |<?xml version="1.0" encoding="UTF-8"?>

<simpleviewergallery
   
    galleryStyle="Classic"
    title="Alexander"
    textColor="FFFFFF"
    frameColor="FFFFFF"
    frameWidth="5"
    thumbPosition="left"
    thumbColumns="3"
    thumbRows="3"
    showOpenButton="TRUE"
    showFullscreenButton="TRUE"   
    maxImageWidth="884"
    maxImageHeight="400"
    useFlickr="false"
    flickrUserName=""
    flickrTags=""
    languageCode="AUTO"
    languageList=""       
    imagePath="images/"
    thumbPath="thumbs/"
   
>

<image imageURL="images/01.jpg" thumbURL="thumbs/01.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/02.jpg" thumbURL="thumbs/02.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/03.jpg" thumbURL="thumbs/03.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/04.jpg" thumbURL="thumbs/04.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/05.jpg" thumbURL="thumbs/05.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/06.jpg" thumbURL="thumbs/06.jpg" linkURL="" linkTarget="">
    <caption>
    </caption>   
</image>
<image imageURL="images/07.jpg" thumbURL="thumbs/07.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/08.jpg" thumbURL="thumbs/08.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/09.jpg" thumbURL="thumbs/09.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/10.jpg" thumbURL="thumbs/10.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/11.jpg" thumbURL="thumbs/11.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/12.jpg" thumbURL="thumbs/12.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/13.jpg" thumbURL="thumbs/13.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/14.jpg" thumbURL="thumbs/14.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   
</image>
<image imageURL="images/15.jpg" thumbURL="thumbs/15.jpg" linkURL="" linkTarget="" >
    <caption>
    </caption>   

</image>
</simpleviewergallery>

_________________________

Re: Photos are X in firefox

There seems to be something strange about your web host setup. If you try to load one of the image files directly, you get an error: http://alexander-vega.awardspace.info/s … ges/01.jpg

Felix Turner
SimpleViewer Support Team.

Re: Photos are X in firefox

Felix wrote:

There seems to be something strange about your web host setup. If you try to load one of the image files directly, you get an error: http://alexander-vega.awardspace.info/s … ges/01.jpg


I'm kind of new with this and i do not know what to look for at the host setup. Can it just be something easy on the setup that makes the pictures not show on just firefox? What should i look for at the host setup?

Re: Photos are X in firefox

Are you sure you uploaded your images and thumbs folders?

Mike Richards
SimpleViewer Support Team.

Re: Photos are X in firefox

miker wrote:

Are you sure you uploaded your images and thumbs folders?


yes i shure. I'm sure because it works fine on other broswers.

Re: Photos are X in firefox

Looking at the HTML code it looks like you have 3 close div tags, </div> that shouldn't be there on lines 24, 25 and 27. I'm guessing this may be part of your issue.

http://validator.w3.org/check?uri=http% … 67#line-21

1.  <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
   2. <html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US" xml:lang="en">
   3. <head>
   4. <!--
   5. Designed by CompanyName
   6. Base template (without user's data) checked by http://validator.w3.org : "This page is valid XHTML 1.0 Transitional"
   7. -->
   8. <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
   9. <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
  10.
  11. <title>Your Company Name | AllFreeTemplates.info free templates </title>
  12.
  13. <script type="text/javascript" src="../script.js"></script>
  14. <script src="../Scripts/swfobject_modified.js" type="text/javascript"></script>
  15. <link rel="stylesheet" href="../style.css" type="text/css" media="screen" />
  16. <!--[if IE 6]><link rel="stylesheet" href="style.ie6.css" type="text/css" media="screen" /><![endif]-->
  17. <!--[if IE 7]><link rel="stylesheet" href="style.ie7.css" type="text/css" media="screen" /><![endif]-->
  18. </head>
  19. <body>
  20. <div class="art-contentLayout">
  21. <iframe src="web/index.html" name="iframe" width="884" height="400" align="left" scrolling="No" frameborder="0" id="iframe"></iframe>
  22. </div>
  23. <div class="cleared"></div>
  24. </div>
  25. </div>
  26. <p class="art-page-footer">&nbsp;</p>
  27. </div>
  28.
  29. </body>
  30. </html>

Mike Richards
SimpleViewer Support Team.

Re: Photos are X in firefox

miker wrote:

Looking at the HTML code it looks like you have 3 close div tags, </div> that shouldn't be there on lines 24, 25 and 27. I'm guessing this may be part of your issue.

http://validator.w3.org/check?uri=http% … 67#line-21

1.  <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
   2. <html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US" xml:lang="en">
   3. <head>
   4. <!--
   5. Designed by CompanyName
   6. Base template (without user's data) checked by http://validator.w3.org : "This page is valid XHTML 1.0 Transitional"
   7. -->
   8. <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
   9. <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
  10.
  11. <title>Your Company Name | AllFreeTemplates.info free templates </title>
  12.
  13. <script type="text/javascript" src="../script.js"></script>
  14. <script src="../Scripts/swfobject_modified.js" type="text/javascript"></script>
  15. <link rel="stylesheet" href="../style.css" type="text/css" media="screen" />
  16. <!--[if IE 6]><link rel="stylesheet" href="style.ie6.css" type="text/css" media="screen" /><![endif]-->
  17. <!--[if IE 7]><link rel="stylesheet" href="style.ie7.css" type="text/css" media="screen" /><![endif]-->
  18. </head>
  19. <body>
  20. <div class="art-contentLayout">
  21. <iframe src="web/index.html" name="iframe" width="884" height="400" align="left" scrolling="No" frameborder="0" id="iframe"></iframe>
  22. </div>
  23. <div class="cleared"></div>
  24. </div>
  25. </div>
  26. <p class="art-page-footer">&nbsp;</p>
  27. </div>
  28.
  29. </body>
  30. </html>

I did try to eras those but the problem is still there. It works fine on Chrome and IE but not Firefox.
I also empty my casch after updating the html so it just wasn´t my computer that showed me an old file but still no luck sad

_____________

What i just did was copying your simpleviwer "web" folder and just made the Index.html to an Iframe thats links the site to The Index.html inside Web And i still get the same problem. Only X on FireFox and the standard pictures on the other browsers So i do not think the problem lies in your program or the html code. I think it has something to do with my web hosting but i do not know what and i do not know how to fix it.
Any ides ?

Last edited by mattehalen (2010-03-09 02:17:48)

Re: Photos are X in firefox

When you go directly to and image in firefox for example http://alexander-vega.awardspace.info/s … ges/02.jpg you get a 404 not found error. Do you have any hot-linking/image protection turned on? Do the files have the proper server permissions set to be viewed? Did the FTP software you used to upload them some how partially corrupt them? If that does not solve the issue I would contact your hosts support and see what they say.

Mike Richards
SimpleViewer Support Team.

Re: Photos are X in firefox

miker wrote:

When you go directly to and image in firefox for example http://alexander-vega.awardspace.info/s … ges/02.jpg you get a 404 not found error. Do you have any hot-linking/image protection turned on? Do the files have the proper server permissions set to be viewed? Did the FTP software you used to upload them some how partially corrupt them? If that does not solve the issue I would contact your hosts support and see what they say.


I Got this from the webhose:

"Hello Mathias,


Hotlinking of images on our free accounts is not allowed. A flash image gallery uses analagous methods to get the image data. Because this is so, there is little to nothing that we can do about it.

If you really need this image gallery, you should consider upgrading to one of our paid plans.

If you have more questions, please don't hesitate to ask us again, we will be glad to help you out anyway we can.

Best Regards,
John Winston
AwardSpace Dedicated Support Team"

So i guess i need to upgrade before i go further.

Thanks for everything.