Topic: Postcard viewer/pictures not showing

I'm not sure what version of the postcard viewer I have but I downloaded the free version from the web site on April 3/2010.I'm not that great at working with web  pages but I managed to get it working for me when I made a postcard viewer page for my web site using front page 2000.It works fine when i view the finished page in front page but when I up load it to my server and view it on the internet I cant see any picture at all.I can see the background how I changed the color and I can see some font I had put on the top of the page but thats it.I read through the forums and still dont know why its not working since the  pictures are lower case .jpg and did the other checks that were mentioned.Is there anything else you can think of that it might be?

Thank you,Brent

Last edited by Brent (2010-04-04 03:14:12)

Re: Postcard viewer/pictures not showing

What is the URL of your gallery that is having the issues

Mike Richards
SimpleViewer Support Team.

Re: Postcard viewer/pictures not showing

Hello  Miker

Thanks for getting back to me so quickly.The url is
http://www.cramattekennels.com/postcard … _pics.html

I still see it fine when I upload the page onto my server and view it in front page but cannot see the pictures on the  internet.

Thank you ,Brent

Re: Postcard viewer/pictures not showing

The viewer is pulling the image location form gallery.xml, <url>images/tall.jpg</url> so this image should be found at
www.cramattekennels.com/postcardviewer/images/tall.jpg but there is nothing there.

Mike Richards
SimpleViewer Support Team.

Re: Postcard viewer/pictures not showing

I don't understand what to do then.I have my pictures in a folder  named images inside the postcard viewer folder.

I did do one change to see it that would work.I had made a copy of the  index  html document and had that renamed puppy_pics html.I have since taken that out and left the original index html in there.It still is not working, my pictures are not there.

The new url is
http://www.cramattekennels.com/postcard … index.html

Inside my postcard folder is this
images folder with my pictures
index html
viewer shockwave
read me html
swfobject
_vti_cnf
gallery xml


Here is what I see inside my gallery

<?xml version="1.0" encoding="UTF-8" ?>
<gallery cellDimension="800" columns="4" zoomOutPerc="15" zoomInPerc="100" frameWidth="20" frameColor="0xFFFFFF" captionColor="0xFFFFFF" enableRightClickOpen="true" >
<image>
   <url>images/lexi-male-pup.jpg</url>
    <caption>Lexi + Bubbs male pup</caption>
</image>
<image>
   <url>images/murphy.jpg</url>
   <caption>Marly + Rudi male pup</caption>
</image>
<image>
   <url>images/aryan-pups.JPG</url>
   <caption>Arayn + Bubbs male pups</caption>
</image>
<image>
   <url>images/tall.jpg</url>
   <caption>4 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption> 
</image>
<image>
   <url>images/lola-pup2.jpg</url>
   <caption>lola + Rudi female pup</caption>
</image>
<image>
   <url>images/aryan-pup.jpg</url>
   <caption>Aryan + Bubbs male pup</caption>
</image>
<image>
   <url>images/lexi-pup.jpg</url>
   <caption>lexi + Bubbs pup</caption>
</image>
<image>
   <url>images/ziggy-pup.jpg</url>
   <caption>Ziggy + Rudi male pup</caption>
</image>
<image>
   <url>images/lucy-pup.jpg</url>
   <caption>Lucy + Bubba female pup</caption>
</image>
<image>
   <url>images/marly-ellie-pup-1wk.jpg</url>
   <caption>Marly + Rudi female pup</caption>
</image>
<image>
   <url>images/murphy-marly-rudi.jpg</url>
   <caption>Marly + Rudi male pup</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>12 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>13 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>14 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>15 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
</gallery>



Thank you..Brent

Last edited by Brent (2010-04-06 23:11:24)

Re: Postcard viewer/pictures not showing

The gallery.xml at http://www.cramattekennels.com/postcard … allery.xml does not match the one you posted.

<?xml version="1.0" encoding="UTF-8" ?>
<gallery cellDimension="800" columns="4" zoomOutPerc="15" zoomInPerc="100" frameWidth="20" frameColor="0xFFFFFF" captionColor="0xFFFFFF" enableRightClickOpen="true" >
<image>
   <url>images/tall.jpg</url>
    <caption><![CDATA[Captions can be HTML formatted. Supported tags are linebreaks<br> <u>underline</u>, <u><a href="http://www.google.com" target="_blank">hyperlinks</a></u>,  and <font color="#ffff00" size="40">font tags</font>. Italics and bold are not supported.]]></caption>
</image>
<image>
   <url>images/tall.jpg</url>
   <caption><![CDATA[Captions can be HTML formatted. Supported tags are linebreaks<br> <u>underline</u>, <u><a href="http://www.google.com" target="_blank">hyperlinks</a></u>,  and <font color="#ffff00" size="40">font tags</font>. Italics and bold are not supported.]]></caption>
</image>
<image>

   <url>images/tall.jpg</url>
   <caption><![CDATA[Captions can be HTML formatted. Supported tags are linebreaks<br> <u>underline</u>, <u><a href="http://www.google.com" target="_blank">hyperlinks</a></u>,  and <font color="#ffff00" size="40">font tags</font>. Italics and bold are not supported.]]></caption>
</image>
<image>
   <url>images/tall.jpg</url>
   <caption>4 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>  
</image>
<image>
   <url>images/wide.jpg</url>

   <caption>5 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>6 ellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>7 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>

</image>
<image>
   <url>images/wide.jpg</url>
   <caption>8 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>9 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>

<image>
   <url>images/wide.jpg</url>
   <caption>10 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>11 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>

   <url>images/wide.jpg</url>
   <caption>12 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>13 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>

   <caption>14 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>15 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
</gallery>
Mike Richards
SimpleViewer Support Team.

Re: Postcard viewer/pictures not showing

miker wrote:

The gallery.xml at http://www.cramattekennels.com/postcard … allery.xml does not match the one you posted.

<?xml version="1.0" encoding="UTF-8" ?>
<gallery cellDimension="800" columns="4" zoomOutPerc="15" zoomInPerc="100" frameWidth="20" frameColor="0xFFFFFF" captionColor="0xFFFFFF" enableRightClickOpen="true" >
<image>
   <url>images/tall.jpg</url>
    <caption><![CDATA[Captions can be HTML formatted. Supported tags are linebreaks<br> <u>underline</u>, <u><a href="http://www.google.com" target="_blank">hyperlinks</a></u>,  and <font color="#ffff00" size="40">font tags</font>. Italics and bold are not supported.]]></caption>
</image>
<image>
   <url>images/tall.jpg</url>
   <caption><![CDATA[Captions can be HTML formatted. Supported tags are linebreaks<br> <u>underline</u>, <u><a href="http://www.google.com" target="_blank">hyperlinks</a></u>,  and <font color="#ffff00" size="40">font tags</font>. Italics and bold are not supported.]]></caption>
</image>
<image>

   <url>images/tall.jpg</url>
   <caption><![CDATA[Captions can be HTML formatted. Supported tags are linebreaks<br> <u>underline</u>, <u><a href="http://www.google.com" target="_blank">hyperlinks</a></u>,  and <font color="#ffff00" size="40">font tags</font>. Italics and bold are not supported.]]></caption>
</image>
<image>
   <url>images/tall.jpg</url>
   <caption>4 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>  
</image>
<image>
   <url>images/wide.jpg</url>

   <caption>5 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>6 ellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>7 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>

</image>
<image>
   <url>images/wide.jpg</url>
   <caption>8 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>9 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>

<image>
   <url>images/wide.jpg</url>
   <caption>10 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>11 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>

   <url>images/wide.jpg</url>
   <caption>12 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>13 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>

   <caption>14 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
<image>
   <url>images/wide.jpg</url>
   <caption>15 Pellentesque turpis leo, dignissim ac, vestibulum quis, hendrerit quis, enim.</caption>
</image>
</gallery>

Re: Postcard viewer/pictures not showing

I'm starting to get more and more lost now.I have everything as it is it the folder when I downloaded the postcarviewer program.All I did was make a  hyper link to the Index html in that  folder,is that wronge?All of my pictures are in the  images folder and  have put thier jpg names and captions in the  gallery.My url is below.

http://www.cramattekennels.com/postcard … index.html

Was I supposed to make the hyper link go to my gallery xml?

Re: Postcard viewer/pictures not showing

To view the gallery you should be viewing the html, however the XML is what tells the postcardviewer.swf what images to load and the XML on your server is not pointing to any images on your server. How did you create your postcard gallery? Did you use one of these methods?

Mike Richards
SimpleViewer Support Team.

Re: Postcard viewer/pictures not showing

Sure wish some one would answer this post,I am so close to getting this to work now.

I  opened the  gallery with note pad . I edited the text and put my .jpg picture names in where it was supposed to go and the caption where it was supposed to go.Was I supposed to enter something else in the gallery note pad toi make the xml file point to the images on my server?My gallery folder looks like this below., Or am I supposed to add something in the index.html file to male the xml file point to the images on my server?

<?xml version="1.0" encoding="UTF-8" ?>
<gallery cellDimension="800" columns="4" zoomOutPerc="15" zoomInPerc="100" frameWidth="20" frameColor="0xFFFFFF" captionColor="0xFFFFFF" enableRightClickOpen="true">
<image>
   <url>images/lexi-male-pup.jpg</url>
    <caption>Lexi + Bubbs male pup</caption>
</image>
<image>
   <url>images/murphy.jpg</url>
   <caption>Marly + Rudi male pup</caption>
</image>
<image>
   <url>images/aryan-pups.JPG</url>
   <caption>Arayn + Bubbs male pups</caption>
</image>
--------------------------------------------------------------------------------------
index.html looks like below,


<!-- saved from url=(0014)about:internet -->
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>PostcardViewer</title>
<!-- Download PostcardViewer at www.airtightinteractive.com/projects/postcardviewer -->
<script type="text/javascript" src="swfobject.js"></script>
<style type="text/css">   
    /* hide from ie on mac \*/
    html {
        height: 100%;
        overflow: hidden;
    }   
    #flashcontent {
        height: 100%;
    }
    /* end hide */
    body {
        height: 100%;
        margin: 0;
        padding: 0;
        background-color: #000000;
        color:#ffffff;
        font-family:sans-serif;
        font-size:40;
    }   
    a {   
        color:#cccccc;
    }
</style>
</head>
<body>




                    <p align="center"><font size="3"><br>
                    </font>
                    <font color="#FF0000" face="Forte" size="6">Cramatte Kennels</font><font size="3"><br>
                    <img border="0" src="../images/bullet_11.gif" width="15" height="15">
                    &nbsp; </font><font size="2">Click on any thumbnail picture to make it go larger,
                    click again any where on the screen to go back</font>
    <div id="flashcontent"><font size="3">PostcardViewer requires JavaScript and the Flash Player. <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash here.</a> </font> </div>   
    <script type="text/javascript">
        var fo = new SWFObject("viewer.swf", "viewer", "100%", "100%", "8", " #000000");       
               
        //Optional Configuration
        //fo.addVariable("langOpenImage", "Open Image in New Window");
        //fo.addVariable("langAbout", "About");   
        //fo.addVariable("xmlURL", "gallery.xml");                   
       
        fo.write("flashcontent");   
       
    </script>   
</body>
</html>

Last edited by Brent (2010-04-09 05:25:31)

Re: Postcard viewer/pictures not showing

it looks like you still have the wrong gallery.xml on the server. I would try deleting the one on the server and upload again the you made changes too.

Mike Richards
SimpleViewer Support Team.

Re: Postcard viewer/pictures not showing

I took the gallery .xml file out of my postcard viewer and  dragged it onto my desk top.Then I uploaded my web site to my server, once the changes took place I put the gallery xml file back into the postcard viewer and up loaded my web site again to the server.I then checked out my web site on the internet and still no pictures are showing.I can see how I changed the back ground color and put some font on top of the page still but now I see something new on the page.It says gallery xml file not found ,just like what you,ve been telling me, but what do I  do now to fix this?Like I mentioned before I did contact where I have my web site on thier server and they said things are fine  on thier end.

http://www.cramattekennels.com/postcard … index.html

Re: Postcard viewer/pictures not showing

Hello Mike,

Thank you for getting back to me so quickly.

That is what I did,I took the XML file out of the  postcard viewer folder and then up loaded my web site again.Then once that was done I put the XML file back into the post card viewer folder and uploaded my web site to the server.

Re: Postcard viewer/pictures not showing

Yeah sorry, my browser apparently didn't refresh to the new version. Looking at the XML it seems to have an XML error.

XML Parsing Error: XML or text declaration not at start of entity
Location: http://www.cramattekennels.com/postcard … allery.xml
Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8" ?>
^

Try replacing it with this.

<?xml version="1.0" encoding="UTF-8" ?>
<gallery cellDimension="800" columns="4" zoomOutPerc="15" zoomInPerc="100" frameWidth="20" frameColor="0xFFFFFF" captionColor="0xFFFFFF" enableRightClickOpen="true" >
<image>
   <url>images/lexi-male-pup.jpg</url>
    <caption>Lexi + Bubbs male pup</caption>
</image>
<image>
   <url>images/murphy.jpg.jpg</url>
   <caption>Marly + Rudi male pup</caption>

</image>
<image>

   <url>images/aryan-pups.JPG.jpg</url>
   <caption>Marly + Rudi male pup</caption>
</image>
<image>
   <url>images/lola-pup2.jpg</url>
   <caption>Marly + Rudi male pup</caption>

</image>
<image>
   <url>images/lola + Rudi female pup.jpg</url>
   <caption>Marly + Rudi male pup</caption>
</image>
</gallery>
Mike Richards
SimpleViewer Support Team.

Re: Postcard viewer/pictures not showing

Hello Mike,

I did exactlly what you said and I even took the  gallery xml file out and up loaded my site then put it back in and up loaded it again and still no pictures.

I dont know if my url is supposed to have gallery in the end but it doesnt.

http://www.cramattekennels.com/postcard … index.html

Last edited by Brent (2010-04-09 18:27:08)

Re: Postcard viewer/pictures not showing

aryan-pup.jpg
     aryan-pups.jpg
     lexi-male-pup.JPG
     lexi-pup.jpg
     lola-pup2.JPG
     lucy-pup.JPG
     marly-ellie-pup-1wk.jpg
     murphy-marly-rudi.jpg
     murphy.jpg
     ziggy-pup.jpg

These are the images in your images folder on your server, I had just copied the xml code you had listed above thinking it was how you had named your images, but there are some that do not match. You need to fix the image names in the gallery.xml and the .jpg extensions so that they match the file names exactly including matching the case.

Mike Richards
SimpleViewer Support Team.

Re: Postcard viewer/pictures not showing

This is getting very frustrating ,this cant possibly  be this hard.Perhaps not meant for people who are not super smart with computors.

I had seen just one that was not named properly.I have since takin out the pictures from the images file that were not in my gallery.xml file.I have also opened up each picture in my Adobe  photo shop 7 and clicked on the box that says lower case .jpg.Even though I have done this before I had even started with this .I see that my pictures are still JPEG but in the  gallery it is.jpg.Is this normal that after I have changed the pictures to lower case to still be JPEG in my images folder?Maybe it is normal but just thought I would ask since this may be the problem.

I now have just 6 pictures in my images folder and when I view postcardviewer on my computor I see everything just fine.I still have the same problem when I view my web site on the internet, there are no pictures.

Here is how my gallery.XML file looks now

<?xml version="1.0" encoding="UTF-8" ?>
<gallery cellDimension="800" columns="4" zoomOutPerc="15" zoomInPerc="100" frameWidth="20" frameColor="0xFFFFFF" captionColor="0xFFFFFF" enableRightClickOpen="true" >
<image>
   <url>images/lola-pup2.jpg</url>
    <caption>Lola pup</caption>
</image>
<image>
   <url>images/ziggy-pup.jpg</url>
   <caption>Ziggy + Rudi pup pup</caption>

</image>
<image>

   <url>images/aryan-pupps.jpg</url>
   <caption>Aryan + Bubbs pups pups</caption>
</image>
<image>
   <url>images/lexi-pup.jpg</url>
   <caption>Lexi + Bubbs male pup</caption>

</image>
<image>
   <url>images/marly-pup.jpg</url>
   <caption>Marly + Rudi pup</caption>
</image>
<image>
   <url>images/aryan-pup.jpg</url>
   <caption>Aryan female pup</caption>
</image>
</gallery>

-----------------------------------------------------------------------

http://www.cramattekennels.com/postcard … index.html

Last edited by Brent (2010-04-09 21:19:52)

Re: Postcard viewer/pictures not showing

Part of the issue it that you are taking the most difficult rout by producing the gallery manually instead of using one of the automatic scripts.

http://simpleviewer.net/postcardviewer/support/#start

Going to your XML http://www.cramattekennels.com/postcard … allery.xml I looks like this:

<?xml version="1.0" encoding="UTF-8" ?>
<gallery cellDimension="800" columns="4" zoomOutPerc="15" zoomInPerc="100" frameWidth="20" frameColor="0xFFFFFF" captionColor="0xFFFFFF" enableRightClickOpen="true" >
<image>
   <url>images/lexi-male-pup.jpg</url>
    <caption>Lexi + Bubbs male pup</caption>
</image>
<image>
   <url>images/murphy.jpg.jpg</url>
   <caption>Marly + Rudi male pup</caption>

</image>
<image>

   <url>images/aryan-pups.JPG.jpg</url>
   <caption>Marly + Rudi male pup</caption>
</image>
<image>
   <url>images/lola-pup2.jpg</url>
   <caption>Marly + Rudi male pup</caption>

</image>
<image>
   <url>images/lola + Rudi female pup.jpg</url>
   <caption>Marly + Rudi male pup</caption>
</image>
</gallery>

None of those files names match up to what is in the images folder. The following matches up with your what is in your images folder

<?xml version="1.0" encoding="UTF-8" ?>
<gallery cellDimension="800" columns="4" zoomOutPerc="15" zoomInPerc="100" frameWidth="20" frameColor="0xFFFFFF" captionColor="0xFFFFFF" enableRightClickOpen="true" >
<image>
   <url>images/lexi-pup.jpg</url>
    <caption>Lexi + Bubbs male pup</caption>
</image>
<image>
   <url>images/murphy.jpg</url>
   <caption>Marly + Rudi male pup</caption>
</image>
<image>
   <url>images/aryan-pupps.jpg</url>
   <caption>Marly + Rudi male pup</caption>
</image>
<image>
   <url>images/lola-pup2.JPG</url>
   <caption>Marly + Rudi male pup</caption>
</image>
<image>
   <url>ziggy-pup.jpg</url>
   <caption></caption>
</image>
<image>
   <url>marly-pup.jpg</url>
   <caption></caption>
</image>
</gallery>
Mike Richards
SimpleViewer Support Team.

Re: Postcard viewer/pictures not showing

Some thing weird is going on here then because what you are showing how my gallery.XML file is not how it looks over here at all.All my pictures in the image folder do match the gallery.XML here.

You are not seeing what I have  here on my gallery.XML
All of those picture names match perfectly to my photos on the image folder

<?xml version="1.0" encoding="UTF-8" ?>
<gallery cellDimension="800" columns="4" zoomOutPerc="15" zoomInPerc="100" frameWidth="20" frameColor="0xFFFFFF" captionColor="0xFFFFFF" enableRightClickOpen="true" >
<image>
   <url>images/lola-pup2.jpg</url>
    <caption>Lola pup</caption>
</image>
<image>
   <url>images/ziggy-pup.jpg</url>
   <caption>Ziggy + Rudi pup pup</caption>

</image>
<image>

   <url>images/aryan-pupps.jpg</url>
   <caption>Aryan + Bubbs pups pups</caption>
</image>
<image>
   <url>images/lexi-pup.jpg</url>
   <caption>Lexi + Bubbs male pup</caption>

</image>
<image>
   <url>images/marly-pup.jpg</url>
   <caption>Marly + Rudi pup</caption>
</image>
<image>
   <url>images/aryan-pup.jpg</url>
   <caption>Aryan female pup</caption>
</image>
</gallery>

Last edited by Brent (2010-04-10 00:09:36)

Re: Postcard viewer/pictures not showing

I have no idea, I had cleared my browser cache and it was still showing up with the older file. Your gallery is working fine for me now.

Mike Richards
SimpleViewer Support Team.

Re: Postcard viewer/pictures not showing

I asked my web site people where  I have my web site on thier server and they knew what it was right away.It's all fixed now and working fine, thank you very much for all your  help.I really like the postcardviewer on my site.


Thank you ,Brent