Topic: How to alter the embed tag in the swobject script

On my website, I am using a javascript code for a roll over menu.  The roll over function of my menu doesn't work on top of my autoviewer galleries ex:  http://photographybyasiya.com/newborn/index.html in Internet Explorer (IE) and Chrome on a PC. 

The maker of the java script roll over menu suggested i alter the embed tab by setting: wmode="opaque" or wmode="transparent"

In order to make my roll over menu work on top of my flash autoviewer galleries in IE, how can I implement this? 

Thanks for any help in advance!!!

Re: How to alter the embed tag in the swobject script

The code you need is fo.addParam("wmode", "opaque"); or fo.addParam("wmode", "transparent");

<script type="text/javascript">
var fo = new SWFObject("../viewer.swf", "viewer", "975", "395", "8", "#000000");
fo.addParam("wmode", "opaque");
fo.write("flashcontent");
</script>
Mike Richards
SimpleViewer Support Team.

Re: How to alter the embed tag in the swobject script

Hi Mike,
Thanks so much for your response. For some reason, the roll over menu is still not working on IE.  Do you know what could be the cause of this problem and how I could fix it?

Thanks again for your help,
Asiya

Re: How to alter the embed tag in the swobject script

Clear your browser's cache.

Mike Richards
SimpleViewer Support Team.

Re: How to alter the embed tag in the swobject script

I just cleared IE's cache and the problem with the roll over still persists.  Any other advice on how to make Autoviewer and this roll over menu work together?
http://photographybyasiya.com/newborn/index.html

Thanks for your time Mike.

Re: How to alter the embed tag in the swobject script

I actually just got it to work. I change it from addVariable to addParam and it's working!!!

Re: How to alter the embed tag in the swobject script

Woops sorry my mistake, I typed the wrong thing.

Mike Richards
SimpleViewer Support Team.