Topic: Embed simpleviewer isn't as it should

Hi guys smile

I have a sv pro gallery here:
http://www.roelandvanassche.be/Nieuwe_s … viewer.swf

And I would like to embed it, well iframes aren't a solution for me because the gallery is made just the size to fit in a part of a webpage. If I use an iframe I also got the annoying gray areas around it. But I can't find a way to just embed the gallery. I'm using iweb so it should be html... Any solutions?

Thank you so much smile

Thomas

Re: Embed simpleviewer isn't as it should

Have you tried the embed code found here or if you are going to use version 2 use this embed code?

Mike Richards
SimpleViewer Support Team.

Re: Embed simpleviewer isn't as it should

Yes but I have 3 pages with a sv, if I have to put my sv files next to my 3 html files I got it like this: index_1.html index_2.html and so on. And actually when I tried one ot didn't work either...

Re: Embed simpleviewer isn't as it should

The easiest way to run multiple galleries is to produce the galleries as you normally would with photoshop, lightroom, etc. upload the folder that is output and then link to each folder (yoursite.com/theFolderName/). Are any of those pages that you are having trouble with online?

Mike Richards
SimpleViewer Support Team.

Re: Embed simpleviewer isn't as it should

http://www.thomas-degry.be/rvs/Verzekeringen.html

So I have verzekeringen.html and then the verzekeringen_files, the simpleviewer files are in both folders.

Re: Embed simpleviewer isn't as it should

You have two copies of the embed code in that page are you trying to have multiple galleries in one page?

              <script type="text/javascript">
var fo = new SWFObject("viewer.swf", "viewer", "100%", "400", "7", "#181818");    
fo.addVariable("preloaderColor", "0xffffff");
fo.addVariable("xmlDataPath", "gallery.xml");    
fo.write("flashcontent");    
</script>
              <div id="widget0-htmlRegion" class="html_region_widget"></div>
            </div>
            <script type="text/javascript">
var fo = new SWFObject("viewer.swf", "viewer", "100%", "400", "7", "#181818");    
fo.addVariable("preloaderColor", "0xffffff");
fo.addVariable("xmlDataPath", "gallery.xml");    
fo.write("flashcontent");    

</script>
          

You also are missing the swfobject.js include code.

<script type="text/javascript" src="swfobject.js"></script>

Mike Richards
SimpleViewer Support Team.