Topic: Arrows navigation customization.

Hi All.

I have order recently simpleviewer pro to get few thing i wanted to make with this stuff. but i stuck. i can find it. I want to modify a arrow that used in gallery and replace it by my own. i haven't found that in API (as i understand i can change only color)...  there are no source included to the zip i download to change it. as my friends tell me - they are using a different recent version of the software - source was included in the zip.

where can i request the source to make modification i need? or is it possible by some undocumented (even test) methods ?

thanks for your attention.

Oleg Butuzov
Cheers.

Re: Arrows navigation customization.

You can create custom arrows with the API set thumbNavStyle to none load the simpleviewer.swf into a container flash, create your custom arrows and use showNextImage() and showPreviousImage() to run the arrows.

If you need access to the old Pro v1.9 files, please email us including your SimpleViewer-Pro purchase details.

Mike Richards
SimpleViewer Support Team.

Re: Arrows navigation customization.

I have created custom arrows, but whenever I have to edit a gallery the the arrows disappear when I ftp the page. They will show up in the .swf file when I preview it on Dreamweaver, but once online, there are no arrows. I think the arrows are there, but do not show up as blue. I have checked the swf file, the gallery.html, the .fla file. I am stumped. This happens every time I update a gallery.
Go to : http://www.emmamcdonaldphotography.com/ … shion.html and you can see the blue navigation arrows.

Go to : http://www.emmamcdonaldphotography.com/ … trait.html and they are not there.

I have older versions of Simpleviewer and on up to Simpleviewer Pro v2. Please help. I need to understand what I am doing wrong.
Thanks

Re: Arrows navigation customization.

@bluehandesign

Go to : http://www.emmamcdonaldphotography.com/ … trait.html and they are not there.

The reason the arrows do not show for your portraits gallery is that the XML is set so that there are 10 images per thumbnail navigation page and you only have 8 images in your gallery. If you want the thumbnail arrows to show either add more images or change  thumbnailColumns="2" thumbnailRows="5"

http://www.emmamcdonaldphotography.com/ … allery.xml

Mike Richards
SimpleViewer Support Team.