Topic: SV galleries are covering my Spry sub-menu items...

I'm using Dreamweaver and I'm building a portfolio website... I've put a horizontal Spry menubar at the top of the page, and a SV Gallery beneath it... But when I move the mouse over the options in the menu, the SV Gallery is hiddng the drop-down sub-menus... It doesn't behave that way when I just put a normal image on the same surface... Is that a Z-index issue?... Is there a setting I have to change to make the SV Gallery "back" in relation to the Spry menu, that should appear on top?...

Sorry if it's a novice issue, but it's the first time I work with Spry menubars, and I'm just starting with SV programming...

Re: SV galleries are covering my Spry sub-menu items...

http://www.simpleviewer.net/simpleviewe … ml#embed_5

Felix Turner
SimpleViewer Support Team.

Re: SV galleries are covering my Spry sub-menu items...

You can have the SimpleViewer SWF appear under DHTML layers by adding this code above the SWFObject line in the HTML document. Note this may cause issues with certain browsers.

params.wmode = "transparent";

Doesn't work at all...

Re: SV galleries are covering my Spry sub-menu items...

Z-index doesn't work with flash the only thing you can do to change it is add a wmode. Did you clear your browser's cache after making the change? Is the page up on the web where we can take a look? I know people have had issues with Spry menubars in the past you could also try searching the forum to see what they did.

Mike Richards
SimpleViewer Support Team.

Re: SV galleries are covering my Spry sub-menu items...

miker wrote:

Is the page up on the web where we can take a look? .

The two pages I'm working on right now are the ones I'm showing on the other topic on scrollbars...

http://www.robertrivard.net/niaisage/mydrielle.html

http://www.robertrivard.net/niaisage/accueil.html

The sub-menus are getting blocked by the SWF... The "designs" option in the menubar has over ten items in the sub-menu... It's hard to believe I'm the only one experiencing that issue...

Re: SV galleries are covering my Spry sub-menu items...

Oh yeah, it's fixed!...

It's just that I was trying to edit the page straight into the code, and since I don't know much about HTML, I don't think I was doing the right thing...

So I tried to set the wmode to "transparent" in design view, using Dreamweaver... I just selected the SWF by clicking on it, and on the "properties" inspector, I clicked on the "parameters" tab...

I added parameters : flashvars, and for value : baseURL=yourgalleryfoldername/...

I then added a second parameter : wmode, and for value : transparent...

It worked right away in Firefox, IE, and Safari... The BG color is gone, but the horizontal menubar works fine now...