Topic: A link in 'caption' section of image needs to open in the same window.

All right guys,

Registered just for this question so hopefully you guys can help me!
I tried searching these forums but couldn't seem to find anything... (Could be because of my bas English)

So this is what's happening:

When I put a link in the caption area of an image (at the description) it opens in a new window when I click on it.
I want it to open in the same window, so practically overwriting it's current page.

I think it's easy but I can't seem to get it done. My knowledge of html/css/scripting is practically in existent so... yeah, you get the point!

Anyway, thanks a lot!
Cheers,
Jasper

Last edited by PrX (2010-06-12 14:59:24)

Re: A link in 'caption' section of image needs to open in the same window.

To open a caption link in the current window do something like this:

<caption><![CDATA[<u><a href="http://www.google.com" target="_self">Open Link in Current Window</a></u>]]></caption>
Felix Turner
SimpleViewer Support Team.

Re: A link in 'caption' section of image needs to open in the same window.

Oh my... how stupid was that! I completely missed the fact that that line was already there, but then with 'target="_blank"'...

Thanks a lot, works like a charm.  big_smile

Re: A link in 'caption' section of image needs to open in the same window.

First - love the support I've gotten since purchasing the product.  Great and thanks!  I've found most of my answers already listed in the forum, so I love the forum feature.

I have a similar issue to this topic, so I figured I just post my question along here with this one so as to keep things clean and easy for other to find if they are experiencing the same issue.

Where the link area (on the flipside of the photo) is found, I have it linking directly to another HTML page where I have a larger image for the viewer to see (it doesn't link to Flickr as I'm using xml option).  I added what I assumed made the most sense to have that link open in the same window instead of a new one by using the target self html (see my line of code below) in the xml file.  However, it continues to open in a new window.

Maybe I'm missing something in the index file rather than the xml file? Any help would be appreciated.  Thanks!

<photo imageurl="////GalleryPlaces/web/imgs/RobKaz_Beacon_36x36.jpg" linkurl="http://www.robkazart.com/GalleryPlaces/ImgPgs/Beacon.html" target="_self">        <title>Beacon</title>
            <description><![CDATA[<b>Original Dimensions:</b> 36"x36"<br><b>Description:</b> In stories throughout history, ships depended upon stars to navigate the seas. I wanted to capture that essence in Beacon with the moon being a beacon in the distance. I've always loved the warmth of a lit sail at night.]]></description>
        </photo>

Re: A link in 'caption' section of image needs to open in the same window.

@dorisd It sounds like you are using TiltViewer and not SimpleViewer. TiltViewer does not support the link target being defined in the links, you instead need to define it in the embed options in your HTML. You can try either of the following for the image to open in the same page fo.addVariable("linkTarget", "_parent"); or fo.addVariable("linkTarget", "_self"); and make sure to clear you browser's cache after making the change.

Mike Richards
SimpleViewer Support Team.

Re: A link in 'caption' section of image needs to open in the same window.

Oh shoot - I didn't even realize I was in the wrong forum.  I will give that a try!  Thanks a lot!