Topic: Embeding Simpleviewer V2 with Gallery2 Script [External Gallery]

Here is the link to my gallery, loading the images but showing a big "X" mark instead of the images.

http://www.nextlevelmarket.com/simpleviewer/

Help?

Last edited by nextlevel (2010-06-30 04:11:24)

Re: Embeding Simpleviewer V2 with Gallery2 Script [External Gallery]

The X either means the images are not on the server or the path to them is wrong. Has the gallery plugin been update for SimpleViewer 2?

Mike Richards
SimpleViewer Support Team.

Re: Embeding Simpleviewer V2 with Gallery2 Script [External Gallery]

"The images are not on the server"

Here are the two locations which are in the same server:

Simpleviewer: http://www.nextlevelmarket.com/simpleviewer/

gallery2: http://www.nextlevelmarket.com/gallery/main.php

and this is the current path I am using to call the xml feed in the file: gallery.xml

<simpleviewergallery title="Makeup and Hair Styles"
    watermarkURL="http://www.nextlevelmarket.com/images/nextlevel-watermark-s.png"
    watermarkHAlign="CENTER"
    autoPlayOnLoad="true"
    backgroundURL="http://www.lilisweddings.com/templates/rt_refraction_j15/images/backgrounds/bgstyle9/bgimage.jpg"
    backgroundScale="NONE"
    thumbpath="http://www.nextlevelmarket.com/gallery/main.php?g2_view=dynamicalbum.UpdatesAlbum"
    imagePath="http://www.nextlevelmarket.com/gallery/main.php?g2_view=dynamicalbum.UpdatesAlbum"

>

and then on the file index.html :

        <script type="text/javascript">
            var flashvars = {};
            flashvars.galleryURL = "http://www.nextlevelmarket.com/gallery/ … 2_itemId=7";
            var params = {};           
            params.allowfullscreen = true;
            params.allowscriptaccess = "always";
            params.bgcolor = "222222";
            swfobject.embedSWF("simpleviewer.swf", "flashContent", "100%", "100%", "9.0.124", false, flashvars, params);
        </script>


I don't know if I am using the correct codes "imagePath" as this is very confusing and there are no samples on your site.

I don't have much time to check on this and this is why I rather post all I've got.

Thank you in advance for your help.

Re: Embeding Simpleviewer V2 with Gallery2 Script [External Gallery]

The Gallery2 simpleviewersource module was built to support SimpleViewer 1.x so you may have issues with that, unless it has been update. Looking at the thread for the module some one has a download you can use to update it, I would try that.

Mike Richards
SimpleViewer Support Team.

Re: Embeding Simpleviewer V2 with Gallery2 Script [External Gallery]

So what would you suggest me, to get the update of the plugin so it works with simple viewer v 2? or to downgrade and use simpleviewer v 1?

Thank you so much for your reply!!

Re: Embeding Simpleviewer V2 with Gallery2 Script [External Gallery]

You could try the update the the module, but if that does not work you will have to use version 1.x if you intend to use gallery.

Mike Richards
SimpleViewer Support Team.