Topic: Building Trouble

Hi, i need help.
I keep getting this error log when i run the <<buildgallery.php>>

Creating XML and thumbnails for SimpleViewer.
-------------------------------------------------

Sorting images by date.
Sorting images in forward order.


Warning&#58; opendir&#40;images&#41;&#58; failed to open dir&#58; No such file or directory in /webroot/buildgallery.php on line 72

Warning&#58; readdir&#40;&#41;&#58; supplied argument is not a valid Directory resource in /webroot/buildgallery.php on line 73

Warning&#58; asort&#40;&#41; expects parameter 1 to be array, null given in /webroot/buildgallery.php on line 87

Warning&#58; Invalid argument supplied for foreach&#40;&#41; in /webroot/buildgallery.php on line 89

Warning&#58; closedir&#40;&#41;&#58; supplied argument is not a valid Directory resource in /webroot/buildgallery.php on line 109

Successfully created XML document&#58; gallery.xml

my directory setup is like this:

|-webroot
||<<viewer.html>> (html file that creates simple viewer flash object)
||<<buildgallery.php>>
||-photos
|||-album1
||||-2006
|||||-images (all photos here)
|||||-thumbs (thumbs to be generated here)
|||||<<gallery.xml>>

i have modified the <<buildgallery.php>> options to:

$options .= '<simpleviewerGallery maxImageWidth="480" maxImageHeight="480" textColor="0x00205b" frameColor="0x6285ff" frameWidth="20" stagePadding="40" thumbnailColumns="3" thumbnailRows="3" navPosition="right" title="SF Photos" enableRightClickOpen="true" backgroundImagePath="" imagePath="photos/album1/2006/images/" thumbPath="photos/album1/2006/thumbs/">';

and the <<viewer.html>> line:

fo.addVariable&#40;"xmlDataPath", "photos/album1/2006/gallery.xml"&#41;;

in accordance to the different file directory already.

Please help and thanks.