Topic: Several issues. Please help.

Hello guys,

I just purchased Simple Viewer Pro. I have several issues. If you can be of assistance, please be. smile

I am using Flickr to display my images... works wonders for my mom, who is using it.

First of all, here are the links:

http://www.tailsandwhiskerspetsitting.com/gallery.php (Where the Gallery is)

http://www.tailsandwhiskerspetsitting.c … allery.xml (The XML file)

http://www.tailsandwhiskerspetsitting.c … rolina.mp3 (The music file)

My issues are:

1. I have captions enabled. They do not show. They are supposed to be below the image (at least that's what the application showed when using it).

2. The music does not play. I've double checked it over and over... and it's just not working.

Any help, please?

Thanks!

Last edited by brianarney (2010-08-06 13:57:26)

Re: Several issues. Please help.

1. I have captions enabled. They do not show. They are supposed to be below the image (at least that's what the application showed when using it).

Do your flickr images have descriptions? Try increasing the height of your flash area.

http://simpleviewer.net/simpleviewer/pr … tml#flickr

http://www.tailsandwhiskerspetsitting.c … rolina.mp3 (The music file)
...
2. The music does not play. I've double checked it over and over... and it's just not working.

The audoURL in your gallery.xml does not match what you listed in your post.

 audioURL="http://www.tailsandwhiskerspetsitting.com/viewer/home-to-carolina.wav"

Also if you are using flickr change your XML from:

<?xml version="1.0" encoding="UTF-8"?>

<simpleviewergallery 

    title=""
    useFlickr="true"
    flickrUserName="darney56"
    flickrImageCount="500"
    flickrTitleFontName="Verdana"
    flickrTitleFontColor="000000"
    flickrImageSize="LARGE"
    flickrTitleFontSize="25"
    backButtonFontColor="003366"
    backButtonBackColor="F0F0F0"
    embedColor="FFFFFF"
    frameColor="E0E0E0"
    imageFrameStyle="SQUARE"
    imageCornerRadius="25"
    frameWidth="5"
    thumbFrameHoverColor="CCCCCC"
    maxImageWidth="400"
    maxImageHeight="400"
    showOpenButton="false"
    showFullscreenButton="false"
    showNavButtons="false"
    showAutoPlayButton="true"
    buttonBarPosition="OVERLAY"
    titleFontName="Verdana"
    titleFontColor="000000"
    titleFontSize="14"
    titleTextAlignment="CENTER"
    titleDropShadow="false"
    captionPosition="BOTTOM"
    captionFontColor="000000"
    imageNumberFontSize="12"
    captionFontSize="12"
    captionFontName="Verdana"
    captionTextAlignment="CENTER"
    playAudioOnLoad="true"
    thumbHoverFrameWidth="5"
    thumbCornerRadius="10"
    imageAreaY="60"
    imageTransitionTime="0.9"
    imageScaleMode="SCALE_UP"
    audioURL="http://www.tailsandwhiskerspetsitting.com/viewer/home-to-carolina.wav"
    audioVolume="1.0"

>
  <image imageURL="images/wide.jpg"
    thumbURL="thumbs/wide.jpg"
    linkURL=""
    linkTarget="">
    <caption><![CDATA[Welcome to <u><a href="http://www.simpleviewer.net/simpleviewer/pro"
    target="_blank">SimpleViewer-Pro</a></u>.]]></caption>
  </image>
  <image imageURL="images/tall.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL=""
    linkTarget="">
    <caption>SimpleViewer-Pro allows you to customize SimpleViewer to your own requirements.</caption>
  </image>
  <image imageURL="images/wide.jpg"
    thumbURL="thumbs/wide.jpg"
    linkURL=""
    linkTarget="">

    <caption>SimpleViewer-Pro has no branding or download link.</caption>
  </image>
  <image imageURL="images/tall.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL=""
    linkTarget="">
    <caption><![CDATA[No Flash® IDE needed. Customization via XML or by using <u><a href="http://www.simpleviewer.net/simpleviewer/pro/support/svbuilder.html"
    target="_blank">svBuilder</a></u>.]]></caption>
  </image>
  <image imageURL="images/wide.jpg"
    thumbURL="thumbs/wide.jpg"
    linkURL=""
    linkTarget="">
    <caption><![CDATA[Over 150 Additional <u><a href="http://www.simpleviewer.net/simpleviewer/pro/support/pro_options.html"
    target="_blank">Pro Customization Options</a></u> available.]]></caption>
  </image>

  <image imageURL="images/tall.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL="http://www.simpleviewer.net"
    linkTarget="_blank">
    <caption><![CDATA[For SimpleViewer-Pro support and documentation, view the <u><a href="http://www.simpleviewer.net/simpleviewer/pro/support"
    target="_blank">SimpleViewer-Pro Support Page</a></u>.]]></caption>
  </image>
  <image imageURL="images/wide.jpg"
    thumbURL="thumbs/wide.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>
  <image imageURL="images/tall.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>

  <image imageURL="images/wide.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>
  <image imageURL="images/tall.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>
  <image imageURL="images/wide.jpg"
    thumbURL="thumbs/wide.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>

  <image imageURL="images/tall.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>
  <image imageURL="images/wide.jpg"
    thumbURL="thumbs/wide.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>
  <image imageURL="images/tall.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>

  <image imageURL="images/wide.jpg"
    thumbURL="thumbs/wide.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>
  <image imageURL="images/tall.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>
  <image imageURL="images/wide.jpg"
    thumbURL="thumbs/wide.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>

  <image imageURL="images/tall.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>
  <image imageURL="images/wide.jpg"
    thumbURL="thumbs/wide.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>
  <image imageURL="images/tall.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>

  <image imageURL="images/wide.jpg"
    thumbURL="thumbs/wide.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>
  <image imageURL="images/tall.jpg"
    thumbURL="thumbs/tall.jpg"
    linkURL=""
    linkTarget="">
    <caption/>
  </image>
</simpleviewergallery>

To:

<?xml version="1.0" encoding="UTF-8"?>

<simpleviewergallery 

    title=""
    useFlickr="true"
    flickrUserName="darney56"
    flickrImageCount="500"
    flickrTitleFontName="Verdana"
    flickrTitleFontColor="000000"
    flickrImageSize="LARGE"
    flickrTitleFontSize="25"
    backButtonFontColor="003366"
    backButtonBackColor="F0F0F0"
    embedColor="FFFFFF"
    frameColor="E0E0E0"
    imageFrameStyle="SQUARE"
    imageCornerRadius="25"
    frameWidth="5"
    thumbFrameHoverColor="CCCCCC"
    maxImageWidth="400"
    maxImageHeight="400"
    showOpenButton="false"
    showFullscreenButton="false"
    showNavButtons="false"
    showAutoPlayButton="true"
    buttonBarPosition="OVERLAY"
    titleFontName="Verdana"
    titleFontColor="000000"
    titleFontSize="14"
    titleTextAlignment="CENTER"
    titleDropShadow="false"
    captionPosition="BOTTOM"
    captionFontColor="000000"
    imageNumberFontSize="12"
    captionFontSize="12"
    captionFontName="Verdana"
    captionTextAlignment="CENTER"
    playAudioOnLoad="true"
    thumbHoverFrameWidth="5"
    thumbCornerRadius="10"
    imageAreaY="60"
    imageTransitionTime="0.9"
    imageScaleMode="SCALE_UP"
    audioURL="http://www.tailsandwhiskerspetsitting.com/viewer/home-to-carolina.wav"
    audioVolume="1.0"

>
</simpleviewergallery>
Mike Richards
SimpleViewer Support Team.

Re: Several issues. Please help.

Mike,

Thank you for replying.

I had two versions of the music file. A .wav and a .mp3 and both do not work with the gallery. I am still confused a little by it.

Here are the URLs: http://www.tailsandwhiskerspetsitting.c … rolina.wav and http://www.tailsandwhiskerspetsitting.c … rolina.mp3

I ensured that captions are enabled on Flickr.

I made the flash area bigger and same problem.

I replaced the XML as you requested. Same problem.

Hm. I wonder what this could be, because when I used SimpleViewer (the free version)  - it worked perfectly the way I wanted.

The funny thing is... it appears EXACTLY how I want it using the SV application: svBuilder - but does not appear on the website as I want it to.

Re: Several issues. Please help.

The SWF at http://www.tailsandwhiskerspetsitting.com/gallery.php is the non-pro version. You can tell because the 'simpleviewer' badge is present at bottom right.

To upgrade existing SimpleViewer galleries to SimpleViewer-Pro, you need to replace the simpleviewer.swf file in your existing gallery folder with the one that comes in the Pro download (at \web\simpleviewer.swf).

Felix Turner
SimpleViewer Support Team.

Re: Several issues. Please help.

Wow! I swore I thought I had uploaded the PRO one! Thanks a lot, Felix! It worked. smile