Topic: XML Gallery doesn't show anything locally

Pleeeeeeeeeeeeeeeeeeeeeeeaaase help me.
It's driving me crazy
I'm using tiltViewer Pro , and the xml gallery doesn't show anything when i run it locally . But when i upload the file on the server it display all the images perfectly.
( I'm testing the sample included in the product folder "xml_gallery" )

Plus i don't wanna use it online , it's going to be a multimedia portfolio CD.

Re: XML Gallery doesn't show anything locally

I don't see a folder named 'xml_gallery' in the current TiltViewer Pro download package.
Are you suggesting that a sample gallery supplied in the download (not one you've created yourself) fails to run on your PC?

What browsers (and versions) have you tried viewing the gallery in and which work/fail? (IE, Firefox, Chrome, Safari, Opera...)

It sounds to me like an Internet Explorer 'security feature' whereby the gallery might not run locally but will run fine when uploaded.  Please try running the gallery in a few browsers locally, if you can, and post your results.

Steven Speirs
SimpleViewer Support Team.

Re: XML Gallery doesn't show anything locally

Mabe mine isn't the new version.
yes , the sample gallery supplied in the download :
The file is located on " TiltViewer-Pro --> examples --> xml_gallery "
When i run the swf file separately , it display the flicker gallery nice and perfect , but when used in a Index.html file , just display dark page.

I looked in the code , when i delete the line "fo.addVariable('useFlickr', 'false');" the page display flicker album but when add this line , just blank dark page.

I'm using FireFox 3.6.8 , IE 8.0 , Safari 5.0 , and Windows 7

Just confused. I don't think it's security, even when i use the free version it all goes OK but when i replace the swf file with the PRO version , again the dark page.

Last edited by Farzanmc (2010-08-29 08:33:23)

Re: XML Gallery doesn't show anything locally

Thanks for the added information.
Flickr galleries will only work when uploaded to a web server.
See Question #2:
http://simpleviewer.net/tiltviewer/support/faq.html

Steven Speirs
SimpleViewer Support Team.

Re: XML Gallery doesn't show anything locally

I think you didn't understand what my problem exactly is , or i don't big_smile
I want to use my own xml gallery, your free version of tiltlViewer works fine running locally with xml gallery.
I want to use  :
fo.addVariable('useFlickr', 'false');
fo.addVariable('xmlURL', 'gallery.xml');

But when these 2 lines of code added, just works on server not locally.

But the same scenario works fine in free version.

For example see this page : http://farzanmohajerani.com/album/
It works just fine, created by jAlbum and tiltViewer Pro
But when i run it locally on my hard drive i can't see the images , just a blank and dark page.

Last edited by Farzanmc (2010-08-29 09:02:09)

Re: XML Gallery doesn't show anything locally

Judging by your first post, you don't seem to have the current version of TiltViewer Pro and I can't be sure I'm looking at the same code as yourself.
Any chance you could zip and upload  the sample gallery (along with both swf files you are using) somewhere and send me a link.  It would help greatly if I could see the files you are working with.

Steven Speirs
SimpleViewer Support Team.

Re: XML Gallery doesn't show anything locally

[Link removed.]

Re: XML Gallery doesn't show anything locally

Many thanks.  I can now confirm your findings (blank page in Firefox on my own PC locally) and will investigate further.

Steven Speirs
SimpleViewer Support Team.

Re: XML Gallery doesn't show anything locally

No matter what I try, I can't seem to get your Pro swf to work locally either.
I've tried adding a DTD and mark-of-the-web to the index.html page, have tried SWFObject 2.2.

However, the good news is that as soon as I swap your Pro swf (which I suspect is v1.2) for the current version, everything works as expected.

If you still have your original download link, you should be able to download the current Pro version, otherwise, please fill out the form on this page:
http://simpleviewer.net/support/admin/upgrade.html

Steven Speirs
SimpleViewer Support Team.