Topic: Download image not working in Chrome

I'm having problems with downloading images in Google Chrome, either via the download link, or by right-clicking the image.

It opens a save box and a file is saved, however the downloaded file is always only 386 bytes (image is over 5MB).

This is only happening in Chrome - It works well in IE8.  If anyone has any ideas how to resolve this, I'll be extremely grateful smile  Thx

Re: Download image not working in Chrome

This is a known bug in v2.1.
Until the v2.1.1 bugfix comes out, the workaround is to use absolute URLs for your imageURLs.

Steven Speirs
SimpleViewer Support Team.

Re: Download image not working in Chrome

Great, thanks Steven - that's fixed it smile

Re: Download image not working in Chrome

Download image not working for me uaing Safari 5.0.2 or Firefox 3.6.2 on a Mac. I have also tried without success to download images using Firefox and IE on Fusion/XP virtual machine on this Mac without success. Link addresses to the images are absolute.

Very open for suggestions.

Re: Download image not working in Chrome

Is your gallery on a server or local pc? Image downloading only works when you upload the gallery to a server.

Mike Richards
SimpleViewer Support Team.

Re: Download image not working in Chrome

Thanks Mike for the quick response. The gallery is on remote hosted web space on a server.

I did have someone else not on this home network try to download an image from the gallery. They were unsuccessful also. I do not know which browser they use. I do know they are running Vista Home Premium.

Re: Download image not working in Chrome

Please post a URL to the gallery you are having trouble with.

Steven Speirs
SimpleViewer Support Team.

Re: Download image not working in Chrome

Steven Speirs wrote:

Please post a URL to the gallery you are having trouble with.

http://ysrphoto.com/united-hatzala/

Thanks

Re: Download image not working in Chrome

@yitzy
Your gallery looks OK to me other than the download button not working.
This is a known bug and until a bugfix version is released, the workaround is to use absolute URLs for your imageURLs (yours are currently relative).

Steven Speirs
SimpleViewer Support Team.

10

Re: Download image not working in Chrome

Thanks for the quick response Steven. Could you send me a method, via my on-file email address, for sending you the URL?

However since my earlier post I've confirmed that the 'download image' will work...sometimes. I am now home on my own network and am able to download photos just fine using the same Mac I was using earlier. I can also download images using my pc desktop.

The "other person" mentioned in my earlier post attempted again to download photos and they still cannot. Their browser is Firefox.

Sounds like a security setting on routers may be the challenge. The Mac was connected to the Internet via wireless router when images would not download. The Mac is now connected via Cat 5E hard wire. The other person's connection to the Internet is via wireless also.

Do you know of security settings on routers and/or firewalls that may be blocking the downloads?

Again, thanks!

Re: Download image not working in Chrome

Steven Speirs wrote:

@yitzy
Your gallery looks OK to me other than the download button not working.
This is a know bug and until a bugfix version is released, the workaround is to use absolute URLs for your imageURLs (yours are currently relative).

Thanks Steven

I guess this is a stupid question, but where do i change that?
(Couldn't find anything useful by search)

My clients are complaining that they cant download the pictures sad


Yitzy

Last edited by yitzy (2010-10-19 23:46:36)

Re: Download image not working in Chrome

where do i change that?

In your gallery.xml file.
You currently have image entries such as:

<image imageURL="images/IMG_2353.jpg" thumbURL="thumbs/IMG_2353.jpg" linkURL="images/IMG_2353.jpg" linkTarget="_blank">

You'll need to change the relative paths for the imageURLs to absolute paths, eg:

<image imageURL="http://ysrphoto.com/united-hatzala/images/IMG_2353.jpg" thumbURL="thumbs/IMG_2353.jpg" linkURL="images/IMG_2353.jpg" linkTarget="_blank">
Steven Speirs
SimpleViewer Support Team.

Re: Download image not working in Chrome

Thanks  smile

Re: Download image not working in Chrome

I finally had time to check it out, and its still not working sad

Re: Download image not working in Chrome

Your download button now works for me (tested in IE8, Firefox, Safari and Chrome) now that your imageURL links are absolute.
Try clearing your browser's cache.

Steven Speirs
SimpleViewer Support Team.

Re: Download image not working in Chrome

Another workaround:

Use the "open in new window" button.  Then users can right-click and download.

Much easier than changing all those URLs


Anthony

Re: Download image not working in Chrome

AnthoNYC wrote:

Much easier than changing all those URLs


Anthony

Don't need to change them one by one

use 'find and replace'...
smile

Re: Download image not working in Chrome

I'm having a similar problem, my download button does not work at all and when I try to change the urls the viewer does not show up on my page. Can you please tell me specifically where and how to change the urls?

Currently I am  replacing this
<image>
<filename>nameofjpg.jpg</filename>
<caption>blah blah blah</caption>
</image>

with
<image imageURL="http://www.tombrydelsky.com/images/nameofjpg.jpg" thumbURL="thumbs/nameofjpg.jpg" linkURL="images/nameofjpeg.jpg" linkTarget="_blank">

this is a link to the page

http://www.tombrydelsky.com/artindex.html

any help is greatly appreciated

Re: Download image not working in Chrome

You need a closing </image> tag, so replace:

<image>
<filename>nameofjpg.jpg</filename>
<caption>blah blah blah</caption>
</image>

... with:

<image imageURL="http://www.tombrydelsky.com/images/nameofjpg.jpg" thumbURL="thumbs/nameofjpg.jpg" linkURL="images/nameofjpeg.jpg" linkTarget="_blank">
<caption>blah blah blah</caption>
</image>
Steven Speirs
SimpleViewer Support Team.

Re: Download image not working in Chrome

Thanks Steve,
I've followed your instructions, but now many of the images are not showing up on the screen.
please help

Re: Download image not working in Chrome

Your imageURLs specifiy images in the 'images/' folder but they appear to be in the 'artwork/images/' folder.

Steven Speirs
SimpleViewer Support Team.

Re: Download image not working in Chrome

Thanks very much Steve! Everything seems to be working fine.

Re: Download image not working in Chrome

One more question, is there a way to put the download button on the same line as the thumbnails?
Thanks in advance.

Re: Download image not working in Chrome

If you don't need the gallery to resize you could use fixed layout to position the button bar or you could set the flash's wmode to transparent and place your own button in the html behind the flash using a little javascript and the API to download the image.

Mike Richards
SimpleViewer Support Team.

Re: Download image not working in Chrome

Thanks Mike