Topic: ButtonBar shown when site is first loaded; showOverlay="HOVER"

While making sure your mouse is not over the content area of your web browser, open this site:

http://ericdesch.com/Test/

The pause, previous, and next buttons are shown even though showOverlay="HOVER".

If you put your mouse over the SimpleViewer app and then move it off, the overlay behaves correctly. The only problem is that SimpleViewer behaves as if the mouse is over itself when it first loads.

Re: ButtonBar shown when site is first loaded; showOverlay="HOVER"

I'm not seeing that behavior on my machine. Have you cleared your cache?

Felix Turner
SimpleViewer Support Team.

Re: ButtonBar shown when site is first loaded; showOverlay="HOVER"

I looked at this on 4 machines and cleared the caches. I see it:

On Windows 7 on IE8, Firefox3.6.10 and Chrome6
On Windows 2003 Adv Server  IE8
On Windows XP IE8, Chrome6, Firefox
On Windows XP IE7*

*On XP IE7, I don't see it when the page loads, but if you click the refresh button and keep your mouse over the refresh button, I see it. This was over Remote Desktop to a machine on a completely different network, for what it's worth. For all other configurations that I tried, I see it both when loading the site and when refreshing the site.

I tried removing params.wmode = "transparent"; in case that had something to do with it, but I still see it.

Re: ButtonBar shown when site is first loaded; showOverlay="HOVER"

The problem seems to be with the width and height arguments to load(). If you have these set to '100%', you don't see the issue. If you set them to a specific value, you do.

This page shows the problem and SV.simpleviewer.load() is called with with specific values for width and height:

http://www.ericdesch.com/Test/test1.html

Exact same page but with '100%' passed for both width and height and it works fine:

http://www.ericdesch.com/Test/test2.html

Re: ButtonBar shown when site is first loaded; showOverlay="HOVER"

Thanks for tracking this down.

This bug has been logged and will be fixed in future version: 'Button bar image overlay shows on gallery load with showOverlay="HOVER", on PC with gallery dimensions pixel value, not percentage'

Felix Turner
SimpleViewer Support Team.

Re: ButtonBar shown when site is first loaded; showOverlay="HOVER"

This bug is fixed in v2.1.2

Felix Turner
SimpleViewer Support Team.