Topic: Tilt not working in Safari or Firefox

I created the below page which works great in IE but not showing at all in the two other browsers.

http://www.home-theater-design-concepts … nTilt.html

Any help would be greatly appreciated.

Last edited by ledrim (2010-10-18 21:06:59)

Re: Tilt not working in Safari or Firefox

Your TiltViewer gallery displays OK in Safari and Firefox on my PC (although the bottom of the gallery is cut off and there is no scrollbar).

In order for the web page to be displayed consistently between all browsers, you should fix the HTML errors found while validating the page through the W3C Markup Validation Service and also the CSS errors found through the W3C CSS Validation Service.

Steven Speirs
SimpleViewer Support Team.

Re: Tilt not working in Safari or Firefox

I am having a similar problem.  The gallery works great in IE, but i've had reports today from users saying it wasn't showing - what they had in common was using Safari.  I tried to view in Safari myself and this is the error message I am getting:

Error #2044: Unhandled ioError:. text=Error #2032: Stream Error. URL: http:/GalleryPlaces/web/gallery.xml
at data::XMLDataSource/getList()
at data::DataManager/getList()
at ImageGrid/reloadPage()
at ImageGrid/getNextPage()
at ImageGrid()
at TiltViewer/init()
at Preloader/initMainApp()
at Preloader/onEnterFrame()

Here is the link to my two galleries:

http://www.robkazart.com/GalleryPlaces/web/index.html
http://www.robkazart.com/GalleryFriends/web/index.html

Any help would be greatly appreciated.  Perhaps I'm missing something simple for the fix?

Re: Tilt not working in Safari or Firefox

Try replacing:

fo.addVariable("xmlURL", "///GalleryPlaces/web/gallery.xml");

... with:

fo.addVariable("xmlURL", "gallery.xml");

... and do likewise in the other gallery.

Also, your HTML documents should have a Doctype Declaration.
At the very beginning of each index.html file, place the following code before your opening <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> tag.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
   "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

You should also fix the HTML errors in the first gallery.

Steven Speirs
SimpleViewer Support Team.