Topic: Pre-Sale Questions

I came across SimpleViewer via included plugin in Lightroom 3. I am currently looking for a solution that would allow me to share galleries on my local network (bandwidth use not a concern). I am fairly happy with SimpleViewer gallery UI, so I am trying to determine if the pro version can handle my requirements before purchasing.

Specific questions...

1. I need to be able to share full size images (20 megapixel). This doesn't seem to work with the free version. The image isn't scaled. I only get a portion of image displayed. Will the Pro version scale down the images for gallery display while allowing the original to be access via button/menu/link?

2. Is there any support for having three sizes (thumb, intermediary, original)? Scaling down originals on the client is ok for galleries on the local network, but will not work for web deployments. I am also looking at FotoPlayer, which has support for original image handling (including optional password or paywall), but their layouts/galleries suck.

3. I want to use Lightroom as the gallery export client. Is there a plugin for the Pro version of SimpleViewer? Alternatively, can I take gallery.xml file from the free version and use it with the pro version (after tweaking the presentation parameters, of course)?

4. The Lightroom plugin prevents image size from being set hiegher than 1500px, which I guess makes sense since the free version will not scale images. Assuming that the pro version will scale, is there a way to tell it export using original size? My current workaround is to export the gallery, throw away the images and then export again using Lightroom basic export function. Pain in the behind. Your gallery solution would be more compelling if I didn't have to resort to a multi-step workaround.

- Konstantin

Re: Pre-Sale Questions

1. SimpleViewer has image scaling options in addition you should make sure you set the max hight and max width options. You also need to be aware the flash itself has restrictions on the maximum  image size that flash can load.

2. Not by default, you could however use the API in conjunction with JavaScript or ActionScript to achieve something like this.

3. There is not a pro version of the Lightroom plugin, you can out put the galleries with Lightroom and then either use svBuilder pro to style them or you can create a Preset XML file using svBuilder-Pro, allowing multiple galleries to share one style document so you would only have to style your galleries once.

4. The Lightroom Plugin was created by another site, The Turning Gate, I would check with them on what their product can support. It may come back to the restrictions on the maximum size image that flash can load.

Mike Richards
SimpleViewer Support Team.

Re: Pre-Sale Questions

It turns out that Lightroom 3 ships with SimpleViewer 1.8.5. I upgraded my gallery to use version 2.1 and now the images are being scaled. Now a different problem. The "Open Image in New Window" menu and the corresponding button does not work in 2.1. Nothing happens (Firefox 3.6.4 and IE 8 on Win7). This part worked with 1.8.5. Is this a known bug?

- Konstantin

Re: Pre-Sale Questions

Are you opening the gallery locally or on a server? Did you turn off any popup blockers?

Mike Richards
SimpleViewer Support Team.

Re: Pre-Sale Questions

I am running the gallery locally. Popups are not blocked. On FireFox, I had the default "open new windows in tab" option turned on. Tried it both ways; no difference.

This works in version 1.8.5 using default FireFox configuration.

- Konstantin

Re: Pre-Sale Questions

You either need to upload the gallery to a web server or when you get the flash alert choose settings and adjust flash's security settings.

Mike Richards
SimpleViewer Support Team.

Re: Pre-Sale Questions

I am not sure what Flash alert you are referencing. I don't get any alerts. The action simple doesn't do anything.

I need to be able to distribute galleries on a DVD. I cannot reasonably ask everyone to mess with their Flash settings.

What has changed from 1.8.5, where this worked, to make this an issue in 2.1 and are there any plans to fix this?

- Konstantin

Re: Pre-Sale Questions

The "Open Image in New Window" menu and the corresponding button does not work in 2.1. Nothing happens (Firefox 3.6.4 and IE 8 on Win7).

Just tested this locally and it works in all browsers. Possibly you have modified the default browser security settings or have a popup blocker installed. Can you test with the example 'web' gallery in the SimpleViewer download and see if you get the same result?

Felix Turner
SimpleViewer Support Team.

Re: Pre-Sale Questions

Popup blockers are completely disabled in both IE and FireFox. No improvement. Same result with the sample "web" gallery from the SimpleViewer v2.1 distribution. This feature still works fine on a gallery using SimpleViewer v1.8.5. Same machine, same browsers.

Flash Version: 10,1,85,3

- Konstantin

Re: Pre-Sale Questions

Tried the sample gallery on another machine running Vista. Same results there on FireFox 3.6.11, IE 8 and Flash Player 10.1.85.3.

- Konstantin

Re: Pre-Sale Questions

Just for kicks, tried installing Chrome on my Vista machine. Didn't touch any settings. Same results. Nothing happens when I go to open image.

Could you guys try this on a vanilla OS install with no browser customizations and only Flash Player installed (no Adobe developer tools)?

The other thing to look at is what changed in the code for opening the image between version 1.8.5 and 2.1, cause one works and the other doesn't. Can't attribute that to environment issues.

BTW, there is the same problem with "About Simple Viewer 2.1.0..." menu item, but "About Adobe Flash Player 10..." menu item works just fine.

- Konstantin

Re: Pre-Sale Questions

Does the open in a new window button work for you on this link?
http://www.simpleviewer.net/simpleviewe … es/modern/

Try changing your flash security setting at this link.
http://www.macromedia.com/support/docum … ger04.html

Mike Richards
SimpleViewer Support Team.

Re: Pre-Sale Questions

> Does the open in a new window button work for you on this link?
> http://www.simpleviewer.net/simpleviewe … es/modern/

This works, so it does appear to be a local-only issue.

> Try changing your flash security setting at this link.
> http://www.macromedia.com/support/docum … ger04.html

I looked through all of the setting pages and did not find anything that looked appropriate for this situation. Could you be more specific about which setting must be changed in order for this to work locally?

- Konstantin

Re: Pre-Sale Questions

Under the Global Security Settings tab select the edit/add locations drop down, browse to the folder of you gallery and select it. If Always Deny is selected your could also change that to Always Ask.

Mike Richards
SimpleViewer Support Team.