Topic: SV2 Pro Embedded in iFrame using svManager

Hey guys,

I'm having a strange issue with my client's browser in both IE and Chrome.  Here's the deal:

I have about 68 SV2 galleries I'm creating with svManager and I'm inserting each one inside an iFrame in the Drupal beta website I'm building for them.  Everything looks great in my browser but in her browser, the flash gallery inside the iFrame shrank a bit and it is aligned to the top right of the iFrame window.  This is causing a lot of ugly white space on the page in her browser.

(For troubleshooting, I added a frameborder to the iFrame to get this figured out.)

-Here is a screenshot of what she is seeing (flash shrunk): http://www.jhlconstructors.net/svmanager/test/bad.jpg

-Here is a screenshot of what I am seeing (correct, fills it out): http://www.jhlconstructors.net/svmanager/test/good.jpg

-Here is the URL of the beta page on the Drupal site: http://www.jhlconstructors.net/drupal/e … r-featured

-Here is the URL of the flash gallery all by itself: http://www.jhlconstructors.net/svmanager/g26/

Any idea how to fix it to where the SV2 gallery fills out the iFrame window?  I have this particular one (Gallery g26 in the last one above) for Gallery width set to 600 and the Gallery height is 440 as it should be.  It's driving me nuts because I can't recreate the problem on my browsers but she (the client) is having this issue and I have to fix it.  Help!

-Wes

Re: SV2 Pro Embedded in iFrame using svManager

The dimensions in your SV.simpleviewer.load() line are 600x440 but the dimensions of the iframe are 600x452.

Also, the page is more likely to be rendered with greater consistency between browsers if the validation errors shown here are fixed: W3C Markup Validation Service

Steven Speirs
SimpleViewer Support Team.

Re: SV2 Pro Embedded in iFrame using svManager

Thanks for the reply, Steven!

I have changed change the iFrame dimensions to 600x450 and then changed the SV Gallery to 100%x100% to fill the window.  I also removed the iframe border since I was able to figure out that the extra space was within the iframe and not outside of it.

I also went through and made the W3C Markup edits to where there are 0 errors now - so it's 100% validated at this point.

Steven, what does the website gallery look like on your browsers?  Is there a sizable gap between the description text below and the thumbs (http://www.jhlconstructors.net/svmanager/test/bad.jpg) or does it fill out the iFrame as it should (http://www.jhlconstructors.net/svmanager/test/good.jpg).

Any ideas why or how the SV flash gallery could've shrunk a bit in her browser?  I can't figure it out and it's almost impossible to troubleshoot for me since I can't replicate the problem here!

-Wes

Last edited by guitarwez (2010-10-23 00:07:53)

Re: SV2 Pro Embedded in iFrame using svManager

Steven, what does the website gallery look like on your browsers?

Website looks good on my PC in IE8, Firefox 3.6.11, Google Chrome 7.0.517.41 and Safari 5.0.1.
Firefox screenshot here: http://www.box.net/shared/n2cugl6m97
Website looks identical in all 4 browsers, ie no odd gaps.

Any ideas why or how the SV flash gallery could've shrunk a bit in her browser?

Most likely cause would be invalid HTML or CSS (you might also want to take a look at the CSS errors found by the W3C CSS Validator) or the use of a web browser that does not conform to web standards.

Steven Speirs
SimpleViewer Support Team.