Topic: typo3 and SV v2.1 pro

hello! as you see I run simpleviewer in my page (http://www.bolingerphotography.com). now I would like to use SV 2.1 pro. already two typo specialist tried to bring it to work, but one says the parameters and/or the paths are not properly and so the gallery.xml cannot be found. the use of iframe says the second specialist does affect the typo3 surrounding and "kills" (?) it. he says also that the functionality of the 'optimized' javascript is not longer visible and so probably not to manage. alone – without menues and logos in typo3 – it seems to work.

samples:
"old" simpleviever in use: http://www.bolingerphotography.com

nice try, but doesent work anymore: http://www.bolingerphotography.com/index.php?id=176

new simpleviewer 2.1pro without surrounding menues in typo3
(on a customer-site) works: http://www.kathrinspuehler.ch.osaka.int … dmin/test/

does anybody has same experiences or a proper solution to implement SV 2.1 pro in a typo3 based page?
do yo have working sample links?

to make clear: I am technically not really a crack and have to pass your posts to the specialists...
would be really great if the simpleviewer-cracks and programmers would have an ey on this post and give on the website special tipps and solutions!

seems that none of the advices in the << SimpleViewer Embedding Guide >> helps to solve the problem...
and I havent found other posts about SV and typo3 with additional info.

THANKS FOR YOUR HELP. bruno

Re: typo3 and SV v2.1 pro

As you are using an external svcore folder, define svCoreURL with the code:

<script type="text/javascript">
var svCoreURL = 'http://www.bolinger.ch/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/svcore/';
</script>

... before your line:

<script type="text/javascript" src="http://www.bolinger.ch/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/svcore/js/simpleviewer.js"></script>

See here for details: http://simpleviewer.net/simpleviewer/su … tml#svcore

Steven Speirs
SimpleViewer Support Team.

Re: typo3 and SV v2.1 pro

dear steven, dear all
thanks for the tipp. now I seems close to an solution but... – step by step:

with the definitions and html-code you suggested(*) the message appears: "gallery xml not found"

see: http://www.bolingerphotography.com/index.php?id=176

(* here the code we used to test)

<!--START SIMPLEVIEWER EMBED -->
<script type="text/javascript">
var svCoreURL = 'http://www.bolinger.ch/fileadmin/sw_bol … LE/svcore/';
</script>
<script type="text/javascript" src="http://www.bolinger.ch/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
$(document).ready(function () {
SV.simpleviewer.load('sv-container', '100%', '100%', 'FFFFFF',true);
});
</script>
<div id="sv-container"></div>
<!--END SIMPLEVIEWER EMBED -->

the webmaster tells me that he tried several things an we should know a kind of path-variable which defines the absolute path to the gallery.xml-file as the path to the svCoreURL.

ist the solution << flashvars.galleryURL = "myGallery.xml";>> ?

but please – where and how I have to set the URL (HTML-Code) for the gallery.xml path?

in my case it is located under www. bolinger.ch / fileadmin / sw_bolingerphotography / simplegalleries / TEST_SIMPLE

if I use the link in my browser...: http://www.bolinger.ch/fileadmin/sw_bol … ST_SIMPLE/
the right gallery appears!! ?? but not surrounded by the menues...

thanks for further help and sorry if I'm not familiar with certain technical issues and proper code-writing skills.
regards, bruno

Re: typo3 and SV v2.1 pro

In your above code as an example, you'd use this to define the path to your gallery.xml file:

<script type="text/javascript">
var flashvars = {};
flashvars.galleryURL = "http://www.bolinger.ch/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/gallery.xml";
$(document).ready(function () {
SV.simpleviewer.load('sv-container', '100%', '100%', 'FFFFFF', true, flashvars);
});
</script>

See here for details: http://simpleviewer.net/simpleviewer/su … tml#params

Steven Speirs
SimpleViewer Support Team.

Re: typo3 and SV v2.1 pro

thanks!

in your code is the y missing in galler(y)URL... : )

because i am not familiar with html and tried several things... could you quick give me the complete code for my html-page?

i would do so: (something happens, but i cant see pictures):

<!--START SIMPLEVIEWER EMBED -->
<script type="text/javascript">
var svCoreURL = 'http://www.bolinger.ch/fileadmin/sw_bol … LE/svcore/';
</script>
<script type="text/javascript" src="http://www.bolinger.ch/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/svcore/js/simpleviewer.js">
</script>
<script type="text/javascript">
$(document).ready(function () {
SV.simpleviewer.load('sv-container', '100%', '100%', 'FFFFFF',true);
});
</script>
<script type="text/javascript">
var flashvars = {};
flashvars.galleryURL = "http://www.bolinger.ch/fileadmin/sw_bol … allery.xml";
$(document).ready(function () {
SV.simpleviewer.load('sv-container', '100%', '100%', 'FFFFFF', true, flashvars);
});
</script>
<div id="sv-container"></div>
<!--END SIMPLEVIEWER EMBED -->

result: http://www.bolingerphotography.com/index.php?id=178
thanks, bruno

Re: typo3 and SV v2.1 pro

This would be the complete embedding code you'd need to use:

<!--START SIMPLEVIEWER EMBED -->
<script type="text/javascript">
var svCoreURL = 'http://www.bolinger.ch/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/svcore/';
</script>
<script type="text/javascript" src="http://www.bolinger.ch/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.galleryURL = "http://www.bolinger.ch/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/gallery.xml";
$(document).ready(function () {
SV.simpleviewer.load('sv-container', '100%', '100%', 'FFFFFF', true, flashvars);
});
</script>
<div id="sv-container"></div>
<!--END SIMPLEVIEWER EMBED -->

Paste the code into the body of the HTML page where you want to the gallery to appear.

The full embedding guide is here: http://simpleviewer.net/simpleviewer/su … dding.html

Steven Speirs
SimpleViewer Support Team.

Re: typo3 and SV v2.1 pro

thanks again... it seems to load, but i cant see any pictures. any other suggestions in my case?

in the iframe-version (http://www.bolingerphotography.com/index.php?id=177) it works but... my mobile-device doesnt show pictures because of missing flash?

Re: typo3 and SV v2.1 pro

If the gallery in question is: http://www.bolingerphotography.com/index.php?id=176 then change the line:

flashvars.galleryURL = "[url]http://www.bolinger.ch/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/gallery.xml[/url]";

... to:

flashvars.galleryURL = "http://www.bolinger.ch/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/gallery.xml";

(The forum software formatted my code and you copied it before I had a chance to edit it.)

Steven Speirs
SimpleViewer Support Team.

Re: typo3 and SV v2.1 pro

i did this before! the actual code is copied below.
it must bee someting else, but I'll show it to my webmaster before we go on.
good night and thanks al lot. bruno

<!--START SIMPLEVIEWER EMBED -->
<script type="text/javascript">
var svCoreURL = 'http://www.bolinger.ch/fileadmin/sw_bol … LE/svcore/';
</script>
<script type="text/javascript" src="http://www.bolinger.ch/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.galleryURL = "http://www.bolinger.ch/fileadmin/sw_bol … allery.xml";
$(document).ready(function () {
SV.simpleviewer.load('sv-container', '100%', '100%', 'FFFFFF', true, flashvars);
});
</script>
<div id="sv-container"></div>
<!--END SIMPLEVIEWER EMBED -->

Re: typo3 and SV v2.1 pro

me again: my webmaster found the solution!! jep.

first, in the gallery.xml the absolute paths must be defined to load the images properly.
in my case as shown below.

...

>
  <image imageURL="http://www.bolingerphotography.com/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/images/bolingerphotography_migros08_01.jpg"
    thumbURL="http://www.bolingerphotography.com/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/thumbs/bolingerphotography_migros08_01.jpg"
    linkURL="http://www.bolingerphotography.com/fileadmin/sw_bolingerphotography/simplegalleries/TEST_SIMPLE/images/bolingerphotography_migros08_01.jpg"
    linkTarget="_blank">
    <caption><![CDATA[test]]></caption>
  </image>

...

now a suggestion for the sv-builder-tool. it would be great, if it would be possible to ad the ability to define the "later" URLpath in advance, so that the gallery.xml already uses the right paths. otherwise this changement has to be done manually for every single gallery in the gallery.xml-file... ?

second: my path to the url in the html-code was not the right one. i changed and it works.

now it works, but... new problem: on my mobile device still the message aprears "gallery.xml not found".

bruno