Topic: Help - SV2.1 Galleries won't embed in my Html

Hi - Firstly I should make clear I'm a complete amateur where coding is concerned so may well be making elementary mistakes. A friend set up my original website using the original simpleviewer and through trial and error I have been able to update it myself and built a second site.  Up until SV2.1 I was able to get Simpleviewer galleries working on my photography websites but I'm updating them at the moment and wanted to use the mobile compatibility of SV2.1 galleries.

I have generated a test gallery in SV Builder pro and have put the embed code generated in the index.php file that generates each of my galleries. However, the gallery doesn't seem to embed, it generates but doesn't sit in the frame of the html. Here's a link to illustrate what I mean:

http://www.abrackenbury.com/weddings2/portraits/

Here's how it should look (this is a SV2.0x gallery I had built and embedded previously:

http://www.abrackenbury.com/weddings2/preparation/


Here's the embedding code generated by SV2.1

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
$(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "FFFFFF", true);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

I've tried playing with the %s in the SV.simpleviewer.load line but while this reveals the html frame the gallery sits above it rather than within it.

ANY help would be greatly appreciated - solving this one problem would allow me to finish my web gallery updates. Thanks in advance and in case it helps the code for my index php page is as follows:


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
$(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "FFFFFF", true);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->
<title>Andrew Brackenbury Wedding Photography - reportage-style wedding photography </title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style type="text/css">
<!--
body {
    background-color: #CCCCCC;
}
.style1 {
    color: #666666;
    font-family: Geneva, Arial, Helvetica, sans-serif;
}
.style3 {
    color: #FFFFFF;
    font-style: italic;
    font-size: 14px;
}
body,td,th {
    font-family: Geneva, Arial, Helvetica, sans-serif;
    color: #999999;
}
-->
</style>
<link href="../css/hover.css" rel="stylesheet" type="text/css">
<link href="../css/link.css" rel="stylesheet" type="text/css">
<link href="../css/visited.css" rel="stylesheet" type="text/css">
<style type="text/css">
<!--
a:link {
    color: #999999;
    text-decoration: none;
}
a:visited {
    text-decoration: none;
    color: #999999;
}
a:hover {
    text-decoration: underline;
}
a:active {
    text-decoration: none;
}
.style4 {font-size: 12px}
-->
</style>
</head>

<body>
<table width="90%"  border="1" align="center" bordercolor="#666666" bgcolor="#FFFFFF">
  <tr>
    <td height="126" colspan="3" bordercolor="#FFFFFF"><div align="left">
<?php include("../includes2/header.php")?>
     
</div></td>
  </tr>
  <tr bordercolor="#FFFFFF">
   <td height="349" colspan="3" bgcolor="#FFFFFF"><table width="100%" height="496"  border="0" align="center" bordercolor="#FFFFFF">
     <tr>
       <td width="2%" bordercolor="#FFFFFF" bgcolor="#FFFFFF">&nbsp;</td>
       <td width="93%" height="800" align="center" bgcolor="#FFFFFF"><div id="flashContent">SimpleViewer requires JavaScript and the Flash Player.
<a href="http://www.adobe.com/go/getflashplayer/">Get Flash.</a></div></td>
       <td width="5%" bgcolor="#FFFFFF">&nbsp;</td>
     </tr>
   </table></td>
  </tr>
  <tr>
    <td height="25" colspan="3" valign="top" bordercolor="#FFFFFF" bgcolor="#FFFFFF">&nbsp;</td>
  </tr>
  <tr>
    <td width="2%" height="25" valign="top" bordercolor="#FFFFFF" bgcolor="#FFFFFF"><div align="center"></div></td>
    <td width="93%" valign="top" bordercolor="#FFFFFF" bgcolor="#666666"><div align="right"><span class="style3"><span class="style4">&copy;Andrew Brackenbury</span>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span></div></td>
    <td width="5%" valign="top" bordercolor="#FFFFFF" bgcolor="#FFFFFF">&nbsp;</td>
  </tr>
</table>
</body>
</html>

Re: Help - SV2.1 Galleries won't embed in my Html

It seems to be working ok in Chrome, what browser are you using? Did you clear your browser's cache after you made changes? You have some HTML error you could fix.

Mike Richards
SimpleViewer Support Team.

Re: Help - SV2.1 Galleries won't embed in my Html

Try removing:

<div id="sv-container"></div>

... from the <head> section of your HTML page and replace:

<div id="flashContent">SimpleViewer requires JavaScript and the Flash Player.
<a href="http://www.adobe.com/go/getflashplayer/">Get Flash.</a></div>

... in the <body> section with:

<div id="sv-container"></div>
Steven Speirs
SimpleViewer Support Team.

Re: Help - SV2.1 Galleries won't embed in my Html

Hi - Thanks so much for both responses, the code changes seem to have done the trick. Thanks also for pointing out the HTML errors - will work at these as much as I can.

Really pleased and although there are teething issues I'd like to resolve - the galleries seem slower to load than before for example, I'm very happy and highly impressed by the support I received. Also impressed by how the gallery looks on the iPhone - so pleased SV works this way now!

Cheers and thanks again,
Andrew