Topic: Link in caption in svManager not possible

I can't seem to create a link (to an external page) in the caption of a SimpleViewer gallery via svManager.

On the svManager support page
it states:

> Html code in captions (SimpleViewer)
> Captions can contain any text character plus the following html tags:
> <b> <br> <br /> <font> <i>
> Example: One of my <i>better</i> shots
> The following tags can also be used in captions if the Auto caption links option is not selected in the Customize screen:
> <u> <a>

But when I turn off Auto caption links, the <a> tag still can't be used. This is essential, as my client needs to be able to add unique links to each caption himself.

Is there anything else I can do to make this work?

svManager version 1.7.2, build 101001

Re: Link in caption in svManager not possible

There's an easy fix for this. I'll add it to the next release but in the meantime you can fix it for yourself.

Backup your whole svManager folder (just to be on the safe side).

Find the file svmanager/plugins/simpleviewer2/sv2gallery.php

The following line of code should occur twice in the file. In your release it should be lines 157 and 227 or you can just do a text search.

if (strtoupper($this->preferences['addLinks']) == 'FALSE') $this->okCaptionTags .= '<u>';

Add <a> inside the quote marks like this:

if (strtoupper($this->preferences['addLinks']) == 'FALSE') $this->okCaptionTags .= '<u><a>';

Do this for both times this line occurs in the file.

That should fix it. If you're not happy doing it yourself, then post again here and I'll email a modified file for you to upload.


Jack Hardie
SimpleViewer Support Team.

Re: Link in caption in svManager not possible

Great, thanks a lot, that sounds simple enough, I'll give it try!