Topic: Gallery in IE incorrectly displayed

I have created a gallery in SV 2.1.  and pasted the code in to my HTML on a website built in Dreamweaver MX.

I have used the fix in … ng.html#js

using "Object Embed" and pasted this in the HTML (I was unable to get the Flash detection to work)
but noticed that this is all written for version SV2.0. is there an amended version for SV2.1?

The gallery displays correctly in Firefox but with a box below the gallery in black and in IE with Flash 8 via VISTA, even uglier with a white box below the gallery … cling.html


Re: Gallery in IE incorrectly displayed

You seem to have successfully embedded the SimpleViewer v2.1 gallery using the method described here: … dding.html
You can, therefore, remove the <object> embed code from your cycling.html page which is not required and is more than likely the cause of the box beneath the gallery.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery in IE incorrectly displayed

Unfortunately when I remove this piece of coding the gallery does not display, other than a thin band of it at the top of the box.

More thoughts?

Re: Gallery in IE incorrectly displayed

You need to remove the code as Steven said.

<object width="555" height="400"><param name="movie" value="simpleviewer.swf?galleryURL=gallery.xml"></param> 
<param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"> 
</param><param name="bgcolor" value="000000"></param><embed src="simpleviewer.swf?galleryURL=gallery.xml"
type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="555" height="400"

Fix your HTML erorrs

Once you have those changes made if it is still not working we can take another look.

Mike Richards
SimpleViewer Support Team.

Re: Gallery in IE incorrectly displayed

I have removed the coding and when viewed in IE it is as, above stated not loading correctly (I was viewing it locally when I made the previous comment) though fine in Firefox (why doesn't eveyone use FF?  roll )

Any thoughts Gents. Your time is very much appreciated.

URL in discussion … cling.html

Last edited by Citrus Images (2010-10-26 17:56:43)

Re: Gallery in IE incorrectly displayed

Your HTML document should have a DOCTYPE Declaration.
Use the following code at the very beginning of cycling.html, before the opening <html> tag.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"

This might be enough for the gallery to display correctly in IE.
However, as Mike has said, in order for the page to be displayed with greater consistency across different browsers, you'll need to fix the HTML errors.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery in IE incorrectly displayed

I'm getting a bit out of my depth here and very frustrated as this is a great product, but causing me headaches in IE

I have placed the code as recomended by Steven at the head of the HTML which allowed me to view the galley in VISTA (though not on my wife's laptop!), but am still struggling with other versions, all the while FF is working great.

In IE the very top of the gallery starts to download, but then it ends there.

Thanks in anticipation for your perseverance in

Below is an extract of

the HEAD of the page

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
<title>Citrus Images Cycling Team Herbalife Wheelbase</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style type="text/css">
body,td,th {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 12px;
    color: #FFFFFF;
body {
    background-color: #000000;

and the space in which the gallery should appear

      <td height="400" colspan="8" valign="top"> <!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
$(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "222222", true);
<div id="sv-container"></div>
        <td width="35" rowspan="2" valign="top"><!--DWLayoutEmptyCell-->&nbsp;</td>

Re: Gallery in IE incorrectly displayed

I notice you've removed the duplicate <html> tag and all but the very bottom of the gallery is displayed in IE on my PC (the caption is somewhat cut off).
You still need to fix the HTML errors and you could try defining the height in the <tr> tag rather than the <td> tag in your table.

Steven Speirs
SimpleViewer Support Team.