Topic: SWF file

Hello there!
I have a problem with swf file. I don't know if this is due to not being a PRO version, but the SWF file contains demo images and not mine.
I created gallery with PS CS5. index.html file shows or opens the gallery with my photos but swf file doesn't.
Can anyone help me, please?
TNX

Re: SWF file

Please post the URL of your gallery that is having the issue.

Mike Richards
SimpleViewer Support Team.

Re: SWF file

Sounds like you are opening the swf file directly in your browser which will load Flickr images by default.
You need to embed the swf file into an HTML page (as you have done with your index.html file) and point your browser towards this HTML page (as you have discovered).
The embed code within the HTML file tells the swf file where the gallery.xml file is which in turn lists the images to display.
Without this information, the swf file alone cannot display your images.

Steven Speirs
SimpleViewer Support Team.

Re: SWF file

Thanks for quick reply.
This is the code:
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>TiltViewer</title>
<script type="text/javascript" src="swfobject.js"></script>
<style type="text/css">   
    /* hide from ie on mac \*/
    html {
        height: 100%;
        overflow: hidden;
    }

    #flashcontent {
        height: 100%;
    }
    /* end hide */

    body {
        height: 100%;
        margin: 0;
        padding: 0;
        background-color: #000000;
        color:#ffffff;
        font-family:sans-serif;
        font-size:40;
    }

    a {
        color:#cccccc;
    }
</style>
</head>
<body>
    <div id="flashcontent">TiltViewer requires JavaScript and the latest Flash Player. <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash here.</a> </div>   
    <script type="text/javascript">

        var fo = new SWFObject("TiltViewer.swf", "viewer", "100%", "100%", "9.0.28", "#000000");

        //XML GALLERY OPTIONS
        fo.addVariable("xmlURL", "gallery.xml");
        fo.addVariable("useFlickr", "false");
        fo.addVariable("maxJPGSize","800");

        //GENERAL OPTIONS
        fo.addVariable("xmlURL", "gallery.xml");
        fo.addVariable("useReloadButton", "false");
        fo.addVariable("columns", "5");
        fo.addVariable("rows", "4");
        //fo.addVariable("showFlipButton", "true");
        //fo.addVariable("showLinkButton", "true");
        //fo.addVariable("linkLabel", "View image info");
        fo.addVariable("frameColor", "0xFFFFFF");
        fo.addVariable("backColor", "0xFFFF00");
        fo.addVariable("bkgndInnerColor", "0x333333");
        fo.addVariable("bkgndOuterColor", "0x000000");
        //fo.addVariable("langGoFull", "Go Fullscreen");
        //fo.addVariable("langExitFull", "Exit Fullscreen");
        //fo.addVariable("langAbout", "About");

        // END TILTVIEWER CONFIGURATION OPTIONS

        fo.addParam("allowFullScreen","true");
        fo.write("flashcontent");   
    </script>   
</body>
</html>

I am trying to embed it into iWeb.
With PS CS5 I created the gallery. In the folder I have gallery.xml, index.html, readme.html, swfobject.js and TiltViewer.swf.
So this tiltviewer.swf file only shows default pictures instead of mine...

Re: SWF file

I am trying to embed it into iWeb.
With PS CS5 I created the gallery. In the folder I have gallery.xml, index.html, readme.html, swfobject.js and TiltViewer.swf.
So this tiltviewer.swf file only shows default pictures instead of mine...

You need to either place the embed code into your iweb page or use and iframe to call the index.html, instead of linking directly to the swf.

Mike Richards
SimpleViewer Support Team.