Topic: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

http://www.tmrgallery.com

I used a spry menu in Dreamweaver for this site.

ThePaintings menu tab is long, and is being cut off at the gallery edge in IE8.

I have no problems in Firefox (why am I not surprised!)

Its like the gallery cuts off the menu dropdown halfway down where it meets the gallery.

Please help.

Tony

I tried the transparent background you suggest elsewhere, and that made the gallery disappear in both IE and Firefox--- obviously not a solution.

Last edited by TonyLucas (2010-11-01 15:22:19)

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

Please check FAQ #5 for how to prevent drop down menus from being cut off or hidden under the flash.

Mike Richards
SimpleViewer Support Team.

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

Mike, I tried that, gallery disappeared. IN BOTH IE and FF
added line 
SV.simpleviewer.load("sv-container", "100%", "100%", "222222", true, null, {wmode : "transparent"});
Tony

Just tried it again to make sure I didnt do something wrong. replaced existing sv line as above an worse results.

Thanks. Tony

Last edited by TonyLucas (2010-11-01 15:46:08)

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

Would you please add the change back to your site so I can see the issue.

Mike Richards
SimpleViewer Support Team.

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

Ok, I changed the abstracts page under paintings.

The menus work fine in both now, but the galleries do not show.

Tony

Last edited by TonyLucas (2010-11-01 16:42:23)

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

sorry,

http://tmrgallery.com/abstract/indexabstract.html

Last edited by TonyLucas (2010-11-01 16:16:25)

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

when I paste your text, it gives me an error at this line

//-->

here is the whole section:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
$(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "222222", true, null, {wmode : "transparent"});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->
</td></tr>
</table>
<script type="text/javascript">
<!--
var MenuBar2 = new Spry.Widget.MenuBar("tmr", {imgDown:"SpryAssets/SpryMenuBarDownHover.gif", imgRight:"SpryAssets/SpryMenuBarRightHover.gif"});
//-->
</script>
</body></html>

I tried using my actual measurements of 1080 and 640 but still no go.

PLEASE HELP!

t

Last edited by TonyLucas (2010-11-01 17:11:28)

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

Do you have a solution?

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

The SimpleViewer embed code looks fine and adding wmode should not kill it... you do have some HTML errors in the page and it looks like you have not uploaded the menu bar assets.

hozstrip.png Failed to load resource: the server responded with a status of 404 (Not Found)
SpryMenuBarRight.gif Failed to load resource: the server responded with a status of 404 (Not Found)
SpryMenuBarDown.gif Failed to load resource: the server responded with a status of 404 (Not Found)
indexabstract.html Uncaught SyntaxError: Unexpected end of input
SpryMenuBarRightHover.gif Failed to load resource: the server responded with a status of 404 (Not Found)
SpryMenuBarDownHover.gif Failed to load resource: the server responded with a status of 404 (Not Found)

Also try changing:

<script type="text/javascript">
<!--
var MenuBar2 = new Spry.Widget.MenuBar("tmr", {imgDown:"SpryAssets/SpryMenuBarDownHover.gif", imgRight:"SpryAssets/SpryMenuBarRightHover.gif"});
//-->
</script>

To:

<script type="text/javascript">
//<![CDATA[
var MenuBar2 = new Spry.Widget.MenuBar("tmr", {imgDown:"SpryAssets/SpryMenuBarDownHover.gif", imgRight:"SpryAssets/SpryMenuBarRightHover.gif"});
//]]>
</script>
Mike Richards
SimpleViewer Support Team.

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

At the moment, you embed code look like this:

<script type="text/javascript">
$(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "222222", true, null, {wmode : "transparent"});
</script>

You are missing the closing }); so it should look like this:

<script type="text/javascript">
$(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "222222", true, null, {wmode : "transparent"});
});
</script>

You should also fix the HTML errors on the page.

Steven Speirs
SimpleViewer Support Team.

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

Mike,

I made a new file so I wouldn't interfere w/ site on Firefox till I figure this out.

go here:

http://tmrgallery.com/abstract/indexabstract-2.html

I fixed the missing tag on your line, and all is ok in Firefox again, but gallery still doesn't show in Explorer

I looked at html errors and from what I can tell they should not interfere w/ this.

T

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

SV.simpleviewer.load("sv-container", "1080", "640%", "CCCCCC", true, null, {wmode : "transparent"});

Try changing 640% to be between 0% and 100% or a fixed number such as 640.

Mike Richards
SimpleViewer Support Team.

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

Mike,

I changed the embedded code  to repair the error and now it works great in Firefox, but the original problem still occurs in IE. The menu is still cut off.

Please help! Client is getting upset.

Tony

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

the 640% was a typo. it is "640"--- I cant type worth a dam.

problem still there in IE. menu gets cut off.

working on this file so that site not affected while I putz w/ it.

T

http://tmrgallery.com/abstract/indexabstract-2.html

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

If I navigate to http://tmrgallery.com/abstract/indexabstract-2.html it is still showing "640%". Also Make sure to clear your browser's cache after making the change.

Mike Richards
SimpleViewer Support Team.

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

The original file is still up:
http://tmrgallery.com/abstract/indexabstract.html

the updated file does not show the gallery:
http://tmrgallery.com/abstract/indexabstract-2.html

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

indexabstract-2.html is working for me in IE and Google Chrome now that you removed the percent sign and I cleared my browser's cache.

Mike Richards
SimpleViewer Support Team.

Re: My SPRY menu is cut off by my SVgallery in IE 8, shows ok in FIREFOX

Whoa! i think I (you) fixed it! Will propagate changes to rest of pages. Thanks!!!

http://tmrgallery.com/abstract/indexabstract.html