Topic: Problem with drop down menu

I've been having trouble getting my drop down menu to appear in IE 7 & 8 and Mozilla Firefox.

I'm using iframe to embed my Simpleviewr Pro v2 gallery, where the gallery is displayed correctly.

http://michalismakri.x10.mx/flowers.php

Please note that with Mozilla firefox ver 3.6.12 the drop down menu works fine but not with the previous versions.


Also I have added the parameter wmode  trasparent in the index.php. Please see below:

<script type="text/javascript">
    var params = {};
    params.wmode = "transparent";
    $(document).ready(function () {
        SV.simpleviewer.load('sv-container', '960', '600', '000000', true, params);
    });
    </script>

Please advice.

Last edited by michalis (2010-11-04 11:35:18)

Re: Problem with drop down menu

The 'SV.simpleviewer.load' line of code uses the following parameters:
http://simpleviewer.net/simpleviewer/su … tml#params
ie, you need to have 'flashvars' in between 'useFlash' and 'params'.  If not using flashvars, enter 'null'.
Your code should be:

SV.simpleviewer.load('sv-container', '960', '600', '000000', true, null, params);
Steven Speirs
SimpleViewer Support Team.

Re: Problem with drop down menu

Thanks for the reply.

After I have modified the code, the problem with the drop down menu has been resolved but the black background of my gallery has disappeared.

Please advice.

New code:
<script type="text/javascript">
    var flashvars = {};
    flashvars.galleryURL = "gallery.xml";
    var params = {};
    params.wmode = "transparent";
    $(document).ready(function () {
        SV.simpleviewer.load('sv-container', '960', '600', '000000', true, flashvars, params);
    });
    </script>

Re: Problem with drop down menu

If you don't want the swf to be transparent change the wmode transparent to opaque.

Mike Richards
SimpleViewer Support Team.

Re: Problem with drop down menu

The problem has been resolved by applying wmode opaque.

Thanks a lot for your support.