Topic: Image cut off in SimpleViewer

Attempting to create a gallery into an existing web page.  Have done so, but not all of the image shows on the web page when clicked from the thumbnail prints.  It appears to need a vertical scroll bar.  I have opened the gallery file and the supporting CSS file and eliminated the overrun:hidden files but no joy.  Any help would be appreciated.

Re: Image cut off in SimpleViewer

Did you clear your browser's cache after making the change? Beyond that please post the URL of the gallery.

Mike Richards
SimpleViewer Support Team.

Re: Image cut off in SimpleViewer

Cleared the browser cache after the change but still have the issue.

The page is not posted to the Internet yet.  I will list the URL once I get in online.

Re: Image cut off in SimpleViewer

Here's the address of the gallery:

http://cowboycarvings.com/gallery.html

Re: Image cut off in SimpleViewer

It looks like you need to define the size of your contentarea div's height in your CSS.

Mike Richards
SimpleViewer Support Team.

Re: Image cut off in SimpleViewer

The supporting CSS seems to work on all the other pages, as they have a vertical scroll bar as needed.  If I need to further define the content area (it has a width defined), what sort of height entry do you think it needs?

Re: Image cut off in SimpleViewer

Something in your code is setting overflow: hidden; for your page, this will cause the scroll bars not to show. Sorry I missed that you were using overflow hidden, so you shouldn't need to change your contentarea div's size.   Also for smaller browser windows there is a bug with SimpleViewer that cause the gallery to get cut off. It will be fixed in the next version which will be released shortly. Until then you can use the code below along with removing the over flow hidden to get your page working. Just replace the 720 with whatever size works for you page, if you are not sure what size to use I would suggest experimenting. Just remember to clear your browser's cache after making the change.

<style type="text/css" media="screen">
    #sv-mobile-flash { height: 720 !important;}
</style>
Mike Richards
SimpleViewer Support Team.

Re: Image cut off in SimpleViewer

This should be fixed in the version that was just released, SimpleViewer 2.1.1. To upgrade delete the svCore folder from your server and upload the new svCore folder from the SimpleViewer 2.1.1 download, remove the CSS change if you made it and clear your browser cache or you can upgrade the gallery using in the new version of svBuilder.

Mike Richards
SimpleViewer Support Team.

Re: Image cut off in SimpleViewer

Thanks, I'll give it a whirl.

Re: Image cut off in SimpleViewer

Looks like it worked.  Thanks for the help.

Re: Image cut off in SimpleViewer

im having the same issue at www.lousiewhale.com

i have the new viewer,

i see the code, but i get the 'cannot parse' error when I have it inserted

need these full images, help please!

Re: Image cut off in SimpleViewer

The link to your website does not work so I cannot take a look at your gallery's XML file.
However, one possible cause for 'Cannot Parse Gallery XML' is duplicate option entries, such as:

<simpleviewergallery
  thumbWidth="75"
  thumbHeight="100"
  thumbHeight="100"
>

Make sure there are no duplicate option entries in the opening <simpleviewergallery> tag.

You can also check to see if there are any XML structure errors by opening the XML file directly in Firefox.  If there are any 'XML Parsing Errors' errors, Firefox will tell you the location of the error in the file.

Steven Speirs
SimpleViewer Support Team.