Topic: Very defected images

Hello everybody.

First of all I should say that I love PostcardViewer. I have a problem though. I use Wordpress and NextGEN FlashViewer plugin. Somehow the images look very defected. You can see this in the following link: http://istanbulplace.com/apartments/pasha-place/

In the past when I used PostcardViewer this happened only for the thumbnail size but when you click to see the full size quality was good. You can see my previous website here: http://www.istanbulplaceapartments.com/ … llery.html

Could you please help me to solve this problem?

Regards,
Tarkan

Re: Very defected images

The images used in one of your galleries are of a much higher quality than those used in the other.
One image in one gallery was 89kb and the corresponding image in the other gallery was 25kb.
Use the higher quality images for both galleries and you should get consistent results.

Steven Speirs
SimpleViewer Support Team.

Re: Very defected images

Hello Steven.

Thank you very much for your prompt reply. In fact sometime ago I thought the same thing what you suggest and tried to use better quality images but I realised this was not the reason/solution to this problem. Just to be sure, 2 minutes ago I downloaded same high resolution images from my old site and uploaded to my new site and images are still very defected: http://istanbulplace.com/apartments/pasha-place/

One more thing though. My old site doesn't use nextgen-flashviewer plugin, it was a dreamveawer site. But I guess/assume such a problem should not be related to the plugin. nextgen-flashviewer plugin should be doing the manual work automatically I guess.

Any other suggestions?

Kind regards,
Tarkan

Re: Very defected images

Try setting the Flash param 'quality' to either 'high' or 'best'.
In your page, use:

params : {
  quality: "high",
  wmode : "opaque",
  allowfullscreen : "true",
  bgcolor : "#FFFFFF"},
Steven Speirs
SimpleViewer Support Team.

Re: Very defected images

Thank you very much for the suggestion. Would it be possible to tell me exactly where I should put these lines? I'm not very techie, only a bit.

Regards,
Tarkan

Re: Very defected images

In your HTML page, lines 142-145 are currently:

params : {
wmode : "opaque",
allowfullscreen : "true",
bgcolor : "#FFFFFF"},

Open the HTML file in a plain text editor, replace the above code with the following code and reupload the file.

params : {
quality: "high",
wmode : "opaque",
allowfullscreen : "true",
bgcolor : "#FFFFFF"},

Alternatively, you can insert this parameter into the NextGEN FlashViewer code in order for it to be used automatically next time you create a gallery.
Open the file 'nextgen-flashviewer/lib/functions.php' in a plain text editor and add the line between the current lines 29 and 30:

$swfobject->add_params('quality', 'high');
Steven Speirs
SimpleViewer Support Team.

Re: Very defected images

Thank you again for this detailed explanation. The problem is still there though.

As you suggested, I added

$swfobject->add_params('quality', 'high');

to 'nextgen-flashviewer/lib/functions.php'  under the postcard viewer section. Because wordpress re-creates html pages I think this should be enough. When I check the source of http://istanbulplace.com/apartments/pasha-place/
now I can see
quality: "best",

In fact I tried
quality: "high",
first but there was no improvement either.

Very strange indeed. Any other ideas to solve this problem?

Kind regards,
Tarkan

Re: Very defected images

Try using the same settings for both galleries (for consistency when comparing the two galleries).
Currently, one gallery uses:

<gallery cellDimension="800" columns="5" zoomOutPerc="25" zoomInPerc="100" frameWidth="20" frameColor="0xFFFFFF" captionColor="0xFFFFFF" enableRightClickOpen="true">

... and the other gallery uses:

<gallery cellDimension="750" columns="4" zoomOutPerc="22" zoomInPerc="90" frameWidth="0" frameColor="0x999999" captionColor="0xFFFFFF" enableRightClickOpen="false">
Steven Speirs
SimpleViewer Support Team.

Re: Very defected images

Thank you very much Steven. I tried to set all values same as you suggested but still no improvement. I tested 5 columns only in a short while because I do these tests on my live site, so now the column numbers is back to 4. I noticed one thing though I added
enableRightClickOpen : "true",
in the same way I added
quality : "best",
and I can see
enableRightClickOpen : "true",
in the html source. But inspite of this, I can't open the images with a right click. Now I wonder also the quality parameter is not taken into account even though it is in the html source? Or am I doing something wrong?

Kind regards,
Tarkan

Re: Very defected images

enableRightClickOpen is not a Flash param.
It should be used as an attribute in the opening <gallery> tag of the XML file, eg:

<gallery cellDimension="800" columns="4" zoomOutPerc="25" zoomInPerc="100" frameWidth="20" frameColor="0xffffff" captionColor="0xFFFFFF" enableRightClickOpen="true">

If you are wondering if the 'quality' param is having an effect, try setting in to 'low' and then 'high'.
You should see a difference between the two.
You may have to clear your browser's cache after making any changes.

Steven Speirs
SimpleViewer Support Team.

Re: Very defected images

I've tried quality "low" and now the quality went down dramatically. Now we know that quality parameter works! And it is set to best and the problem is still there. Is there anything else for me to try?

Kind regards,
Tarkan

Re: Very defected images

I think I've found the answer.
Change line 144 of your HTML file from:

<tr>

... to:

<tr style="width:700px; height:560px;">
Steven Speirs
SimpleViewer Support Team.

Re: Very defected images

I tried this too but still the same. I also created a test page without any table and the quality is very bad there as well. Here is a link to it: http://istanbulplace.com/test-2/

Really sorry but if you have any more ideas I'm very happy to try!

Regards,
Tarkan
PS: By the way, why don't you have a guide about how to embed into Wordpress? You have it for Joomla and Drupal...

Re: Very defected images

Try changing '7.0.0' in the embed code to '8.0.0'.

Felix Turner
SimpleViewer Support Team.

Re: Very defected images

Thank you very much I've done it. Now it is 8.0.0 but still the same low quality... Any other suggestions?

By the way, is it me having this problem or everybody else who uses nextgen-flashviewer?

Kind regards,
Tarkan

Re: Very defected images

Here's something strange.
If I download your HTML page and open it on my PC (in Firefox), the images show jagged diagonal lines (as you have experienced).
However, the following steps show the images as expected (smooth scaling).
(This is using your first gallery here: http://istanbulplace.com/apartments/pasha-place/.)
(1) Create a 'gallery.xml' file using the code from here: http://istanbulplace.com/wp-content/plu … .php?gid=4
(2) Use relative links (not absolute) for the images (I stored them locally in a folder called 'images' for convenience and changed the references to them in the 'gallery.xml' file, eg <url>images/1.jpg</url>
(3) Use a relative (not absolute) link for the swf file (again, stored locally)
(4) Change the following code in the HTML file:
Change:

xmlURL : "http://istanbulplace.com/wp-content/plugins/nextgen-flashviewer/xml/postcardviewer.php?gid=4"},

... to:

xmlURL : "gallery.xml"},

... and change:

swfobject.embedSWF("http://istanbulplace.com/wp-content/plugins/nggflash-swf/pcviewer.swf", "fo4_1", "750", "560", "8.0.0", false, this.flashvars, this.params , this.attr );

... to:

swfobject.embedSWF("pcviewer.swf", "fo4_1", "750", "560", "8.0.0", false, this.flashvars, this.params , this.attr );

Opening the HTML file now displays the images as they should be displayed.
All the files (the swf file and the images) except for 'gallery.xml' and the HTML file (2 lines changed) are the same.

Steven Speirs
SimpleViewer Support Team.

Re: Very defected images

Hello all. The problem has been solved:))

May be I had to do this at the first place. When I was trying to what Steven did I corrupted functions.php of nextgen-flashviewer, so I had to uninstall and reinstall the plugin. After doing that quality is back to normal!

Thanks a lot for all your helps.

Kind regards,
Tarkan