Topic: Questions about Caption with Flash in Simpleviewer 2.1.1

Questions about Caption.

Is it possible to use HTML code in the Caption?
I want to use only left and right pading and not top and bottom, is this possible?

I noticed that Caption width and height in Overlay Caption are not working as expected. Text is still full width of picture

When the caption text is longer then the picture width I expect wrap-around. This is not working in all cases, for instance.  When the text is just a few letters longer then the picture wrap-around does not take place. Is this a known problem?

Picture number overwrites the Caption text.

Thanks

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

Yes you can add html to your captions, but the only supported tags are anchor, underline, bold, break and font.

I want to use only left and right pading and not top and bottom, is this possible?

Currently caption padding is all or nothing.

I noticed that Caption width and height in Overlay Caption are not working as expected. Text is still full width of picture

Do you have an example of the issue and what exactly are you expecting?

When the caption text is longer then the picture width I expect wrap-around. This is not working in all cases, for instance.  When the text is just a few letters longer then the picture wrap-around does not take place. Is this a known problem?
Picture number overwrites the Caption text.

I will, have to check to see if it is a known issue, for now I would suggest adding a <br> tag to force a line break.

Mike Richards
SimpleViewer Support Team.

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

Mike Richards wrote:

I noticed that Caption width and height in Overlay Caption are not working as expected. Text is still full width of picture

Do you have an example of the issue and what exactly are you expecting?

When the caption text is longer then the picture width I expect wrap-around. This is not working in all cases, for instance.  When the text is just a few letters longer then the picture wrap-around does not take place. Is this a known problem?
Picture number overwrites the Caption text.

I will, have to check to see if it is a known issue, for now I would suggest adding a <br> tag to force a line break.

See http://www.delosgaia.nl/design2/header/test.html. image number is on, caption is longer then picture width. Caption height is increased but no wrap-around of caption text.

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

Right now you seem to be using  link breaks, is the issue occurring when you are or are not using the line breaks?

Mike Richards
SimpleViewer Support Team.

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

Mike Richards wrote:

Right now you seem to be using  link breaks, is the issue occurring when you are or are not using the line breaks?

I have used <br> in gallery.xml. Normally I am using <br /> in websites. Both don't give me the desired result. You have my permission to download the gallery.xml file.
The path is http://www.delosgaia.nl/design2/header/gallery.xml

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

It looks like captionPosition="OVERLAY_BOTTOM" can only handle a certain amount of text by default, but you can force it to use more by adding <br> tags.

Mike Richards
SimpleViewer Support Team.

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

Mike Richards wrote:

It looks like captionPosition="OVERLAY_BOTTOM" can only handle a certain amount of text by default, but you can force it to use more by adding <br> tags.

It is not only "OVERLAY_BOTTOM" but I have the same problems with "OVERLAY_TOP"

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

Mike Richards wrote:

Yes you can add html to your captions, but the only supported tags are anchor, underline, bold, break and font.

I am still trying to get a line break in my caption but still without succes. I have checked the textfield in Action script 3.0 and you need a multiline text field to use succesfully a line break.

Is it possible that the Simpleviewer caption text field is not a multiline text field?

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

It is not only "OVERLAY_BOTTOM" but I have the same problems with "OVERLAY_TOP"

Yes, you are correct overlay top will functions the same as overlay bottom.

I am still trying to get a line break in my caption but still without succes.

The linke breaks (<br>) that you have placed in your captions seem to be functions just fine for me and the text does not appear to be overrunning the image numbers.

Is it possible that the Simpleviewer caption text field is not a multiline text field?

No, SimpleViewer supports multi line captions for an example see photo 6 here.

Mike Richards
SimpleViewer Support Team.

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

Mike Richards wrote:

It is not only "OVERLAY_BOTTOM" but I have the same problems with "OVERLAY_TOP"

Yes, you are correct overlay top will functions the same as overlay bottom.

I am still trying to get a line break in my caption but still without succes.

The linke breaks (<br>) that you have placed in your captions seem to be functions just fine for me and the text does not appear to be overrunning the image numbers.

Is it possible that the Simpleviewer caption text field is not a multiline text field?

No, SimpleViewer supports multi line captions for an example see photo 6 here.

I can tell you that the caption in Overlay_Top or Overlay_Bottom is not multi-line in Simpleviewer aswell as in a webpages as with SVBuilder_Pro.  This must be a bug in Simple Viewer.

I have found it, it is the Caption Padding, anything below 4 and the next line by wrap around don't show up.

Last edited by arachnid (2010-11-29 21:15:39)

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

Just loaded new page with gallery on website but while everything works as expected in Firefox, the captions don't appear at all in I.E. 9.

In fact, everything is fine in Opera, Chrome, Safari and Firefox but not in I.E. 9.

Would appreciate solution as most of my users use I.E.

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

Just loaded new page with gallery on website but while everything works as expected in Firefox, the captions don't appear at all in I.E. 9.

In fact, everything is fine in Opera, Chrome, Safari and Firefox but not in I.E. 9.

Would appreciate solution as most of my users use I.E.

http://www.iluvchickens.com/charron-duq … hotos.html

Re: Questions about Caption with Flash in Simpleviewer 2.1.1

I have just viewed your gallery in IE9 on my PC and the captions are displayed OK.
Make sure that you have the latest version of Adobe Flash Player installed in your browser by visiting this page: http://kb2.adobe.com/cps/155/tn_15507.html

Steven Speirs
SimpleViewer Support Team.