Topic: Installation problem - "jquery is not defined"

I am trying to load a simple gallery to my simple website. My site contains a few html files and an images directory. When I create my gallery using svBuilder, I create a new directory called "mygallery," which sits in my root directory alongside my html files and my images directory. I copy the embed code and put in on the page I want the gallery to appear on; let's call it mygallerypage.html. When I refresh the mygallerypage.html, the gallery does not appear. I get a jquery error message:

jQuery is not defined

I assume the issue is my path declarations; mygallerpage.html does not seem to be able to access the necessary simpleviewer files. But is there any way to fix this without having to edit gallery.xml or renaming my existing images directory? Am I correct that when I'm generating the gallery in svBuilder and I'm asked to select a folder, if I don't create a new folder I will overwrite my existing images directory and index.html file? (Actually I know the answer because I tested this and did indeed overwrite those files. Yet when I created a new directory, my page can't find the files it needs.)

I know I'm missing something obvious here and I'm hoping someone can help me out, because I have high hopes for simpleviewer and would like to license and use on other sites I'm working on.

Thanks.

Re: Installation problem - "jquery is not defined"

Take a look at these instructions for embedding the gallery.

http://www.simpleviewer.net/simpleviewe … l#external

Mike Richards
SimpleViewer Support Team.

Re: Installation problem - "jquery is not defined"

Mike, thanks, I should have mentioned that I spent two fruitless hours reading and rereading all the support documentation and related forum topics before resorting to the forum. (This is probably only the second time in my life I have been stumped enough to post to a forum.) If you any solutions come to mind after reading my previous post I'd be eager to hear them.

Dave

Re: Installation problem - "jquery is not defined"

Please post the URL of your gallery that is having the issue so we can take a look.

Mike Richards
SimpleViewer Support Team.

Re: Installation problem - "jquery is not defined"

Thank you!

Here's the page where I'd like the gallery to display:

http://cpave.com/staging/commercial.html

The gallery itself and the associated files are at http://cpave.com/staging/gallery/

I look forward to your feedback.

Re: Installation problem - "jquery is not defined"

Hi Mike, have you had a chance to look at the URL I provided?  I know I'm just missing something simple here and I appreciate your time to set me straight.

Re: Installation problem - "jquery is not defined"

So in your page you are using  the following in your http://cpave.com/staging/commercial.html page

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "640px", "100%", "transparent", true );
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

I would suggest you try replacing that with this instead

<iframe src="http://cpave.com/staging/gallery/" width="640" height="100%" frameborder="0" scrolling="no" allowtransparency="true"></iframe>
Mike Richards
SimpleViewer Support Team.

Re: Installation problem - "jquery is not defined"

Thanks Mike. That appears to solve the problem. Still leaves me wondering how people embed a gallery using the directions provided without overwriting their images directory and index.html page ... but for now I'm happy to have something to work with.

Dave

Re: Installation problem - "jquery is not defined"

Which directions are you referring to? The embed directions  on the site show you how to embed the gallery into an existing page and svBuilder output to a folder of your choice and also gives you the embed code if you have an existing page.

Mike Richards
SimpleViewer Support Team.

Re: Installation problem - "jquery is not defined"

Mike I've explained the problem I was encountering when following the instructions for embedding the viewer into an existing web page -- that copying the entire gallery folder generated by svBuilder into the same directory as the html page on which I want the gallery to display produced the "Jquery is not defined" error message, and that, alternatively, copying the contents of the gallery folder into the root directory would overwrite my existing images directory and index.html page ... so I'm missing something somewhere, and my hope was that you could recognize my mistake and point it out to me, rather than continuing to point me to the support documentation. Nonetheless, you helped me comeu up with an alternative solution, and I'm grateful to you for that.

Re: Installation problem - "jquery is not defined"

I wasn't trying to point you back to the documentation, I was asking if you could point out which part you had trouble with as there may be an adjustment we could make so that it is more understandable.

Mike Richards
SimpleViewer Support Team.