Topic: Nothing at all displays in my web hosting space

I have just purchased your Pro simple viewer v2.1.1 having used an old out of date free version for years.
I have created a really nice looking gallery.

Everything works fine on my local pc.

Nothing but a coloured background appears (thankfully the colour I wanted) on the page that is hosted when I updated the embed script to the full site root path to the .js file.
I've tested in Firefox, IE and Crome.


I do not even get the black X's to say that all is working and the paths to the images are wrong.

Nothing at all except coloured background.

I have read your FAQ and suggestions of tweaking paths in the XML file and in the embedded script, which I have done so that I have written the path in full as follows: http://www.vickikelner.co.uk/test/index.html or http://www.vickikelner.co.uk/test/xxx.php

xxx.php being the file name I wrote in the wizard.

I've up loaded all changes time and time again. Hosting space shows all files present.

I've spent hours trying to figure this out with no luck and have an urgent deadline to meet. Thought it would be as simple to install and use as the old original version. This is not the case.

Ideas? Suggestions? MAJOR HELP NEEDED

Last edited by mcange77 (2010-12-06 23:45:24)

Re: Nothing at all displays in my web hosting space

Check out this FAQ and see if it helps: http://simpleviewer.net/simpleviewer/su … trouble_12

Steven Speirs
SimpleViewer Support Team.

Re: Nothing at all displays in my web hosting space

With all due respect I have checked out the FAQ's. As they didn't help I have resorted to this forum.
Please assist me with this problem, for if I can not get it to work, then I will require a refund.
Kind regards
Angela

Re: Nothing at all displays in my web hosting space

What is the gallery URL so we can take a look?

Felix Turner
SimpleViewer Support Team.

Re: Nothing at all displays in my web hosting space

The code to embed is this....



<!--START SIMPLEVIEWER EMBED -->
    <script type="text/javascript" src="svcore/js/simpleviewer.js"></script>

    <script type="text/javascript">
    jQuery(document).ready(function () {
        SV.simpleviewer.load('sv-container', '100%', '100%', 'transparent', true , null, null, null, false);
    });
    </script>
    <div id="sv-container"></div>
    <!--END SIMPLEVIEWER EMBED -->


The page itself is:
http://www.vickikelner.co.uk/SimpleViewer/xxx.php
The folder being:
http://www.vickikelner.co.uk/SimpleViewer

I have been experimenting with the paths but have not yet solved the problem.
I think it has to do with the path that the gallery.xml is located. As anywhere locally on my pc I create a folder and save to it. I can run via localhost without an issue.
Nothing but the website title and a blue background can I get when I upload the entire folder to my hosting company.

I tried then editing the background code manually to red to test and re-uploaded the gallery.xml file, over writing the origonal and whilst checking for cached versions the blue background still showed and not the red. Indicating to me that the actual gallery.xml file not being red?

Thanks
Angela

This is urgent now. Spent allot of time on this that I am not getting paid for.

Re: Nothing at all displays in my web hosting space

"Right click the area where the gallery should be. If you see the message 'Movie Not Loaded...' this means the SWF has uploaded incorrectly. SWF files should be uploaded as 'Binary', not as 'ASCII'. Try re-uploading the SWF file or using a different FTP application."

from http://simpleviewer.net/simpleviewer/su … trouble_12

Felix Turner
SimpleViewer Support Team.

Re: Nothing at all displays in my web hosting space

Delete the swf from the server and upload it again using Filezilla.

Mike Richards
SimpleViewer Support Team.

Re: Nothing at all displays in my web hosting space

Hi Mike,

Thanks for the suggestion but I have uploaded it that many times, deleted entire directories.

My partner who is a top security tester at BT has also tried hard to get it working. It is definitely a path relative problem.
I am really getting fed up now as spent a vast number of unpaid hours on this, have let down a client and was planning to use it on my own site and another clients.

I would like a refund.

Alternatively, I am happy to ask for a temporary sub directory on my hosting account and give you access so that you can upload and test the files to get it working and thus I can then mimic what you have done.

I would need an email address as I don't want to advertise the login details here.

Angela
angemccall@gmail.com

Re: Nothing at all displays in my web hosting space

What FTP application are you using? Did you clear your browser's cache after uploading the new version?

Mike Richards
SimpleViewer Support Team.

Re: Nothing at all displays in my web hosting space

http://vickikelner.co.uk/SimpleViewer/aboutVicki.php

This now works live on my hosting company and clients hosting account.
The folder SimpleViewer/ shown above is the name on my clients site where I have put your entire directory.
The aboutVicki.php page shown above lives in this directory. All works fine, but it is not HERE that I want the visitors of the site to view the album.

If you look at this path instead:
http://vickikelner.co.uk/aboutVicki.php
You will see her actual About Vicki website page. If you view the page source, you will notice that the embeded script is live on the page and should present the album, under all the text and above the yellow footer. It does not.

I have tried typing the site root/path in full as shown here:

<!--START SIMPLEVIEWER EMBED -->
<script type="text/javascript" src="http://www.vickikelner.co.uk/SimpleViewer/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
jQuery(document).ready(function () { SV.simpleviewer.load('sv-container', '100%', '100%', '352063', true , null, null, null, false); });
</script>
<div id="sv-container"></div>
<!--END SIMPLEVIEWER EMBED -->

However, if you test this in Firefox using the Firebug tool, it will clearly show you that not all the path directories are updating to use the path shown above.

PLEASE PLEASE solve this for me.
I have my own Portfolio website, a charity website and two other client websites all waiting to use this tool.
I choose to buy your Professional version as I loved the old free version and wanted a SIMPLER way of incorporating the viewer into the sites that I build.

FTP is done via FileZila (latest version), transfer type is set to binary.

Since writing above, I have now tried to drop the embed file shown above in another webpage incase any of my code was effecting it.
www.vickikelner.co.uk/test.php

When you view the source file, only the very first line of script has the entire path in full as I have put above.
The code that is built into the page at time of creation, does not pick up the full path and is trying to work as if the web page is in the same file directory as the source documents and code.

Your support forum tell me to update the path. I completely understand that this needs to be done and is the issue.
But I can not locate all the paths that need changing.

Assistance please.
Thanks
Angela


Making progress: I now have a XML Gallery Not Found showing in vickikelner.co.uk/test.php
I searched for the file svcore in the simpleviewer.js document and exchanged that for the entire path, which worked.

<!--START SIMPLEVIEWER EMBED -->
<script type="text/javascript" src="http://www.vickikelner.co.uk/SimpleViewer/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://www.vickiKelner.co.uk/simpleViewer/gallery.xml";
jQuery(document).ready(function () {
SV.simpleviewer.load('sv-container', '100%', '100%', '352063', true , null, null, null, false);
});
</script>
<div id="sv-container"></div>
<!--END SIMPLEVIEWER EMBED -->

www.vickikelner.co.uk/test3.php
Is this example:
http://simpleviewer.net/simpleviewer/su … l#external
as per point #1 on your support forum.

Last edited by mcange77 (2011-02-03 16:42:15)

Re: Nothing at all displays in my web hosting space

I know have:

<!--START SIMPLEVIEWER EMBED -->
<script type="text/javascript" src="http://www.vickikelner.co.uk/SimpleViewer/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">

var flashvars = {};
flashvars.galleryURL = "http://www.vickikelner.co.uk/SimpleViewer/";

jQuery(document).ready(function () {
SV.simpleviewer.load('sv-container', '100%', '100%', '352063', true , flashvars, null, null, false);
});
</script>
<div id="sv-container"></div>
<!--END SIMPLEVIEWER EMBED -->

in the document
www.vickikelner.co.uk/test4.php

I am able to generate a PARSE error for the XML file.

A little help here would still be good

Thanks
Angela

Re: Nothing at all displays in my web hosting space

Solution Found Eventually

1) write full site path to the simpleviewer.js file location in the embeded html code on the page you wish to see the album
2) open the simpleviewer.js. Do a search for the word svcore, replace this with the full path name to this folder eg: http://www.vickikelner.co.uk/SimpleViewer/svcore
3) write the full site path to each of the images in the gallery.xml file - see below
4) Create a variable called flashvars and assign to it the full gallery path and then add the variable to the load instruction as per the code below.


<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.vickikelner.co.uk/SimpleViewer/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.galleryURL = "http://www.vickikelner.co.uk/SimpleViewer/gallery.xml";

jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "352063", true , flashvars, null, null, false);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->


  <image imageURL="http://www.vickikelner.co.uk/SimpleViewer/images/VickiDressedUp.jpg"
    thumbURL="http://www.vickikelner.co.uk/SimpleViewer/thumbs/VickiDressedUp.jpg"
    linkURL="http://www.vickikelner.co.uk/SimpleViewer/images/VickiDressedUp.jpg"
    linkTarget="_blank">
    <caption><![CDATA[Vicki Kelner - Yep this is me in all my glory!]]></caption>
  </image>

Re: Nothing at all displays in my web hosting space

If you would like the embedding HTML page to be in a different folder than the gallery folder, you can also use the 'baseURL' parameter as described here: http://www.simpleviewer.net/simpleviewe … l#external

Felix Turner
SimpleViewer Support Team.