Topic: Simpleviewer thumbnail gallery in Dreamweaver page layout

We have created a gallery using the gallery script in Photoshop. The index page that is create is simple and works fine across the board. However, if we take that code and add it to a Dreamweaver page layout, it works in Live View but not in Firefox or from the actual web server. It does not appear as if the flash player object gets loaded. As I said, it does get loaded when using Live View. I have a test page here that perhaps you could have aa look at. I would very much appreciate it.

http://www.zuka.net/portfolio7/index4.html

Thanks

Dave

Re: Simpleviewer thumbnail gallery in Dreamweaver page layout

Actually, it seems this may be an issue of some kind with Firefox as it does work with Safari, Chrome, and IE8. Also, there is some chatter even on this board about Firefox not playing nice.

Last edited by filch (2010-12-09 06:01:01)

Re: Simpleviewer thumbnail gallery in Dreamweaver page layout

Usually if the gallery works in all, but on browser the issue is that there some sort HTML error in your page. The link you posted above is not working, you can either post the link again if you would like us to take a look or try validating the page yourself.

http://validator.w3.org/

Mike Richards
SimpleViewer Support Team.

Re: Simpleviewer thumbnail gallery in Dreamweaver page layout

Here is a new link. Ignore the fact that it does not look right. What I am looking for is why it does not load in Firefox. I have ran this page through the validator and it passes. No errors. Runs in IE and Safari.

http://matrix.senecac.on.ca/~sandee.roe … ndex5.html

Dave

Last edited by filch (2010-12-09 19:07:02)

Re: Simpleviewer thumbnail gallery in Dreamweaver page layout

Two issues I can see to start with you are using two SWFObject scripts when you should only be using one and you are using both SWFObject and the embed tag when you should be using one or the other. Try the following:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Untitled Document</title>
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
<script type="text/javascript">
            var flashvars = {};
            flashvars.galleryURL = "gallery.xml";
            //flashvars.firstImageIndex = "0";
            //flashvars.preloaderColor = "#FFFFFF";
            var params = {};
            params.allowfullscreen = true;
            params.allowscriptaccess = "always";
            params.bgcolor = "000";
            swfobject.embedSWF("simpleviewer.swf", "flashContent", "100%", "100%", "9.0.124", false, flashvars, params);
        </script>
<link href="../assets/css/oneColFixCtr.css" rel="stylesheet" type="text/css" />
</head>
<body>
<div class="container">
  <div class="content"><div id="flashContent">
        <div>
          <h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
          <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
        </div>
  </div></div>
  <!-- end .container --></div>
</body>
</html>
Mike Richards
SimpleViewer Support Team.