Topic: Download Button issue result of missing MIME Type?

Hi,

We are not able to use the "download" button when you hover over an image. The dialog box will appear, but it won't physically save the image to your desktop. I believe this is because we are using IIS6.

Please try for yourself here:
http://www.apus.edu/student-affairs-cen … notemplate

You'll see that it works here if you try to download an image as this is an apache server:
http://online.apus.edu/webdav/users/jma … llery2.htm

How can I enable this to work on an IIS6 server?

Thank you,

Evan

Last edited by evanmoore (2010-12-28 17:56:30)

Re: Download Button issue result of missing MIME Type?

If it helps anyone pinpoint the problem, I've been able to successfully download images using the download button in Firefox, Chrome and Safari but not in Internet Explorer.

I notice you are using SimpleViewer v2.0.3. You could try updating to the latest version of SimpleViewer.
You can download the latest version using the link sent to you in your purchase email.
If you do not require the Universal Playback functionality of the latest versions, there is no need to change the embedding code.  Just replace the 'simpleviewer.swf' file in your gallery with the 'simpleviewer_pro_211/web/svcore/swf/simpleviewer.swf' file from the SimpleViewer Pro download package.

Steven Speirs
SimpleViewer Support Team.

Re: Download Button issue result of missing MIME Type?

Right. I meant to include it does work with FireFox, but not with Internet Explorer.

I plan to download the updated version, I'm just trying to find the email now.

Re: Download Button issue result of missing MIME Type?

If you cannot find your purchase email, please fill in this form to receive a new link: http://simpleviewer.net/support/admin/upgrade.html

Steven Speirs
SimpleViewer Support Team.

Re: Download Button issue result of missing MIME Type?

thank you Steven. I found the original receipt.

Re: Download Button issue result of missing MIME Type?

Hi,

I downloaded the latest simpleviewer and replaced it.

Using Internet Explorer 7.0

I'm only able to use the "download" feature if I navigate directly to the SWF file here using this link:
http://wpc.242f.edgecastcdn.net/00242F/ … viewer.swf

if I navigate to the HTML file, then the download button won't work:
http://www.apus.edu/student-affairs-cen … photos.htm

Note: When I uploaded just the core product and all its assets onto this location, then I'm able to use the download button
http://media.apus.edu/it/evan-testing/g … index.html

Any thoughts?

Last edited by evanmoore (2010-12-28 22:31:06)

Re: Download Button issue result of missing MIME Type?

Hi,

I made this change and now I see X symbols where my images should be

http://www.apus.edu/student-affairs-cen … photos.htm

This is my code:

<script type="text/javascript">
            var flashvars = {};    
            flashvars.galleryURL = "http://wpc.242F.edgecastcdn.net/00242F/student-affairs/gallery/commencement_2010/thursday_062010/gallery.xml";
            var params = {};            
            params.allowfullscreen = true;
            params.allowscriptaccess = "always";
            params.bgcolor = "FFFFFF";
            swfobject.embedSWF("http://wpc.242F.edgecastcdn.net/00242F/student-affairs/gallery/commencement_2010/thursday_062010/simpleviewer.swf", "flashContent", "575", "800", "9.0.124", false, flashvars, params);
        </script>

Re: Download Button issue result of missing MIME Type?

SimpleViewer is looking for the first image here: http://www.apus.edu/student-affairs-cen … ng_002.jpg which does not exist.

If you are referencing images outside of the gallery folder, you need to specify the full absolute or relative path to the image in the gallery XML image tag's imageURL and thumbURL attributes. You should be able to do this via a global search and replace in a text editor.

Felix Turner
SimpleViewer Support Team.

Re: Download Button issue result of missing MIME Type?

Felix - Thank you for your support. The latest version did in fact resolve the issue with the download button not working with IE browsers. Making the changes you recommended put me on track. Thank you again!

Evan

Re: Download Button issue result of missing MIME Type?

this issue is fixed in SimpleViewer v2.1.2. http://www.simpleviewer.net/news/?p=370

Felix Turner
SimpleViewer Support Team.