Topic: mouse wheel doesnt work anymore, problems with height and more

hi

the mouse wheel doesnt work anymore despite i turn it on in the sv-builder (also the galery.xml shows "true"). whats the matter?

i spent hours with trying to embed the a gallery into my html website. but it is not working. i read through the forum but it wont work with height 100% for all div's, i mean it works, but then the gallery is so large that i cant see the header or footer on a 24 inch screen ... so can anybody tell me or give me some advise? i'm desperate and loosing faith in sv - first it looked so great

another thing is, when i change the size of the internet browser i have to refresh the browser otherwise the gallery doesnt fit.

Re: mouse wheel doesnt work anymore, problems with height and more

Please post the url of your page that is having the issue so we can take a look.

Mike Richards
SimpleViewer Support Team.

Re: mouse wheel doesnt work anymore, problems with height and more

thanks for the quick answer!

here is a link to my test website (just use this, in the main folder is the current version of my site and it doesnt match with the one im working on):

http://www.arkitektur.ch/test/04%20aktu … arten.html

general
- my layout is flexible and works (except the sv-gallery) to a screen width of 800 pixel.
- there is a nice site, which works as i would like for my site, also with the the simpleviewer (http://www.hueser.ch/Landschaften/BergTal/BergTal.html) i tried to copy the idea but struggled ...
i tested my site only with firefox, ie 8 give a wired pic of my site and i gave up ... normally firefox doesnt make much problems.

1. the first problem is the huge space i get up and below the gallery.

2. secondly, if i reduce the browser window, the gallery doesnt adapt to the new size (i have to refresh it manualy)

3. the caption disappears when i reduce the browser window

hope you get along with my explanation (im not english)

4. the changing of the pictures doesnt work despite i turn it on in sv-builder (in full screen mode it works ...)


many thanks for your help!!

raphael

Re: mouse wheel doesnt work anymore, problems with height and more

(1) This looks like a lot of space but it just allows for the very tall and thin portrait-style images in your gallery (you have images of varying aspect ratios and the gallery allows room to fit all).
(2) The gallery will only resize dynamically if all parent containers have dimensions specified as percentages.  If a parent container has, for example, a height of 600px and the gallery itself has a height of 100%, then the gallery will not always be resized to 100% of the browser window but will be 100% of 600px, ie always 600px (regardless of the browser window size).
(3) Try adding floatCaption="FALSE" in your XML file.  (http://simpleviewer.net/simpleviewer/pr … ml#caption)
(4) The mousewheel not working correctly with certain combinations of operating system and browser is a known issue (with Flash, not SimpleViewer) and is the main reason why the default setting for enableMouseWheel is FALSE
See here: http://simpleviewer.net/simpleviewer/pr … ml#general

Mouse wheel scrolling may not work on all OS/browser combinations dues to a limitation in the Flash Player.

Steven Speirs
SimpleViewer Support Team.

Re: mouse wheel doesnt work anymore, problems with height and more

1. i changed the layout and every div is now 100%. the result is that i get huge empty areas up and below the flash container.

http://www.arkitektur.ch/test/04%20aktu … arten.html

2. there isnt any height defined. so i dont understand why it doesnt resize automatically.

3. if i turn of the caption float, then it crops the top of the nav-pic's. turned on it crops the caption - really weird.

4. the reason why the mouswheel doesnt work is the transparent background - if i turn it off, the mouse wheel works ... strange behavior. but meanwhile i can live with that. just another question. how do i adjust the background color of the fullscreen when the i set background to transparent?

i spend almost the whole sunday finding a way to solve the problems. i bought sv to save time but its the other way round. so please tell me, am i too stupid to get along or does flash behave so weird all the time? my layout isnt so complicated. i just like to have it flexible.

thanks for your help

ps: im new to this forum. how do i get to this thread directly - i always have to look it up in the general list

Re: mouse wheel doesnt work anymore, problems with height and more

Replace the entry:

max-width: 1024px;

... with:

width: 100%;

... in the #wrapper CSS section in the file 'css1 bildschirm.css' and your gallery should resize dynamically horizontally.

You can set a fullscreen background color (with a transparent background in normal mode) by setting the bgcolor Flash param with the following code:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var params={};
params.bgcolor="ffffff";
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "transparent", true, null, params);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

To go directly to this thread, open the following link in your browser: http://www.simpleviewer.net/forum/viewt … p?id=11857

Steven Speirs
SimpleViewer Support Team.

Re: mouse wheel doesnt work anymore, problems with height and more

hi steven (or who is in charge)

many thanks for your help.

i managed to get a proper gallery with firefox 3.6 - so far so good. but then i realised that ie8 behaves totally strange:

(thats my test enviroment; login: test, pw: 321): http://www.arkitektur.ch/test/04%20aktu … arten.html

and even the gallery of my current website (http://www.arkitektur.ch/sv/x-mas_cards.html), which is just the code of the sv-builder, acts in ie8-64bit like this > the image is way to big and the navigation isnt according my settings - quite weird.


thanks a lot for your help!!

raphael

ps: here is a screen capture:

http://www.arkitektur.ch/_test/test%20 … %2001.html

Last edited by ikcuts (2011-01-23 11:06:12)

Re: mouse wheel doesnt work anymore, problems with height and more

the image is way to big and the navigation isnt according my settings

This sounds like the mobile version of SimpleViewer.
If SimpleViewer detects that Adobe Flash Player is not installed in the user's browser, then the gallery is displayed using HTML rather than Flash.  This maximizes the size of the main image (for mobile devices, most of which have small screens) and has no thumbnails.
You can check what version of Flash Player you have installed by going to this web page in the relevant browser: http://kb2.adobe.com/cps/155/tn_15507.html
(Firefox and IE require different Flash Player installations.)
To run Flash applications in the 64-bit version of IE8, you'll need to install the Flash Player 'Square' preview: http://labs.adobe.com/technologies/flas … 10/square/

Steven Speirs
SimpleViewer Support Team.