Topic: Compatible with PHP 5.3 ?

There is a good number of depreciated functions starting with PHP 5.3.  The svManager test code passes on PHP 5.3.2 (no E_DEPRECATED), but I want to make sure it runs on PHP 5.3.x. before I make my purchase.

Re: Compatible with PHP 5.3 ?

There is one deliberate use of php 4 code that is deprecated in php 5.

$errorHandler = & new ErrorHandler();

Passing the value of new by reference is necessary to ensure the code runs properly in php 4.

If you have your error reporting set to show E_DEPRECATED errors on screen, then this will cause problems.

So you'll need to turn-off E_DEPRECATED reporting.

Or you could do a search for the 8 instances of & new and delete the ampersands.

The code has been developed using MAMP php 5.3.2 and I am not aware of any other issues.

And here's to the day when we can all stop supporting php 4!


Jack Hardie
SimpleViewer Support Team.