Topic: Flash Album Exporter index.html creation

I have exported photos from Aperture 3 (32-bit) in order to use AutoViewer on my website.  After following the instructions for uploading the files created from the Aperture export via Flash Album Exporter to the servers site, I notice that a new index.html file is created.  If I 'replace' the original index file the site uses with the index.html file created by the export, the website opens as ONLY the exporter - not embedded as I intend for it to be.  Conversely, if I re-name the created index file (so that it is located in the same file), it is not recognized on the website and "AutoViewer rquires JavaScript and the Flash Player" dialogue is displayed in the desired location. 

Are there any *easy* work-arounds for this?  I am not in any way knowledgeable about HTML coding. 

What I am using:
Mac OS 10.6.6
iWeb '08
Aperture 3 (in 32-bit for Flash Album Exporter)
Safari 5.0.3
Firefox 3.6.13

Re: Flash Album Exporter index.html creation

If you wish to embed AutoViewer into an existing page, please follow the AutoViewer Embedding Guide.
If you continue to experience difficulties, please post a URL to your gallery so that we can take a look.

Steven Speirs
SimpleViewer Support Team.

Re: Flash Album Exporter index.html creation

http://web.me.com/b.oates/Site_2/Welcome.html

Re: Flash Album Exporter index.html creation

It looks like the 'autoviewer.swf' and 'swfobject.js' files should be in the 'Welcome_files' folder and they don't seem to be there.
Try uploading the contents of your gallery to this location and see if it helps.

Steven Speirs
SimpleViewer Support Team.

Re: Flash Album Exporter index.html creation

Please see http://web.me.com/b.oates/Site_2/Welcome.html again...

I have included the 'autoviewer.swf' and 'swfobject.js' as well as the 'gallery.xml', images folder (containing the images to be presented by AutoViewer), and the 'index.htm'l file into the 'welcome_files' folder on the iDisk server. 

Again, the same dialogue mentioned before shows up in the "Welcome" page of the site.  Keep in mind that these (4) files and (1) folder are created using the Flash Album Exporter for Aperture. 

Thanks for the help!

Re: Flash Album Exporter index.html creation

Your gallery is embedded using the following code:

<iframe id="widget1-frame" src=".//Welcome_files/widget1_markup.html" frameborder="0" style="width: 100%; height: 100%;" scrolling="no" marginheight="0" marginwidth="0" allowTransparency="true"></iframe>

Going directly to http://web.me.com/b.oates/Site_2/Welcom … arkup.html in a browser opens the page correctly.
However, going to either http://web.me.com/b.oates/Site_2/Welcom … fobject.js or http://web.me.com/b.oates/Site_2/Welcom … viewer.swf gives an error 404 (file not found).
The gallery is expecting these files to be in these locations but they do not seem to be there.
It seems to be an issue with either the location or accessibility of the files (rather than with Flash Album Exporter).
Perhaps there is an issue with loading non-HTML files from an iDisk account.
Do you have any other web space (other than iDisk) you could use?
If you were to upload the entire gallery folder somewhere and point directly to the gallery's index HTML page via the src attribute of the <iframe>, the gallery should work.

Steven Speirs
SimpleViewer Support Team.