Topic: Gallery XML Not Found (Multiple Galleries)

Hi guys, love your product and been using it for about a year. A few months ago I added a separate gallery  on a different html page with no issues, i just created multiple folders for my images and differently names xml files. Now i am trying to add a second instance of the gallery into the same html page. I created a new folder and different names for everything, but it comes up as Gallery XML not found. I used the iframe coding like the FAQ said with no luck. the site is here,

http://www.totemgallery.com/Tony.html

any help you can give is greatly appreciated!

Re: Gallery XML Not Found (Multiple Galleries)

The first gallery is looking for the file 'tonygallery.xml' in the location http://www.totemgallery.com/tonygallery.xml
The second gallery is looking for the file 'gallery.xml' in the location http://www.totemgallery.com/TonyGallery/gallery.xml
Neither files appear to be in their correct locations.
Please see this FAQ for details: http://simpleviewer.net/simpleviewer/su … #trouble_6

Steven Speirs
SimpleViewer Support Team.

Re: Gallery XML Not Found (Multiple Galleries)

Steven Speirs wrote:

The first gallery is looking for the file 'tonygallery.xml' in the location http://www.totemgallery.com/tonygallery.xml
The second gallery is looking for the file 'gallery.xml' in the location http://www.totemgallery.com/TonyGallery/gallery.xml
Neither files appear to be in their correct locations.
Please see this FAQ for details: http://simpleviewer.net/simpleviewer/su … #trouble_6

I fixed the first gallery, it was working if firefox but wasn't in IE, now it's working in both.

I'm not sure where you see the second gallery pointing to TonyGallery/gallery.xml. This is the code for the iframe i put in,

<iframe src="TonyArtwork/TonyArtworkindex.html" width="800" height="600" frameborder="0" scrolling="no"></iframe>

it should point to a folder i have called TonyArtwork which is where i have the xml file and pics for the second gallery. if i modify the script at the top of the html file from tonygallery to TonyArtwork it will load the second set pictures, so i know those are right, but of course it overwrites my first set of pictures. I'm guessing the issues is with the iframe?

Re: Gallery XML Not Found (Multiple Galleries)

Sorry, my mistake.  I should have written TonyArtwork (not TonyGallery).
The second (<iframe>) gallery is looking for http://www.totemgallery.com/TonyArtwork/gallery.xml and it is not there.  The XML file is named 'TonyArtwork.xml' and is located here: http://www.totemgallery.com/TonyArtwork.xml
You could rename the file to 'gallery.xml' and move it into the expected location or use the following embedding code in your 'TonyArtworkindex.html' page to point to the file:

<!--START SIMPLEVIEWER EMBED -->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.galleryURL = "../TonyArtwork.xml";
jQuery(document).ready(function () {
SV.simpleviewer.load('sv-container', '100%', '100%', '222222', true, flashvars);
});
</script>
<div id="sv-container"></div>
<!--END SIMPLEVIEWER EMBED -->
Steven Speirs
SimpleViewer Support Team.

Re: Gallery XML Not Found (Multiple Galleries)

Embedding the code you gave me did the trick, thanks again!