Topic: Autoview requires Javascript and .... Need help!!

Hello! 
I really have read lots of posts on forum and have been changing lots of variables in my gallery.xml file and my index.html file, but I just can't seem to get it right.

Go to here --->  http://www.hgallery.net/SENIOR2011/index.html  for the problem (Autoview requires Javascript and flash.....).

Here ---> http://www.hgallery.net/SENIOR2011/images/    are my images.

And here ---> http://www.hgallery.net/SENIOR2011/gallery.xml  is my xml file.

Below is what my index.html file looks like which is stored inside the 'SENIOR2011' folder.

<!-- saved from url=(0014)about:internet -->
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>AutoViewer</title>
<!-- Download AutoViewer at www.airtightinteractive.com/projects/autoviewer -->
<script type="text/javascript" src="swfobject.js"></script>
<style type="text/css">
    /* hide from ie on mac \*/
    html {
        height: 100%;
        overflow: hidden;
    }
    #flashcontent {
        height: 100%;
    }
    /* end hide */
    body {
        height: 100%;
        margin: 0;
        padding: 0;
        background-color: #181818;
        color:#ffffff;
        font-family:sans-serif;
        font-size:40;
    }
    a {
        color:#cccccc;
    }
</style>
</head>
<body>
    <div id="flashcontent">AutoViewer requires JavaScript and the Flash Player. <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash here.</a> </div>
    <script type="text/javascript">
        var fo = new SWFObject("http://www.hgallery.net/SENIOR2011/autoviewer.swf", "autoviewer", "100%", "100%", "8", "#181818");

        //Optional Configuration
        //fo.addVariable("langOpenImage", "Open Image in New Window");
        //fo.addVariable("langAbout", "About");
        fo.addVariable("xmlURL", "http://www.hgallery.net/SENIOR2011/gallery.xml");

        fo.write("flashcontent");

    </script>
</body>
</html>




Any help would be greatly appreciated!  I would really like to use this viewer - thank you!!!
~ jamie ;-)

Re: Autoview requires Javascript and .... Need help!!

Your http://www.hgallery.net/SENIOR2011/index.html page contains the line:

var fo = new SWFObject("SENIOR2011/autoviewer.swf", "autoviewer", "100%", "100%", "8", "#181818");

AutoViewer is, therefore, looking for the 'autoviewer.swf ' file in the location 'SENIOR2011/SENIOR2011/autoviewer.swf'.
Change the line to:

var fo = new SWFObject("autoviewer.swf", "autoviewer", "100%", "100%", "8", "#181818");

... or use the absolute path in the code you posted.

Steven Speirs
SimpleViewer Support Team.

Re: Autoview requires Javascript and .... Need help!!

Still not working....

Here is updated index.html file....


<!-- saved from url=(0014)about:internet -->
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>AutoViewer</title>
<!-- Download AutoViewer at www.airtightinteractive.com/projects/autoviewer -->
<script type="text/javascript" src="swfobject.js"></script>
<style type="text/css">
    /* hide from ie on mac \*/
    html {
        height: 100%;
        overflow: hidden;
    }
    #flashcontent {
        height: 100%;
    }
    /* end hide */
    body {
        height: 100%;
        margin: 0;
        padding: 0;
        background-color: #181818;
        color:#ffffff;
        font-family:sans-serif;
        font-size:40;
    }
    a {
        color:#cccccc;
    }
</style>
</head>
<body>
    <div id="flashcontent">AutoViewer requires JavaScript and the Flash Player. <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash here.</a> </div>
    <script type="text/javascript">
        var fo = new SWFObject("autoviewer.swf", "autoviewer", "100%", "100%", "8", "#181818");

        //Optional Configuration
        //fo.addVariable("langOpenImage", "Open Image in New Window");
        //fo.addVariable("langAbout", "About");
        fo.addVariable("xmlURL", "http://www.hgallery.net/SENIOR2011/gallery.xml");

        fo.write("flashcontent");

    </script>
</body>
</html>



The SENIOR2011 folder is in my public_html folder.  Is that part correct?  What else can I try?  How does my gallery.xml file look?  OK?

thanks!  Awaiting reply!

Re: Autoview requires Javascript and .... Need help!!

This is driving me crazy!  I changed my gallery.xml file, too to just have images/whatever.jpg

Any more thoughts?  Anxiously awaiting your reply!!  HELP ME!  I'm pulling my hair out!  ~ jamie ;-)

Re: Autoview requires Javascript and .... Need help!!

Your 'index.html' file has been stripped of all line breaks (no line feed or carriage return characters) which is likely to be playing havoc with the JavaScript on the page.
All the code is currently on a single line.  Put each line of code on a separate line (with a line feed at the end) and all should be well as all the files seem to be in the correct locations and your XML file looks fine.

Steven Speirs
SimpleViewer Support Team.

Re: Autoview requires Javascript and .... Need help!!

I am right clicking on it and opening with 'TextEdit'.  I"m on a mac. os x 10.6.6  When I open it, it looks fine (text aligned as expected).  What program do you recommend me opening it with?
thanks in advance.
~jamie

Re: Autoview requires Javascript and .... Need help!!

OK, I just opened it with dreamweaver and in the code tab, all looks perfect and aligned as expected.  When I click on design tab I can see the 'Autoview requires javascript......bla bla bla'.

Ideas?

Re: Autoview requires Javascript and .... Need help!!

OK, I clicked the space bar on my index.html file in dreamweaver to change something and then saved it.  FTPed that up to webserver and it works!!!!!  Textedit must do weird stuff.  fyi to all

thx for help support guy! ;-)

~ jamie

Re: Autoview requires Javascript and .... Need help!!

OK, today I just checked my main site and now it has the "Autoviewer requires javascript and the flash player." error.  So my link to my stuff works ----> http://www.hgallery.net/SENIOR2011/

but nobody can get to my site ---->>> http://www.hgallery.net/


Heeeeelllllllppppppp!!!!!

~ jamie

Re: Autoview requires Javascript and .... Need help!!

Any ideas?  I'm really freaking out because my site is down.  Is it because I hardcoded the urls?

Re: Autoview requires Javascript and .... Need help!!

OK, I just deleted all the autoviewer files in an attempt to get my website back up and working and now it is jacked up.  So I'm working with my hosting support to restore those files and then then I'll start over with autoviewer....... back soon!! ;-)


CRAP!!!

Re: Autoview requires Javascript and .... Need help!!

OK, finally got site back up and ftp'ed files back over.  Can you take a look again and see what you think?  thank you!

Re: Autoview requires Javascript and .... Need help!!

Your AutoViewer gallery at http://www.hgallery.net/SENIOR2011/ displays fine and the main page to your website at http://www.hgallery.net/ also loads fine.
What is the problem you'd like help with?

Steven Speirs
SimpleViewer Support Team.