Topic: embedding in a html page

I recently upgraded to svbuilderpro.

I cannot anymore embed my galery in my web site html page since I upgraded. it just doesn't appear

here's the code:

<html>
<head>
<meta content="text/html; charset=ISO-8859-1"
http-equiv="content-type">
<title></title>
<meta content="text/html; charset=ISO-8859-1"
http-equiv="content-type">
</head>
<body
style="color: rgb(234, 234, 234); background-color: rgb(25, 25, 25);"
alink="#eaeaea" link="#eaeaea" vlink="#eaeaea">
<h1 style="text-align: center;"><a href="../../index.html"
target="_self" style="text-decoration: none;"><big><span
style="font-family: Skia; font-weight: normal;"><span style="font-weight: bold;">N&nbsp;&nbsp;&nbsp;
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; </span></span></big><small><span
style="font-family: Skia;"></span></small></a></h1>
<br>
<hr style="width: 100%; height: 2px;">
<div style="text-align: center;">
<h3><span style="font-family: Skia;">&nbsp;&nbsp;&nbsp; <a
href="../../iea/mali/index.html" target="_self"
style="text-decoration: none;"><span style="color: rgb(168, 168, 168);">Ici
et ailleurs</span></a>
&nbsp;&nbsp;&nbsp; Famille &nbsp;&nbsp;&nbsp; <span
style="color: rgb(168, 168, 168);"><a href="../../art/art1/index.html"
target="_self"
style="text-decoration: none; color: rgb(168, 168, 168);">Art</a>
&nbsp; &nbsp; <a href="../../plateau/plateau1/index.html"
target="_self"
style="text-decoration: none; color: rgb(168, 168, 168);">Plateau</a>
&nbsp; &nbsp; <a href="../../spectacle/spectacle1/index.html"
target="_self"
style="text-decoration: none; color: rgb(168, 168, 168);">Spectacle</a></span><br>
</span></h3>
</div>
<div style="text-align: center; margin-left: 560px;">
</div>
<div style="text-align: center;"><span style="font-family: Skia;">1 - <a
href="../famille2/index.html" target="_self"
style="text-decoration: none;"><span style="color: rgb(168, 168, 168);">2</span></a><a
href="../famille2/index.html" target="_self"
style="text-decoration: none;"> </a></span><br>
</div>
<br>
<br>
<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "222222", true );
});
</script><!-- END SIMPLEVIEWER EMBED -->

<br>
<br>
<div style="text-align: center;"><span style="font-family: Skia;"><a
href="" target="_blank"
style="text-decoration: none;"></a></span></div>
<hr style="width: 100%; height: 2px;"><br>
<br>
<br>
</body>
</html>


THANKS.....

Re: embedding in a html page

Please post the URL of your page that you are having trouble with.

Mike Richards
SimpleViewer Support Team.

Re: embedding in a html page

Hi,

here's the original galery embedded in my html page with simpleviewer http://www.natachagysin.com/famille/famille1/index.html

here's the galery opened in svbuilder and saved. it is not embedded in my html page http://www.natachagysin.com/test/famille1/n.html

here's the galery opened and saved in svbuilder embedded in my html page
http://www.natachagysin.com/test/famille1/index.html

here's the galery opened and saved in svbuilder embedded in my html page with the change of code
<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "222222", true );
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

http://www.natachagysin.com/test/famille1/index1.html

i really don't understand where is my mistake. sad

thanks for your help

Re: embedding in a html page

here's the galery opened and saved in svbuilder embedded in my html page
http://www.natachagysin.com/test/famille1/index.html

This gallery is still using the SimpleViewer 1.9 embed code and SWF.


here's the galery opened and saved in svbuilder embedded in my html page with the change of code
<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "222222", true );
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

http://www.natachagysin.com/test/famille1/index1.html

If you view the source of the page you will see that you are missing <div id="sv-container"></div> in http://www.natachagysin.com/test/famille1/index1.html

Mike Richards
SimpleViewer Support Team.

Re: embedding in a html page

Thanks a lot,

it's working. the thing is that I use KompoZer to edit my html pages and it jus doesn't except that line. i've tried again and again but when I save it desepears.

So i'Ve just tried with another editor Nvu and it works.

big_smile

Re: embedding in a html page

Hello -

  i kind of have the same problem.  i'm working on a site, you can see the page in question at http://www.monstar.biz/chasebell/foto.html

i used,

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "500", "500", "transparent", true );
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

>>>  to get this page you see, however, when i change the code to...

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.monstar.biz/sv/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "500", "500", "transparent", true );
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

OR

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.monstar.biz/chasebell/sv/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://www.monstar.biz/chasebell/sv/";
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "500", "500", "transparent", flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

my gallery does not show.  i would like to use a specific location so i can keep the root as clean as possible (with folders, etc.)

thanks in advance!

Re: embedding in a html page

Instructions for embedding SimpleViewer Using an External Gallery Folder can be found here:
http://simpleviewer.net/simpleviewer/su … l#external

Change the 'SV.simpleviewer.load' line in the third chunk of code above (the example using baseURL) from:

SV.simpleviewer.load("sv-container", "500", "500", "transparent", flashvars);

... to:

SV.simpleviewer.load("sv-container", "500", "500", "transparent", true, flashvars);

You have 'flashvars' in the position where the 'useFlash' parameter should be: http://simpleviewer.net/simpleviewer/su … tml#params

Steven Speirs
SimpleViewer Support Team.

Re: embedding in a html page

totally overlooked that "true", thanks so much!

Re: embedding in a html page

i'm still having a problem.

i've made a folder named foto-gallery on the root of my FTP and inside it i included the svcore folder and the gallery.xml. 

here is the code i have for the embed

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.chasebell.com/foto-gallery/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://www.chasebell.com/foto-gallery/";
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "500", "500", "transparent", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

however, when i then save everything and go to the page nothing shows.  i'm curious what i'm still doing wrong.  do i have to specify the path of the gallery.xml somewhere?  nothing shows up at all - no load bar - no error message.  for the time being i just have the files on the root but i'd like to know how to remedy this for future reference, thanks!

Re: embedding in a html page

Have you uploaded the 'svcore' folder to the correct location?
Going directly to: http://www.chasebell.com/foto-gallery/s … eviewer.js in a browser gives an error 404 (file not found).

Steven Speirs
SimpleViewer Support Team.

Re: embedding in a html page

for the time being i just have the files on the root

sorry for the confusion but even when i just go to chasebell.com/svcore...  it gives me a strange page - i'm guessing that is the js and instead we should be seeing the gallery right?

it's working on the english page, who's files are directly on the root, however, not on the italian or french page who's files are in separate folders on the root named ITA and FRA respectively.

here's a photo of what my file structure looks like: http://chasebell.com/svhelp.png

Last edited by ejiboo (2011-03-05 20:21:54)

Re: embedding in a html page

Your problem is likely a problem with the path to one or more files.
What is displayed on the screen when you try to view the French or Italian versions?
Do you see a blank page or 'Gallery XML Not Found' message?
Remember that all relative paths are relative to the HTML document that embeds the SimpleViewer gallery.
If you continue to experience difficulties, please post a URL to your French and Italian galleries so that we can take a look.
(I don't know into which pages your French and Italian galleries are embedded.  From the screenshot, it looks like the only page in the ITA folder is a 'gallery.xml' file.)

Steven Speirs
SimpleViewer Support Team.

Re: embedding in a html page

File structure is like this, (i've added pictures to help):

http://www.chasebell.com/svh1.png

root/svcore/ [etc...]
root/gallery.xml

http://www.chasebell.com/svh2.png

root/FRA/foto.html
root/ITA/foto.html

  Here is the code found on all of the foto.html pages, ( http://www.chasebell.com/svh3.png ).  It works on the foto.html on root however not within the FRA and ITA folders. Nothing shows up at all when trying to view the gallery on the FRA and ITA pages.  chasebell.com/FRA/foto.html and chasebell.com/ITA/foto.html

Re: embedding in a html page

Try defining the baseURL and the location of the 'simpleviewer.js' file using either relative paths or absolute paths without the 'www' subdomain.
In your 'FRA' and 'ITA' folders, the embedding code would then look like either:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="../svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "../";
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "500", "500", "transparent", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

... or:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://chasebell.com/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://chasebell.com/";
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "500", "500", "transparent", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->
Steven Speirs
SimpleViewer Support Team.

Re: embedding in a html page

i copied the exact code you gave me there, tried each one, and other things and every time i got this, http://chasebell.com/svh4.png

Re: embedding in a html page

It definitely has something to do with your www subdomain.

Open http://chasebell.com/ITA/foto.html and the gallery displays correctly.
Open http://www.chasebell.com/ITA/foto.html and the 'Gallery XML Not Found' message is displayed.

Steven Speirs
SimpleViewer Support Team.

Re: embedding in a html page

wow that's strange.  i guess i deal with that through my host?

Re: embedding in a html page

This is due to a cross-domain security issue. Flash does not permit loading files from a different domain unless explicitly allowed by the owner of the server. Flash considers "mysite.com" to be a different domain than "www.mysite.com". Check here for more details: http://www.simpleviewer.net/simpleviewe … trouble_11

Since you are setting the baseURL to "http://chasebell.com/" loading the site from "www.chasebell.com" will not work. The solution is to use a relative baseURL or just move your gallery files into the folder you are using them in removing the need for baseURL.

Felix Turner
SimpleViewer Support Team.