Topic: IE6 cannot run simpleviewer pro 2.1.2 from an iframe

My site runs simpleviewer pro from an iframe. Until version 2.1.1 everything was ok, but starting with version 2.1.2, if I run my site in IE 6, the browser freezes.

For testing purposes, I uploaded the web folders delivered in the installation kits here:
http://ionstravels.ro/web211/index.html    (2.1.1)
http://ionstravels.ro/web212/index.html    (2.1.2)

Both of them are running ok in IE6, IE8, FF 3.6.13, Chrome 9 and Opera 11 (all Windows XP SP3, Flash player 10.2).

If I use an iframe,
http://ionstravels.ro/web211/iframe.html
runs ok in all the browsers above,

but
http://ionstravels.ro/web212/iframe.html
freezes IE 6. It seems that this happens after loading simpleviewer_icc.swf.
(Can anyone else confirm this bug, pls?)


The content of iframe.html (a simplified version for testing purposes) is:
<html>
<body>
<iframe frameborder='0' width='100%' height='100%' src='index.html'>Sorry, your browser does not support iframes!</iframe>
</body>
</html>

What can I do? as there are people still using IE 6 :-(
Tx!

Re: IE6 cannot run simpleviewer pro 2.1.2 from an iframe

Try using a Doctype declaration on the page containing your <iframe>.
http://www.w3.org/QA/2002/04/valid-dtd-list.html

Steven Speirs
SimpleViewer Support Team.

Re: IE6 cannot run simpleviewer pro 2.1.2 from an iframe

no, i have just tried, and it doesn't work :-(