Topic: IE not making background Transparent & Captions not linking to URL

Hi All, I'm running the newest version of Simple Viewer Pro and SVManager with Joomla 1.5 -  have the gallery being displayed through an iFrame. Look here: http://gilsontech.com/index.php?option= … Itemid=458

In Chrome, Firefox and Safari there's no problem with the background transparency, only in all versions of IE.

All browsers are not linking the URLs though. Any ideas? Thanks!
-Josh

Re: IE not making background Transparent & Captions not linking to URL

In order to make an <iframe> background transparent in Internet Explorer, you'll need to add the attribute allowtransparency="true" to your <iframe> tag.

<iframe src="/portfolio/web_design/index.php" mce_src="/portfolio/web_design/index.php" width="900" height="480" frameborder="0" scrolling="no" allowtransparency="true"></iframe>

The linkURL links are used for the 'Open Image In New Window' button and right-click menu option (and also when clicking on the main image if setting imageClickMode="OPEN_URL") and you have set showOpenButton="FALSE" in your gallery's XML file which will disable both of these options.
If you wish to have a link in your captions, use HTML formatting as described here: http://simpleviewer.net/simpleviewer/su … l#custom_1

Steven Speirs
SimpleViewer Support Team.

Re: IE not making background Transparent & Captions not linking to URL

thanks for the quick reply. The iframe ie issue is fixed, thanks for that. Even in IE 9 it didn't work sad, but it's all good now!

As far as the linking issue, I'm still having problems. I read the link but it doesn't seem to be working.

For example, which button should be clicked in this image so the links work?
http://www.gilsontech.com/Capture.JPG

Here's the current layout:
http://www.gilsontech.com/Capture1.JPG

When I turn on "Show Open Button" tis icon http://www.gilsontech.com/open.JPG appears and when you right click on an image it appears and says "Open image in new window." But the URL in the above image opens not the image.

I'm a little lost. Thanks for your help.

Re: IE not making background Transparent & Captions not linking to URL

Also when viewing on an iPhone or iPad the simple viewer logo is in the bottom right corner. What pro file do I need to replace to remove that?

Re: IE not making background Transparent & Captions not linking to URL

For example, which button should be clicked in this image so the links work?

Selecting 'Show open button' in your first screenshot will enable the 'Open Image In New Window...' options both on the buttonbar and the right-click menu.  When the user selects one of these options, the user's browser will open the corresponding linkURL.  You may want to change the 'Open Image In New Window' text using the languageList option: http://simpleviewer.net/simpleviewer/pr … .html#html

If an image has a caption and 'Auto caption links' is selected, the caption will automatically link to the image itself.
If you want a caption to link to a URL, deselect 'Auto caption links' and you can then use <a></a> tags to enter an HTML hyperlink in the caption field (top text field in your second screenshot). See 'HTML Code In Captions' on this page: http://simpleviewer.net/svmanager/support/

Since you are using svManager, please follow these instructions for upgrading to SimpleViewer Pro (to remove the SimpleViewer badge at the bottom right-hand corner of the browser window): http://simpleviewer.net/svmanager/support/#svpro

Steven Speirs
SimpleViewer Support Team.

Re: IE not making background Transparent & Captions not linking to URL

Thanks again Steve. The whole URL/Linking thing seems a bit confusing and unclear for an average user. Maybe in a future release there can be tips/descriptions built into the svManager?

Anyway I got it working. I have both "Auto caption links" and "Show open button" unchecked and in the first text field of each image capture I put this code "<a href="http://www.StoreHouseTech.com" target="_blank">StoreHouseTech.com - (Custom HTML, CSS & PHP)</a>" and it seems to work good.

It would be nice if the top text field was text only, the bottom the URL link and a box for target type (i.e. - _blank, etc.)
Keep in mind I use svManager and SimpleViewer for my clients sites for them to upload an manager their own photos.

As far as the SV badge, I've done what the link said you provided, but on an iPhone or iPad (where to SWF is used) the SimpleViewer badge is still displayed. Please confirm, thanks!

-Josh

Last edited by gilsontech (2011-02-20 04:19:05)

Re: IE not making background Transparent & Captions not linking to URL

As far as the SV badge, I've done what the link said you provided, but on an iPhone or iPad (where to SWF is used) the SimpleViewer badge is still displayed. Please confirm, thanks!

I've just checked your gallery on my iPod and the SimpleViewer badge is not there.
Try clearing your browser's cache in order to view any changes made.

Steven Speirs
SimpleViewer Support Team.

Re: IE not making background Transparent & Captions not linking to URL

I've tested it on my iPhone and my wife's iPhone and the badge is not there. But when I test on my iPad it's there. I cleared the cache, history, cookies and restarted the iPad, but it's still there.

Does the iPad use a different display code than the iPhone's and iPods? Also on the iPad the Captions show, but not on iPhones.

Re: IE not making background Transparent & Captions not linking to URL

Does the iPad use a different display code than the iPhone's and iPods?

No.  In all cases, Adobe Flash player will not be detected and the same HTML code will be used.
How it is interpreted may differ slightly between browsers but this will not account for different settings being used (eg. captions showing or not).
I am not seeing the SimpleViewer badge so the Pro version is being used.
The badge will only be displayed if you use the Standard version and if you upgraded your gallery from Standard to Pro, you probably replaced the 'svcore' folder overwriting the Standard files in the process.
Therefore, the only way your iPad can be showing the Standard version with the badge is if it is hanging on to old files (that no longer exist on your web server).
Make sure, before you clear the cache, that you close all web pages and have only a single 'empty' page open.

Steven Speirs
SimpleViewer Support Team.

Re: IE not making background Transparent & Captions not linking to URL

Here's a screen shot from my iPhone: http://i56.tinypic.com/osfqy1.png

Here's a screen shot from my iPad: http://i53.tinypic.com/23robco.png

Here's a screen shot from my friends iPad who's never been to my site until a few minutes ago: http://i51.tinypic.com/2418qbs.png

As you can see the Simple Viewer Badge is showing up on the iPad and the captions aren't showing up on the iPhone.

Re: IE not making background Transparent & Captions not linking to URL

Thanks for the screenshots.
The badge and captions are not showing due to the gallery image being truncated.
This may be due to CSS settings (check the height of all parent containers of your gallery).
You may also like to validate your page with the W3C Markup Validation Service and fix any errors found.

However, one thing I noticed (which might fix all the issues) is that you have a mix of files in your 'svcore' folder.
Your 'svcore/swf/simpleviewer.swf' and 'svcore/swf/simpleviewer_icc.swf' files are v2.1.2 Pro but your 'svcore/js/simpleviewer.js' file is v2.1.1 Standard.
This would certainly account for the badge showing up in the mobile version but not in the Flash version and several bugs were fixed in v2.1.2 so try deleting the 'svcore' folder from your web server and reuploading a fresh version from your SimpleViewer Pro v2.1.2 download package: 'simpleviewer_pro_212/web/svcore'.

Steven Speirs
SimpleViewer Support Team.

Re: IE not making background Transparent & Captions not linking to URL

New screen shot of iPad: http://tinypic.com/r/23mt1qt/7

The above image is showing the direct link to the gallery. I've uploaded the svscore folder and am not using any custom CSS.

The badge continues to show.

Re: IE not making background Transparent & Captions not linking to URL

The 'simpleviewer.js' file at http://www.gilsontech.com/portfolio/web … eviewer.js still shows as SimpleViewer Standard v2.1.1 rather than SimpleViewer Pro v2.1.2.
Ensure that when uploading the 'svcore' folder, that it is to the correct location and that your FTP client program is set to overwrite existing files.

Steven Speirs
SimpleViewer Support Team.

Re: IE not making background Transparent & Captions not linking to URL

Oh. I uploaded the new files to the svscore root folder not the design galleries. I will try in the morning. Thanks.

Last edited by gilsontech (2011-02-21 10:25:36)

Re: IE not making background Transparent & Captions not linking to URL

Thanks for all your help Steve. I have everything working as it should. I had to remove the svscore folder in the SV2 plugin's folder and recreate the galleries with the settings how I need them, and everything looks good.

It would be nice to see th Mobile options area to have more features though!
Thanks.