Topic: Thumbnails not shown in Internet Explorer 7

1. Thumbnails are not shown in Internet Explorer 7 (Windows XP). Also the main image is too large (max image size setting is disregarded).
2. Gallery is displayed correctly in FireFox.
3. On another PC (also XP, IE7), the gallery is also displayed correctly.
4. Another website which uses Simpleviewer, is displayed correctly, both IE7 and Firefox, on both PCs.
Seems like on the PC which has this problem, something is missing or one of the settings is incorrect, but I cannot find the cause.

Re: Thumbnails not shown in Internet Explorer 7

Please post the URL of the page you are having trouble with.

Mike Richards
SimpleViewer Support Team.

Re: Thumbnails not shown in Internet Explorer 7

Unfortunately I could not yet publish this site (because of this issue)

Re: Thumbnails not shown in Internet Explorer 7

Possibly you are viewing the SimpleViewer Mobile gallery on certain browsers. If the browser does not have Flash installed then the Mobile gallery will be displayed. SimpleViewer Mobile has a different layout optimized for mobile phones. Check you have Flash installed here: http://kb2.adobe.com/cps/155/tn_15507.html

Felix Turner
SimpleViewer Support Team.

Re: Thumbnails not shown in Internet Explorer 7

I checked, and I now have the latest Flash player installed but this does not solve the problem.
In FireFox everything looks fine, but not in IE7.

Re: Thumbnails not shown in Internet Explorer 7

Often when it looks right in one browser and not another there is an HTML error or something similar causing the issue. Try validating your HTML code and fixing your errors.

http://validator.w3.org/

Mike Richards
SimpleViewer Support Team.

Re: Thumbnails not shown in Internet Explorer 7

Thanks for the advice; I've validated the code but unfortunately this did not give me the clue to the solution of this problem.
The funny thing is that the gallery is shown correctly on another PC with Internet Explorer 7.

Also, another website using Simpleviewer, is displayed correctly, both IE7 and Firefox, on both PCs (http://www.juanexue.nl/index2.html).

This is a sample of the HTML code of the gallery which has the problem described, may be this helps:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
    <title>SimpleViewer Gallery</title>
</head>

<body>

    <!--START SIMPLEVIEWER EMBED -->
    <script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
    <script type="text/javascript">
    jQuery(document).ready(function () {
        SV.simpleviewer.load('sv-container', '100%', '100%', 'CCCCCC', true );
    });
    </script>
    <div id="sv-container"></div>
    <!--END SIMPLEVIEWER EMBED -->

</body>
</html>

Last edited by hanstheuws (2011-03-02 10:13:55)

Re: Thumbnails not shown in Internet Explorer 7

If you can not post the URL can you post the HTML code the page that has the issue is using?

Mike Richards
SimpleViewer Support Team.

Re: Thumbnails not shown in Internet Explorer 7

Hi Mike,
This is the complete code:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Maugosia Sycz - portretten</title>
<link href="../../sycz2011_main.css" rel="stylesheet" type="text/css" />
</head>

<body bgcolor="#CCCCCC" topmargin="0" marginheight="0">
<table width="1000" border="0" align="center" cellpadding="0" cellspacing="0" bordercolor="#FFFFFF">

<tr height="100"><td width="100" height="50" bgcolor="#333333"><div align="left"><img src="../syczlogo2011.jpg" width="177" height="53" /></div></td>
<td bgcolor="#CCCCCC">

<table width="800" border="0" align="center" cellpadding="0" cellspacing="0">
            <tr>
              <td width="148"><div align="center">
                <h4><a href="../bloemen/sycz_bloemen.html">BLOEMEN</a></h4>
                </div></td>
              <td width="2" align="center"><p>|</p></td>
              <td width="148"><div align="center"><a href="../landschappen/sycz_landschappen.html">LANDSCHAPPEN</a></div></td>
              <td width="2" align="center"><p>|</p></td>
              <td width="148"><div align="center">
                <h4><a href="../interieurs/sycz_interieurs.html">INTERIEURS</a></h4>
              </div></td>
              <td width="2" align="center"><p>|</p></td>
              <td width="148"><div align="center">
                <h4>PORTRETTEN</h4>
              </div></td>
              <td width="2" align="center"></td>
              <td width="160"><div align="center">
                <p>&nbsp;</p>
              </div></td>
            </tr>
</table>
</td>
<tr height="800"><td width="200" bgcolor="#999999" valign="top">
<table width="180" cellpadding="5">
            <tr height="30">
               <td><a href="../../index.html" style="color:#CCCCCC">HOME</a></td>
            </tr>
            <tr height="30">
              <td><a href="../profiel.html" style="color:#CCCCCC">OVER MAUGOSIA SYCZ</a></td>
            </tr>
            <tr height="30">
              <td><a href="../exposities.html" style="color:#CCCCCC">EXPOSITIES</a></td>
            </tr>
            <tr height="30">
              <td><a href="../cursussen.html" style="color:#CCCCCC">CURSUSSEN</a></td>
            </tr>
</table>
</td>
<td bgcolor="#CCCCCC">
<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "CCCCCC", true );
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->
</td>
</tr>
<tr height="200"><td width="200" bgcolor="#999999" valign="top"></td><td width="800" bgcolor="#CCCCCC" valign="top"></td></tr>
</table>
</body>
</html>

Re: Thumbnails not shown in Internet Explorer 7

It looks like you are missing a </tr> for the one in bold below.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Maugosia Sycz - portretten</title>
<link href="../../sycz2011_main.css" rel="stylesheet" type="text/css" />
</head>
<body bgcolor="#CCCCCC" topmargin="0" marginheight="0">
<table width="1000" border="0" align="center" cellpadding="0" cellspacing="0" bordercolor="#FFFFFF">
<tr height="100"><td width="100" height="50" bgcolor="#333333"><div align="left"><img src="../syczlogo2011.jpg" width="177" height="53" /></div></td>
<td bgcolor="#CCCCCC">
<table width="800" border="0" align="center" cellpadding="0" cellspacing="0">
            <tr>
              <td width="148"><div align="center">
                <h4><a href="../bloemen/sycz_bloemen.html">BLOEMEN</a></h4>
                </div></td>
              <td width="2" align="center"><p>|</p></td>
              <td width="148"><div align="center"><a href="../landschappen/sycz_landschappen.html">LANDSCHAPPEN</a></div></td>
              <td width="2" align="center"><p>|</p></td>
              <td width="148"><div align="center">
                <h4><a href="../interieurs/sycz_interieurs.html">INTERIEURS</a></h4>
              </div></td>
              <td width="2" align="center"><p>|</p></td>
              <td width="148"><div align="center">
                <h4>PORTRETTEN</h4>
              </div></td>
              <td width="2" align="center"></td>
              <td width="160"><div align="center">
                <p>&nbsp;</p>
              </div></td>
            </tr>
</table>
</td>
<tr height="800"><td width="200" bgcolor="#999999" valign="top">
<table width="180" cellpadding="5">
            <tr height="30">
               <td><a href="../../index.html" style="color:#CCCCCC">HOME</a></td>
            </tr>
            <tr height="30">
              <td><a href="../profiel.html" style="color:#CCCCCC">OVER MAUGOSIA SYCZ</a></td>
            </tr>
            <tr height="30">
              <td><a href="../exposities.html" style="color:#CCCCCC">EXPOSITIES</a></td>
            </tr>
            <tr height="30">
              <td><a href="../cursussen.html" style="color:#CCCCCC">CURSUSSEN</a></td>
            </tr>
</table>
</td>
<td bgcolor="#CCCCCC">
<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "CCCCCC", true );
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->
</td>
</tr>
<tr height="200"><td width="200" bgcolor="#999999" valign="top"></td><td width="800" bgcolor="#CCCCCC" valign="top"></td></tr>
</table>
</body>
</html>

Try the following:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    <title>
      Maugosia Sycz - portretten
    </title>
    <link href="../../sycz2011_main.css" rel="stylesheet" type="text/css" />
  </head>
  <body bgcolor="#CCCCCC" topmargin="0" marginheight="0">
    <table width="1000" border="0" align="center" cellpadding="0" cellspacing="0" bordercolor="white">
      <tr height="100">
        <td width="100" height="50" bgcolor="#333333">
          <div align="left">
            <img src="../syczlogo2011.jpg" width="177" height="53" />
          </div>
        </td>
        <td bgcolor="#CCCCCC">
          <table width="800" border="0" align="center" cellpadding="0" cellspacing="0">
            <tr>
              <td width="148">
                <div align="center">
                  <h4>
                    <a href="../bloemen/sycz_bloemen.html">BLOEMEN</a>
                  </h4>
                </div>
              </td>
              <td width="2" align="center">
                <p>
                  |
                </p>
              </td>
              <td width="148">
                <div align="center">
                  <a href="../landschappen/sycz_landschappen.html">LANDSCHAPPEN</a>
                </div>
              </td>
              <td width="2" align="center">
                <p>
                  |
                </p>
              </td>
              <td width="148">
                <div align="center">
                  <h4>
                    <a href="../interieurs/sycz_interieurs.html">INTERIEURS</a>
                  </h4>
                </div>
              </td>
              <td width="2" align="center">
                <p>
                  |
                </p>
              </td>
              <td width="148">
                <div align="center">
                  <h4>
                    PORTRETTEN
                  </h4>
                </div>
              </td>
              <td width="2" align="center"></td>
              <td width="160">
                <div align="center">
                  <p>
                     
                  </p>
                </div>
              </td>
            </tr>
          </table>
        </td>
      </tr>
      <tr height="800">
        <td width="200" bgcolor="#999999" valign="top">
          <table width="180" cellpadding="5">
            <tr height="30">
              <td>
                <a href="../../index.html" style="color:#CCCCCC">HOME</a>
              </td>
            </tr>
            <tr height="30">
              <td>
                <a href="../profiel.html" style="color:#CCCCCC">OVER MAUGOSIA SYCZ</a>
              </td>
            </tr>
            <tr height="30">
              <td>
                <a href="../exposities.html" style="color:#CCCCCC">EXPOSITIES</a>
              </td>
            </tr>
            <tr height="30">
              <td>
                <a href="../cursussen.html" style="color:#CCCCCC">CURSUSSEN</a>
              </td>
            </tr>
          </table>
        </td>
        <td bgcolor="#CCCCCC">
          <!--START SIMPLEVIEWER EMBED.-->
          <script type="text/javascript" src="svcore/js/simpleviewer.js">
          </script> <script type="text/javascript">
            //<![CDATA[
                      jQuery(document).ready(function () {
                      SV.simpleviewer.load("sv-container", "100%", "100%", "CCCCCC", true );
                      });
            //]]>
          </script>
          <div id="sv-container"></div>
          <!-- END SIMPLEVIEWER EMBED -->
        </td>
      </tr>
      <tr height="200">
        <td width="200" bgcolor="#999999" valign="top"></td>
        <td width="800" bgcolor="#CCCCCC" valign="top"></td>
      </tr>
    </table>
  </body>
</html>
Mike Richards
SimpleViewer Support Team.

Re: Thumbnails not shown in Internet Explorer 7

Thanks; I've tried this code but still the same problem occurs.
Is there an address where I can send some screenshots? This might help.

Re: Thumbnails not shown in Internet Explorer 7

What flash version are you using in IE7? You could use something like dropbox or screenshots.cc to post a screenshot.

Mike Richards
SimpleViewer Support Team.

Re: Thumbnails not shown in Internet Explorer 7

Hi Mike,

I'm using Flash player 10,2,152,32.

I've stored a screenshot from FireFox (correct):
[img]http://www.screenshots.cc/photos/thumb/49832-byy5s.jpg[/img]

And 2 images (top-bottom) from IE7 (incorrect):
[img]http://www.screenshots.cc/photos/thumb/49833-g3hdj.jpg[/img]
[img]http://www.screenshots.cc/photos/thumb/49834-r928b.jpg[/img]
As you can see, the main image fills the screen, and thumbnails are not visible.

All images were made on the same PC.

Re: Thumbnails not shown in Internet Explorer 7

Your gallery is using the nonFlash version in IE7, try uninstalling flash and reinstalling it.

Mike Richards
SimpleViewer Support Team.

Re: Thumbnails not shown in Internet Explorer 7

Thanks for this suggestion; after reinstalling the Flash player, the same issue still occurs however.
It may be an issue that has to do with my PC settings. If I could be confident this is not likely to occur on other computers, that would already be helpful for me.

Re: Thumbnails not shown in Internet Explorer 7

after reinstalling the Flash player, the same issue still occurs however.

Note that each browser requires it's own Flash player installation. Test you have Flash installed in IE7 by visiting this URL using IE7: http://kb2.adobe.com/cps/155/tn_15507.html

Felix Turner
SimpleViewer Support Team.

Re: Thumbnails not shown in Internet Explorer 7

This seems to work, great!
Thanks for all your help!