Topic: Pics not visable

Hallo there,

Just changed the site of a mate of mine,

http://www.arthurstattoosneek.nl/

I wanted to use the autoviewer for his pictures, im working with Dreamwever CS3,
For the pics on a page i'm using the folowing code.

_________________________________________________________________________________________________

<?xml version="1.0" encoding="UTF-8"?>
<gallery frameColor="000000" frameWidth="10" imagePadding="20" displayTime="6" enableRightClickOpen="true">
<image>
   <url>shop/1.jpg</url>
   <caption></caption>
   <width>403</width>
   <height>550</height>
</image>
<image>
   <url>shop/2.jpg</url>
   <caption></caption>
   <width>750</width>
   <height>550</height>
</image>
<image>
   <url>shop/3.jpg</url>
   <caption></caption>
   <width>403</width>
   <height>550</height>
</image>
<image>
   <url>shop/4.jpg</url>
   <caption></caption>
   <width>750</width>
   <height>550</height>
</image>
<image>
   <url>shop/5.jpg</url>
   <caption></caption>
   <width>403</width>
   <height>550</height>
</image>
<image>
   <url>shop/6.jpg</url>
   <caption></caption>
   <width>750</width>
   <height>550</height>
</image>
<image>
   <url>shop/9.jpg</url>
   <caption></caption>
   <width>403</width>
   <height>550</height>
</image>
</gallery>

_______________________________________________________________________________________________

I previewed the site in CS3, everything's fine, I can see al the pics, after uploading them on the site I only see the 1st, 5th and the 7th (I removed pic 7 and 8, thats why it jump from 6 to 9)

http://www.arthurstattoosneek.nl/avshop/shop.html

One the other pages i use the autoviewer I got the same problem

http://www.arthurstattoosneek.nl/atrswerk.html

Can someone tell me what i did wrong?

Thx

Kingpin

Re: Pics not visable

Stupid stupid stupid,

Some of my pic had the wrong name .JPG and it had to be .jpg.

Works as a dream  cool

Re: Pics not visable

Help please.
I have built a site using autoviewer extensively throughout. The images show fine locally, but when uploaded just x's appear across all.
I have looked at the support FAQ's and the naming is fine.
I've tested in firefox and IE, both have the same issues.
Link here http://rogerdoreyphotography.co.uk/experimental.html
Any ideas very gratefully received.
sad

Re: Pics not visable

think I might have placed in wrong place, so this post has been relocated
Oops

Re: Pics not visable

@jaytee07
Please see my reply here: http://www.simpleviewer.net/forum/viewt … 448#p35448

Steven Speirs
SimpleViewer Support Team.

Re: Pics not visable

I have the same issue but I want to embed the swf file and not use the index.html file . The code is below

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <title>Photography Gallery | Photo Gallery - Photojenic Life</title>
  <meta name="keywords"

content="photography,photographer,wedding,portraits,Witney,Oxford,Oxfordshire

" />
    <script type="text/javascript" src="dropdowntabs.js"></script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-12012789-2']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript';

ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' :

'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0];

s.parentNode.insertBefore(ga, s);
  })();

</script>

  <link rel="stylesheet" type="text/css" href="style.css" />
</head>

<body>

<div id="wrap">

<!--LOGO-->   
<div id="logo" class="logo">
<img src="assets/logo.gif" width="350" height="75" alt="Photojenic Life -

Photography in West Oxfordshire" /></div>

<!--MENU TABS-->
<div id="glowmenu" class="glowingtabs">
<ul>
<li><a href="index.html" title="Home"><span>Home</span></a></li>
<li><a href="aboutjen.html" title="About Jen" rel="dropmenu1_d"><span>About

Jen</span></a></li>
<li><a href="photogallery.html" title="Photo Gallery"

rel="dropmenu2_d"><span>Photo Gallery</span></a></li>
<li><a href="photoservices.html" title="Photographic Services"

rel="dropmenu3_d"><span>Photographic Services</span></a></li>
<li><a href="contact.html" title="Contact"><span>Contact</span></a></li>
</ul>
</div>
<br style="clear: left;" />
<br class="IEonlybr" />


<!--1st drop down menu -->                                                   
<div id="dropmenu1_d" class="dropmenudiv_d" style="width: 152px;">
<a href="testimonials.html" title="Testimonials">Testimonials</a></div>


<!--2nd drop down menu -->                                               
<div id="dropmenu2_d" class="dropmenudiv_d" style="width: 152px;">
<a href="weddinggallery.html" title="Wedding Photography">Wedding

Photography</a>
<a href="portraitgallery.html" title="Portrait Photography">Portrait

Photography</a>
<a href="wildlifegallery.html" title="Wildlife Photography">Wildlife

Photography</a>
<a href="commercialgallery.html" title="Commercial Photography">Commercial

Photography</a></div>

<!--3rd drop down menu -->                                               
<div id="dropmenu3_d" class="dropmenudiv_d" style="width: 152px;">
<a href="weddingphotography.html" title="Wedding Photography">Wedding

Photography</a>
<a href="portraitphotography.html" title="Portrait Photography">Portrait

Photography</a>
<a href="commercialphotography.html" title="Commercial

Photogrpahy">Commercial Photogrpahy</a></div>

<script type="text/javascript">
//SYNTAX: tabdropdown.init("menu_id", [integer OR "auto"])
tabdropdown.init("glowmenu", "auto")
</script>

<!--MAIN CONTENT-->
<div id="main" class="main">
<div class="columnleft">
<br />
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"

codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.c

ab#version=9,0,28,0" width="1100" height="500" id="tech" align="middle">     
    <param

name="movie"value="http://www.photojeniclife.co.uk/website/flash/gallerys/wed

dings/cooper/viewer.swf" />       
    <param name="quality" value="high" />     
    <param name="wmode" value="transparent"/>
<embed

src="http://www.photojeniclife.co.uk/website/flash/gallerys/weddings/cooper/v

iewer.swf" quality="high" width="1100" height="500" quality="high"

align="middle"

pluginspage="http://www.adobe.com/shockwave/download/download.cgi?

P1_Prod_Version=ShockwaveFlash" type-application/x-shockwave-flash"

wmode="transparent"> 
</embed>
</object>

<!--FOOTER-->
<div class="footerline"><hr width="1100" color="#FFFFFF" size="1" /></div>
<div class="footer"><a href="http://www.facebook.com/pages/Standlake-United-

Kingdom/PhotoJenic-Life/193133594686" title="Facebook | PhotoJenic Life"

target="_blank"><img src="assets/facebook.gif" width="228" height="80"

border="0" /></a><a href="http://twitter.com/PhotoJenicLife"

title="PhotoJenic Life (PhotoJenicLife) on Twitter" target="_blank"><img

src="assets/twitter.gif" width="228" height="80" border="0" /></a><a

href="http://www.linkedin.com/companies/1171333/PhotoJenic+Life?

trk=pro_other_cmpy" title="PhotoJenic Life - Company Profile | LinkedIn"

target="_blank"><img src="assets/linkedin.gif" width="228" height="80"

border="0" /></a><a href="http://photojeniclife.us2.list-

manage.com/subscribe?u=403893d5543783b50e1670242&id=2fa2f993b4"

title="PhotoJenic Life Mailing List" target="_blank"><img

src="assets/newsletter.gif" width="200" height="80" border="0" /></a><a

href="http://www.photoboxgallery.com/3014190" title="PhotoJenic Life photo

gallery - a photo gallery powered by Photobox" target="_blank"><img

src="assets/shop.gif" width="216" height="80" border="0" /></a></div>

<div class="footerline" style="width:1000px;"><a

href="mailto:info@photojeniclife.co.uk" target="_blank">Email:

info@photojeniclife.co.uk</a><br />Telephone: 07974426659.</br>All images

featured at Photojeniclife.co.uk are copyright Jennifer Kelly</p></div>
</div>


</body>
</html>

Re: Pics not visable

Please post the URL of the page whose code you posted into which the gallery is embedded.
It would be much easier to debug if I saw the page in action.

What exactly do you see (or not see) and is it the same in different browsers?
If different browsers display your page differently, then try validating your page using the W3C Markup Validation Service and then fix any errors (if any) that are reported.

Also, you could try using the recommended embedding code found here: http://simpleviewer.net/autoviewer/supp … dding.html

Steven Speirs
SimpleViewer Support Team.

Re: Pics not visable

Steven Speirs wrote:

Please post the URL of the page whose code you posted into which the gallery is embedded.
It would be much easier to debug if I saw the page in action.

What exactly do you see (or not see) and is it the same in different browsers?
If different browsers display your page differently, then try validating your page using the W3C Markup Validation Service and then fix any errors (if any) that are reported.

Also, you could try using the recommended embedding code found here: http://simpleviewer.net/autoviewer/supp … dding.html

yes not a problem the url is http://www.photojeniclife.co.uk/website/cooper2.html. I can only see the controls but no images

I did look through it and couldn't make it work unless I am doing it completely wrong.

Last edited by photojenic (2011-06-01 13:14:03)

Re: Pics not visable

Relative paths are relative to the HTML document containing the SWF file.
In your case, this happens to be: http://www.photojeniclife.co.uk/website/cooper2.html
The gallery's XML file (http://www.photojeniclife.co.uk/website/flash/gallerys/weddings/cooper/gallery.xml) contains relative paths to the images, eg.

<url>images/large/_7619613996.jpg</url>

Therefore, AutoViewer is looking for the above image at the location:
http://www.photojeniclife.co.uk/website/images/large/_7619613996.jpg but it exists here:
http://www.photojeniclife.co.uk/website/flash/gallerys/weddings/cooper/images/large/_7619613996.jpg
Change the paths to the images in the XML file and your images should be displayed OK.
Either use absolute paths or relative paths such as:

<url>flash/gallerys/weddings/cooper/images/large/_7619613996.jpg</url>
Steven Speirs
SimpleViewer Support Team.

Re: Pics not visable

Hi Steven,

Thank you for the above but unfortunately it isn't working. I have changed all of the paths to absolute and relative but the images are still not appearing. I have had a look at the SWF file on my computer and it now has white X's instead of the images. Any ideas to what I have done wrong? smile

Thanks for all your time so far

Jen

Last edited by photojenic (2011-06-02 06:33:11)

Re: Pics not visable

Replace your embedding code with the following to allow AutoViewer to find your gallery's XML file:

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="1100" height="500">
    <param name="movie" value="http://www.photojeniclife.co.uk/website/flash/gallerys/weddings/cooper/viewer.swf?xmlURL=flash/gallerys/weddings/cooper/gallery.xml" />
    <param name="quality" value="high" />
    <param name="wmode" value="transparent" />
    <embed src="http://www.photojeniclife.co.uk/website/flash/gallerys/weddings/cooper/viewer.swf?xmlURL=flash/gallerys/weddings/cooper/gallery.xml" width="1100" height="500" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" wmode="transparent"></embed>
</object>
Steven Speirs
SimpleViewer Support Team.

Re: Pics not visable

Steven,

That has done the trick big_smile Thank you so much for your help and patience

Jen