Topic: Embed gallery at my website


I've tried embedding a compact gallery in my existing website, but it keeps saying 'Gallery xml not found'  sad
What am I doing wrong? Cause I want to make a dropdown menu with several albums by embedding the code.

This is the website. http://www.christelvanderbroeckedelsmid … ingen.html

Thanks in advance,

Last edited by Laura81 (2011-03-07 20:23:10)

Re: Embed gallery at my website

I've tried all evening with several codes, but now I don't even see the gallery.
I really don't know what I'm doing wrong.

http://www.christelvanderbroeckedelsmid … index.html

http://www.christelvanderbroeckedelsmid … ingen.html

http://www.christelvanderbroeckedelsmid … anden.html

Last edited by Laura81 (2011-03-07 22:23:30)

Re: Embed gallery at my website

Have you looked at the embedding guide: … dding.html ?

Felix Turner
SimpleViewer Support Team.

Re: Embed gallery at my website

Ofcourse, several times, but I'm not sure which directions to use.
I want to make a html page for every item in my dropdown menu (for example,; rings, necklaces, earpieces, etc.)
Then I want to place the embed code for each album into the html pages and upload each galleryfolder to my website.

I've tried this but it won't work. Somewhere, something is going wrong. But what?

Re: Embed gallery at my website

The second page: http://www.christelvanderbroeckedelsmid … ingen.html
... is looking for the 'svcore' folder to be located here:
... and it does not exist.
Upload the 'svcore' folder into your 'test' directory and the gallery should be displayed.

If uploading several separate galleries, you may want the galleries to share an 'svcore' folder (rather than upload it several times in different locations).  If so, this may help: … tml#svcore

Steven Speirs
SimpleViewer Support Team.

Re: Embed gallery at my website

I've tried again, but it says gallery xml not found. http://www.christelvanderbroeckedelsmid … ingen.html

Also with the svcore folder in the test folder it says gallery xml not found  sad
What's the problem with the gallery xml? Because after that has been solved, I can make the other gallery's the same way.

Re: Embed gallery at my website

If you do not specify a specific location for your XML file, SimpleViewer will look for one (named 'gallery.xml') in the same directory as the HTML file.
Your HTML file is http://www.christelvanderbroeckedelsmid … ingen.html so SimpleViewer expects http://www.christelvanderbroeckedelsmid … allery.xml to exist and it does not.
You can either relocate your XML file or specify the path to it using the 'galleryURL' flashvar. … tml#params

Your embedding code would then look something like:

<script type="text/javascript" src="ringen/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars={};
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "600", "600", "FFFFFF", true, flashvars);
<div id="sv-container"></div>
Steven Speirs
SimpleViewer Support Team.

Re: Embed gallery at my website

Thanks for your help.
I've entered the BaseURL, but now it shows a cross, no photo's....

Re: Embed gallery at my website

You are now using:


... so the XML file can be found but the imageURL, thumbURL and linkURL entries in the XML file are incorrect.
All relative paths are relative to the HTML document into which SimpleViewer is embedded (not relative to the XML file itself).
See here for details: … ml#pathing

Knowing where your images are located, an entry in you XML such as:

<image imageURL="images/Ring goud 1.jpg" thumbURL="thumbs/Ring goud 1.jpg" linkURL="images/Ring goud 1.jpg" linkTarget="_blank">

... should be:

<image imageURL="ringen/images/Ring goud 1.jpg" thumbURL="ringen/thumbs/Ring goud 1.jpg" linkURL="ringen/images/Ring goud 1.jpg" linkTarget="_blank">

However, rather than change all the paths in the XML file, you could use the baseURL option: … .html#html
If set, all relative URLs to gallery content (including images, thumbnails and XML) will be relative to this URL. This includes the galleryURL and presetURL options.
Instead of:


... use:

Steven Speirs
SimpleViewer Support Team.

Re: Embed gallery at my website

Thank you very much for your help! It works  big_smile