Topic: Running Gallery on Local Machine

Hello,

I'm creating a project for which I need to run my gallery locally. The final project will NOT be hosted online. So far everything works well when I run it on my mac or throw it online. However, when I run the gallery locally on Windows, it's not opening the external links I specified in "gallery.xml."  In researching this problem, I've seen that this is common - security settings shut down the functionality when run locally, but work fine when the swf is accessed online.

Is there anyway to get around this? I NEED the gallery to work locally for this project. 

I appreciate any help you can provide.

Thanks for your time.

Re: Running Gallery on Local Machine

I've seen that this is common - security settings shut down the functionality when run locally, but work fine when the swf is accessed online... Is there anyway to get around this? I NEED the gallery to work locally for this project.

I don't think you are going to find any joy on this one, as it wouldn't be much of a security measure if it could just be turned off. The other option would be to put the links into the HTML instead of the flash.

Mike Richards
SimpleViewer Support Team.

Re: Running Gallery on Local Machine

However, when I run the gallery locally on Windows, it's not opening the external links I specified in "gallery.xml."

Try using a different browser or tweaking the security settings in the browser.

Felix Turner
SimpleViewer Support Team.

Re: Running Gallery on Local Machine

Mike Richards wrote:

it wouldn't be much of a security measure if it could just be turned off.

Ha, good point wink

Thank you both for your feedback. I ended up embedding the gallery swf into a second swf, through which I was able to create functioning links. Success!