Topic: Loading Problems on iPhone

I'm using simpleviewer as an embedded viewer inside my custom website template. It works fine with IE, Firefox, Chrome, and Opera but completely disappears when I view the same page on an iPhone/iPod touch. The only thing that shows up is the button to go full screen. See the page here:

http://quicky2g.sytes.net/test

Any ideas why this is happening?

Thanks in advance for any help.

Re: Loading Problems on iPhone

Here is a screenshot comparison between what shows up on the iPhone and what shows up in a regular browser:

http://quicky2g.sytes.net/embeddedproblem/

Re: Loading Problems on iPhone

Your thumbnails are there if you scroll down far enough.
This is most likely due to your gallery having large fixed dimensions of 835px x 810px .

Steven Speirs
SimpleViewer Support Team.

Re: Loading Problems on iPhone

I set the fixed dimensions so it would fit inside my website template. If I set the dimensions to a percentage, the embedded simpleviewer seems to change size based on the size of the browser and not the template div it's inside. Any ideas?

On the mobile browser (my iPhone) I see now that the thumbnails load, but the first image only auto loads on a PC browser and not my iPhone. Any ideas?

Also, the embedded simpleviewer seems to be taking control of my zoom functionality on the iPhone. My template is designed to have a minimum width of 1040px and be centered so that no matter what the size of the browser (Like an iPhone), there will always be a minimum width and my website will look the same on every browser. If I try setting the embedded simpleviewer to a percentage width, it applies to the width of the whole page and not the div it's inside for my template...making simpleviewer look different in every screen size I use like iPhone, laptop, desktop, etc. One of the side effects on the smaller screen seems to be the zoom functionality doesn't work. All my other pages I can zoom in and out of the page, but not on the test page I have with the embedded simpleviewer. Any ideas?

Re: Loading Problems on iPhone

The first issue may be caused by a layout bug which we will look into further.

By default, the mobile player initially loads a page of thumbnails rather than an image.
To bypass the thumbnail page and have the first image loaded automatically, use firstImageIndex="0" in the gallery's XML file.

Zooming is currently disabled on gallery pages in order to not interfere with the swiping motion.

Steven Speirs
SimpleViewer Support Team.