Topic: Since upgrade from 1.5 to 2, the viewer got much slower

Ever since I upgraded to the newest simpleviewer version and bought pro, my galleries have been very slow to load.  The images I am uploading are full resolution photographs, but they are much smaller when viewing the slideshow.

You can see an example of a large slow gallery at http://jadedfamily.com/?p=1205.

You can see an example of an older gallery using the 1.5 version at http://jadedfamily.com/?p=804.

I would be a very happy man if the new galleries loaded as quickly as the old ones, any help would be greatly appreciated as I am not extremely tech savvy.

Thanks,
Jeremy

Re: Since upgrade from 1.5 to 2, the viewer got much slower

The images in your newer gallery look like they are twice as large as the images in the old gallery, 1.2 MB vs 600 KB. I would suggest reducing the size of your images, so that they are around 40 to 200 KB for optimum speed.

Mike Richards
SimpleViewer Support Team.

Re: Since upgrade from 1.5 to 2, the viewer got much slower

I don't think that is it, take a look at http://jadedfamily.com/?p=1205 now, I have two galleries up using the same exact pictures.  The gallery using the new software is significantly slower than the one with the old software.

I need to upload the full resolution images, and the old version of simple viewer had no problem with this.  Am I doing something wrong, or is the new version just much slower than the old version?

Last edited by jdubo79 (2011-03-18 02:36:13)

Re: Since upgrade from 1.5 to 2, the viewer got much slower

The two galleries in your 1205 post are not using the same image files.

http://jadedfamily.com/wp-content/uploa … G_0006.jpg
Your SV 2.1.2 gallery image is 2,592px × 1,944px at 1,032.17 KB

vs

http://jadedfamily.com/wp-content/photo … G_0006.JPG
Your SV 1.5 gallery image is 300px × 225px at 12.5 kb

Mike Richards
SimpleViewer Support Team.

Re: Since upgrade from 1.5 to 2, the viewer got much slower

Thanks for your reply

The images were smaller because in version 1.5 I was linking to the thickbox and not the actual image, now the download link will send you to the actual images and all the images in the two galleries are the same size.  Version 1.5 is still much faster, while 2.0 is still unusably slow.

Last edited by jdubo79 (2011-03-18 11:43:58)

Re: Since upgrade from 1.5 to 2, the viewer got much slower

The XML for the older gallery is still loading the smaller images.

imagePath="http://jadedfamily.com/wp-content/photos/-----/reg/" <filename>IMG_0006.JPG</filename>

http://jadedfamily.com/wp-content/photo … G_0006.JPG


you would need to change the imagePath in the xml to imagePath="http://jadedfamily.com/wp-content/uploads/2011/03/"

Mike Richards
SimpleViewer Support Team.

Re: Since upgrade from 1.5 to 2, the viewer got much slower

The gallery url you gave me is the one that was created by simpleviewer 1.5 when I created gallery files from the folder.  If I go ahead and change the xml file  for this one gallery, that means if I want to create a new gallery using simpleviewer 2, I will also need to create a gallery using simpleviewer 1.5 and link the xml file to the images created by 1.5 when I made the gallery.

Is there anyway to have simpleviewer 2 create the smaller versions of the images to load when browsing the gallery and have my web visitors still be able to click through to the larger file the same way 1.5 did?

Thanks,
Jeremy

Re: Since upgrade from 1.5 to 2, the viewer got much slower

Is there anyway to have simpleviewer 2 create the smaller versions of the images to load when browsing the gallery and have my web visitors still be able to click through to the larger file the same way 1.5 did?

The only way to do this would be to link from the captions as you are with the 1.5 gallery. However instead you could reduce the image size and quality to the right proportions, so file size is much smaller while maintaining relatively large image to display on your site.

Mike Richards
SimpleViewer Support Team.

Re: Since upgrade from 1.5 to 2, the viewer got much slower

Any plans for a fix to change version 2 to work similar to 1.5 in this respect?

Re: Since upgrade from 1.5 to 2, the viewer got much slower

How were you building your v1 galleries? SimpleViewer v1 did not include this functionality by default.

Felix Turner
SimpleViewer Support Team.

Re: Since upgrade from 1.5 to 2, the viewer got much slower

I was creating them through the "WP-SV Viewer Galleries" link under the media drop down.  I would then select the directory I wanted to create the gallery from and hit the "Create Gallery Files For This Folder" button.

Re: Since upgrade from 1.5 to 2, the viewer got much slower

I was still not able to solve this problem.  Any more suggestions as to why this used to work with the old version of simpleviewer and how to fix things so they work now?

Re: Since upgrade from 1.5 to 2, the viewer got much slower

According to the posts above, your v1.5 version of the gallery is loading image files that are much smaller than the v2 version of the gallery. This is why it's loading faster. So the easiest solution is to resize your image files down to something like 1024x768. You can do this automatically using svBuilder-Pro. If you want to use larger versions of the images for download, you will need to upload these in a separate folder and add your links in the captions manually.

BTW both your galleries load pretty fast for me.

Felix Turner
SimpleViewer Support Team.