Topic: Get Object Expected error when using embed code

Below is the embed code I am using to refer to an external gallery.  When I run this I receive an "Object Expected" error and the gallery is not displayed.  Any help would be greatly appreciated.

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.classicrealestate.com/listings/fx1234567/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://www.classicrealestate.com/listings/fx1234567/";
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "100%", "100%", "222222", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

Re: Get Object Expected error when using embed code

what browser/os are you reviving the error in? What is the URL of the page that your are having the issue with?

Mike Richards
SimpleViewer Support Team.

Re: Get Object Expected error when using embed code

Firefox and IE are both reporting the error. The page is just a test page (making sure I can get things to work and...give a friend a hard time) Here is the URL:

http://www.classicrealestate.com/listin … mells.html

Re: Get Object Expected error when using embed code

I am having the same problem: I get a "Error: Expected '}' Code:0" in IE 6 on the PC and the gallery won't load.

Here is the URL: http://www.jebjones.com/colors/index.php

This is the embed code:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
jQuery(document).ready(function () {
SV.simpleviewer.load("sv-container", "900", "70%", "FFFFFF", true );
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

It's a big problem because the site just went live--please help.

Re: Get Object Expected error when using embed code

The gallery is displying fine in my XP virtual machine using IE6, are your copies of IE6 and flash up to date?

Mike Richards
SimpleViewer Support Team.

Re: Get Object Expected error when using embed code

Thanks I figured out my problem about 10 minutes ago--it was a combo of script error from my AddThis buttons and not specifying a TD height. It was working in all browsers for IE (I hate IE!) including FF on the PC so I didn't think about the TD height and just focused on the script error.

Re: Get Object Expected error when using embed code

@tyelving
There is currently a bug in SimpleViewer that will prevent a gallery from being displayed if a baseURL is set back a level from the embedding page.
This will be fixed in the next version.
In the meantime, the workaround is to move your gallery folder ('fx1234567') into your 'TestTab' directory and adjust the baseURL accordingly.

@Fritzen
I do not have IE6 installed but have checked your web page in IETester (IE6) and the gallery displays OK.

Steven Speirs
SimpleViewer Support Team.