Topic: Changing Background Image

Hello I can't seem to get the background to change to the specific image I want.
I have went in and added this line to the gallery.xml, which is a absolute path to my image.

backgroundURL = "http://www.markwag.com/wp-content/uploa … ground.jpg"

I have also tried

backgroundImagePath = "http://www.markwag.com/wp-content/uploa … ground.jpg"

Please let me know what I am not doing correctly

Thank you

Mark Waguespack
http://www.markwag.com/printmaking/

Re: Changing Background Image

backgroundURL is a Pro-only option.
You would need to purchase SimpleViewer Pro and follow these instructions: http://simpleviewer.net/simpleviewer/su … iewer/#pro

Once you have done this, you should be able to edit the gallery by following these instructions: http://simpleviewer.net/simpleviewer/su … ewer/#edit
... and enter the backgroundURL line in the 'Pro Options' text area (rather than by editing the XML file manually, although this should also work).

Try clearing your browser's cache after making any changes.

Otherwise, you could make your gallery's background transparent in order for an HTML/CSS background to show through.

Steven Speirs
SimpleViewer Support Team.

Re: Changing Background Image

Ok so I have upgraded...

I replaced the "web" folder which contains the svcore folder. Previous to this I did not see a svcore folder at all.

I have the option to input information into the Pro Options and I added this

backgroundURL="http://www.markwag.com/wp-content/uploads/2011/03/background.jpg"

but I am still not getting the background image I want.

Here of some screen shot of what I am talking about

http://www.markwag.com/Screen%20shot%20 … 1%20PM.png

http://www.markwag.com/Screen%20shot%20 … 2%20PM.png

Thank you for the response I am getting close!

Re: Changing Background Image

You seem to have copied the contents of simpleviewer_pro_212/web/ into wp-content/plugins/wp-simpleviewer/web/
Instead, you should copy the contents of simpleviewer_pro_212/web/svcore/ into wp-content/plugins/wp-simpleviewer/svcore/

Steven Speirs
SimpleViewer Support Team.

Re: Changing Background Image

Ok... well there was never a svcore folder in wp-content/plugins/wp-simpleviewer

I have placed the svcore folder from the Pro_212 folder in this location now and it still doesn't seem to be working

here is what my folder looks like now...

http://markwag.com/Screen%20shot%202011 … 4%20PM.png

Re: Changing Background Image

If there was never an 'svcore' folder in the 'plugins/wp-simpleviewer' folder, then you must be using an older version of the WP-SimpleViewer WordPress Plugin.

You have 2 options:
(1) If using WP-SimpleViewer v2.0.5 Replace the 'simpleviewer.swf' file currently located at 'wp-content/plugins/wp-simpleviewer/web/simpleviewer.swf' with the 'simpleviewer.swf' file from the SimpleViewer Pro download package 'simpleviewer_pro_212/web/swf/simpleviewer.swf'.
This will work but you will not have the mobile functionality of the latest version (whereby the gallery will be displayed using HTML for mobile devices and browsers that do not have Adobe Flash Player installed).
(2) Otherwise, uninstall the existing WP-SimpleViewer plugin and install the latest version (v2.1.2) from this page http://www.simpleviewer.net/simpleviewe … pleviewer/ and follow the 'Upgrading to SimpleViewer-Pro' instructions on the same page.

Steven Speirs
SimpleViewer Support Team.

Re: Changing Background Image

Thank you, my theme is now interfering with it since I am getting this message.

SimpleViewer requires JavaScript and the Flash Player. Get Flash.

I have tried the standard wordpress template and it works, but would really like to use the edegree theme that I have already spent time customizing. Let me know if there are easy solutions to this like adding some type of call code into the header?

Re: Changing Background Image

I have just installed and activated the eDegree theme and my test SimpleViewer gallery (created with WP-SimpleViewer v2.1.2) is still working OK.
Perhaps you have a plugin that is causing the problem.
Try deactivating your plugins and activating them one at a time (clearing your browser's cache and viewing your gallery each time) to try to find the conflicting one.

Steven Speirs
SimpleViewer Support Team.

Re: Changing Background Image

I got it to work! it wasn't really any other plugin in I am using either I just had to deactivate & reactivate the theme and it ended up working... I am not sure

The only other problem I am having is with this text appearing every time [gallery link="file"]

The steps in which I set up the gallery is to set up the simpleviewer options with the wordpress library, and then insert the wordpress library immediately after. I have tried to research this problem but have only found one instance of it being brought up.

Thanks for all your help.

Re: Changing Background Image

After adding your images in the 'From Computer' tab and clicking 'Save All Changes', the 'Add an Image' pop-up window changes to the newly created 'Gallery' tab.  At this point, close the 'Add an Image' window rather than clicking 'Insert Gallery'.
The 'Insert Gallery' button refers to a WordPress gallery rather than a SimpleViewer gallery and this is what is responsible for adding the [gallery] tag to your post.

Steven Speirs
SimpleViewer Support Team.

Re: Changing Background Image

hi! i am able to change the background of my desired image but the background appears too small in size as compared to the previous one which in turn shows the previous background and a small background which i have changed lying in the middle of the image. How do i increase the size of my new background?

Re: Changing Background Image

How do i increase the size of my new background?

You can define how the background image is scaled to fit the SWF size by using the backgroundScale option.
Possible values are FILL, STRETCH and NONE.
Please see here for details: http://simpleviewer.net/simpleviewer/pr … .html#back

Steven Speirs
SimpleViewer Support Team.