Topic: Persistent slide transition

I'm using a number larger then the slide total for the 'first image index', so I don't get a slide displayed until you click on a thumbnail.  The first slide appears fine, when you click a thumbnail.  However, when you click a different thumbnail, the first slide stays there, behind the next one (showing round it if the second slide is smaller or a different orientation).  That first slide then remains throughout any further transitions, unless you click on the first thumbnail again, in which case it starts behaving properly, and disappearing as it should.
I've this probleme for any transition time.

thanks for you help.

Re: Persistent slide transition

Please post the URL of the gallery so that we can take a look.

Mike Richards
SimpleViewer Support Team.

Re: Persistent slide transition

sorry my gallery isn't in a web site, I can send this by email if you want,

or this is the code:

<?xml version="1.0" encoding="UTF-8"?>

<simpleviewergallery

    maxImageWidth="648"
    maxImageHeight="432"
    imageQuality="80"
    thumbWidth="75"
    thumbHeight="75"
    thumbQuality="90"
    useFlickr="false"
    resizeOnImport="true"
    cropToFit="false"
    indexPageName="portraits.html"
    thumbPosition="RIGHT"
    titlePosition="NONE"
    captionPosition="NONE"
    buttonBarPosition="RIGHT"
    buttonBarVAlign="TOP"
    buttonBarHAlign="RIGHT"
    showNavButtons="false"
    showAutoPlayButton="false"
    showOpenButton="false"
    showFullscreenButton="true"
    buttonBarScale="1"
    buttonBarBackOpacity="0.5"
    buttonBarPadding="20"
    showImageNav="HOVER"
    showToolTips="false"
    imageScaleMode="SCALE_UP"
    showOverlay="ALWAYS"
    imageTransitionType="SLIDE"
    imageFrameStyle="NONE"
    frameWidth="0"
    autoPlayOnLoad="false"
    imagePreloading="PAGE"
    imageClickMode="NAVIGATE"
    thumbColumns="2"
    thumbRows="4"
    thumbNavPosition="BOTTOM"
    captionDropShadow="true"
    flickrTitleFontColor="#FFFF00"
    flickrTitleFontSize="30"
    captionPadding="20"
    imageNumberFontSize="10"
    thumbFrameWidth="0"
    thumbLoadBarHeight="3"
    imageNavStyle="CIRCLE"
    captionFontSize="15"
    thumbHoverFrameWidth="0"
    hideOverlayOnTransition="true"
    lockBottomStack="true"
    galleryStyle="COMPACT"
    stageBorder="0"
    stageHPadding="20"
    stageVPadding="30"
    thumbNavColor="666666"
    thumbNavStyle="BIG"
    backgroundColor="FFFFFF"
    thumbNavSlideTime="3"
    thumbHAlign="RIGHT"
    thumbVAlign="CENTER"
    thumbPadding="10"
    imageTransitionTime="1"
    imageSmoothing="false"
    thumbFrameHoverColor="FFFFFF"
    thumbFrameStyle="SQUARE"
    thumbCornerRadius="100"
    enableMouseWheel="true"
    imageNavScale="1"
    showBigPlayButton="false"
    imageNavBackOpacity="0.5"
    imageNavPadding="10"
    thumbNavPadding="25"
    floatButtonBar="false"
    imageBackColor="FFFFFF"
    thumbNavBackColor="666666"
    thumbNavHoverColor="000000"
    thumbNavBackOpacity="0.1"
    buttonBarBackColor="666666"
    showThumbLoadBar="true"
    showThumbVisited="false"
    thumbDropShadow="true"
    thumbFrameColor="FFFFFF"
    thumbClickShift="2"
    showAutoPlayStatus="false"
    autoPlayThumbs="false"
    stageVAlign="CENTER"
    stageHAlign="CENTER"
    backgroundTransparent="false"
    overlayFadeTime="0."
    useColorCorrection="false"
    galleryHeight="68%"
    imageVAlign="TOP"
    imageNavBackColor="000000"
    imageDropShadow="false"
    imageBackOpacity="0"
    backgroundScale="NONE"
    flashBrightness="2"

>

  <image imageURL="images/1.jpg"
    thumbURL="thumbs/1.jpg"
    linkURL="images/1.jpg"
    linkTarget="_blank">
    <caption><![CDATA[]]></caption>
  </image>

  <image imageURL="images/2.jpg"
    thumbURL="thumbs/2.jpg"
    linkURL="images/2.jpg"
    linkTarget="_blank">
    <caption><![CDATA[]]></caption>

  </image>
  <image imageURL="images/3.jpg"
    thumbURL="thumbs/3.jpg"
    linkURL="images/3.jpg"
    linkTarget="_blank">
    <caption><![CDATA[]]></caption>
  </image>


.
.
.
.

</simpleviewergallery>

thank for all

Re: Persistent slide transition

I'm using a number larger then the slide total for the 'first image index', so I don't get a slide displayed until you click on a thumbnail

This is unsupported and so will probably break stuff. Can you explain the use case why you would want to hide the first image until a thumbnail is clicked? You could do this by using a blank image or by using the SimpleViewer API to show something over the top of the image until an 'svImageChange' event is fired.

Felix Turner
SimpleViewer Support Team.

Re: Persistent slide transition

the probleme is that the first image stays when I click on any Thumbnails or when I use thumbnails Navigation and pointers


the probleme stop only when I click on the first thumbail or when I comme back on the first image with the thumbnail navigation or pointers

I would like a normal slide transition less the the first image who stays  roll

thanks

armel

Last edited by armeloud (2011-04-26 09:31:42)

Re: Persistent slide transition

I've alaways this problem, I'm the only person??
I don't understand where is the bug

help me please

armel

Re: Persistent slide transition

I have been able to replicate this behavior (without using firstImageIndex) and have logged it as a bug.
Thank you for reporting.

Steven Speirs
SimpleViewer Support Team.